IMAGINE Spectral Analysis™
User’s Guide
Table of Contents

Table of Contents ........................................ iii
List of Figures ........................................ xi
List of Tables ........................................ xiii

Introduction ........................................... 1

IMAGINE Spectral Analysis ............................... 3

Introduction ........................................... 3
Processing .............................................. 3
Algorithms .............................................. 4
Task Workflows ........................................ 4
  Anomaly Detection .................................. 5
  Target Detection .................................. 5
  Material Mapping .................................. 5
  Project Wizard ..................................... 5
  Spectral Analysis Workstation..................... 5
Preprocessing .......................................... 6
  Sensor Information .................................. 6
  Bad Bands ........................................... 6
  Spectral Subset .................................... 7
  Spatial Subset ..................................... 8
  Atmospheric Correction ............................ 8
  Minimum Noise Fraction Transform ............... 8
Tour Guide Examples .................................. 9
  Anomaly Detection .................................. 9
  Target Detection .................................. 9
  Material Mapping .................................. 9
  Material Identification ............................ 9
  Spectral Workstation ............................... 9
  Minimum Noise Fraction ............................ 9
  Atmospheric Adjustment ........................... 9
  Additional Tours .................................. 9

Spectral Analysis Theory ............................. 11

Hyperspectral Theory .................................. 13

Introduction ........................................... 13
Imaging Spectroscopy ................................ 13
## Table of Contents

**Atmospheric Correction**
- Atmospheric Modeling ........................................ 17
- Empirical ......................................................... 18
- Linear Mixing .................................................... 19

**Endmembers** .................................................... 19

**Spectrum Libraries** ........................................... 21
- Archive Libraries .............................................. 22
- SITAC .............................................................. 22
- SPECMIN Spectrum Library ................................ 22
- Other Libraries ................................................ 23

**Algorithms and Metrics** ..................................... 25
- Introduction .................................................... 25
- Orthogonal Subspace Projection ............................ 25
- Constrained Energy Minimization Algorithm .......... 25
- Spectral Angle Mapper ....................................... 27
- Spectral Correlation Mapper ................................. 27
- Empirical Line ................................................. 28
- Flat Field ......................................................... 28
  - Modified Flat Field ......................................... 29
- Internal Average Relative Reflectance .................. 29
- Log Residuals .................................................... 30
- Minimum Noise Fraction .................................... 30

**Tour Guides** .................................................... 33

**Spectral Analysis Workstation** ............................. 35
- Introduction .................................................... 35
- Menus ............................................................. 35
  - File ............................................................ 35
  - Edit ............................................................ 37
  - View .......................................................... 37
  - Help ........................................................... 37
- Toolbars .......................................................... 38
- Views .............................................................. 40
- Libraries ........................................................ 41
  - Archive Libraries .......................................... 41
  - Working Libraries ......................................... 41
- Spectrum Plot .................................................. 41
- Preferences ...................................................... 42
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anomaly Detection</td>
<td>43</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>43</td>
</tr>
<tr>
<td><strong>Before You Begin</strong></td>
<td>43</td>
</tr>
<tr>
<td>“Simple Anomaly Detection”</td>
<td>43</td>
</tr>
<tr>
<td>“Bad Band Identification”</td>
<td>43</td>
</tr>
<tr>
<td><strong>Simple Anomaly Detection</strong></td>
<td>44</td>
</tr>
<tr>
<td>Start IMAGINE Spectral Analysis</td>
<td>44</td>
</tr>
<tr>
<td>Choose Input File</td>
<td>45</td>
</tr>
<tr>
<td>Name Output File</td>
<td>46</td>
</tr>
<tr>
<td>Compute Results</td>
<td>46</td>
</tr>
<tr>
<td>Analyze Results—Swipe</td>
<td>47</td>
</tr>
<tr>
<td>Close</td>
<td>49</td>
</tr>
<tr>
<td>Conclusions</td>
<td>49</td>
</tr>
<tr>
<td><strong>Bad Band Identification</strong></td>
<td>49</td>
</tr>
<tr>
<td>Choose Input File</td>
<td>49</td>
</tr>
<tr>
<td>Name Output File</td>
<td>50</td>
</tr>
<tr>
<td>Identify Bad Bands</td>
<td>50</td>
</tr>
<tr>
<td>Save Band Data</td>
<td>55</td>
</tr>
<tr>
<td>Compute Results</td>
<td>55</td>
</tr>
<tr>
<td>Analyze Results—Arrange Layers</td>
<td>56</td>
</tr>
<tr>
<td>Close and Exit</td>
<td>57</td>
</tr>
<tr>
<td>Conclusions</td>
<td>58</td>
</tr>
<tr>
<td><strong>Next</strong></td>
<td>58</td>
</tr>
<tr>
<td>Target Detection</td>
<td>59</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>59</td>
</tr>
<tr>
<td><strong>Before You Begin</strong></td>
<td>59</td>
</tr>
<tr>
<td>“Simple Target Detection”</td>
<td>59</td>
</tr>
<tr>
<td>“Using Library Signatures”</td>
<td>59</td>
</tr>
<tr>
<td>“Spectral Subsetting”</td>
<td>60</td>
</tr>
<tr>
<td><strong>Simple Target Detection</strong></td>
<td>60</td>
</tr>
<tr>
<td>Set Up Project</td>
<td>60</td>
</tr>
<tr>
<td>Identify Target Spectra</td>
<td>61</td>
</tr>
<tr>
<td>Name Output File</td>
<td>62</td>
</tr>
<tr>
<td>Compute Results</td>
<td>62</td>
</tr>
<tr>
<td>Analyze Results</td>
<td>63</td>
</tr>
<tr>
<td>Close</td>
<td>64</td>
</tr>
<tr>
<td>Conclusions</td>
<td>64</td>
</tr>
<tr>
<td><strong>Using Library Signatures</strong></td>
<td>65</td>
</tr>
<tr>
<td>Set Up Project</td>
<td>65</td>
</tr>
<tr>
<td>Select the Target Spectrum</td>
<td>65</td>
</tr>
<tr>
<td>Name Output File</td>
<td>66</td>
</tr>
<tr>
<td>Add Sensor Information</td>
<td>66</td>
</tr>
<tr>
<td>Identify Bad Bands</td>
<td>68</td>
</tr>
<tr>
<td>Compute Results</td>
<td>69</td>
</tr>
<tr>
<td>Compare Results</td>
<td>69</td>
</tr>
<tr>
<td>Add an Overlay</td>
<td>70</td>
</tr>
<tr>
<td>Compare Spectral Plots</td>
<td>72</td>
</tr>
<tr>
<td>Change Spectrum Properties</td>
<td>75</td>
</tr>
<tr>
<td>Create a Working Library</td>
<td>76</td>
</tr>
</tbody>
</table>
Material Mapping

Introduction

Before You Begin

“Simple Material Mapping”
“Compare to On-Line Images”
“Material Mapping with Multiple Signatures”

Simple Material Mapping

Set Up Project
Select Spectra
Name Output File
View Sensor Info
Eliminate Bad Bands
Compute Results
Analyze Results
Compare Output to Truth Image
Arrange Layers
Close
Conclusions

Compare to On-Line Images

Set Up
View USGS Data
Compare Raster Images
Change Attributes
Close
Conclusions

Material Mapping with Multiple Signatures

Set Up Project
Create Spectrum Library
Copy Spectra
Name Output File
Compute Results
Analyze Layers
Open Images
Open Library File
Preliminary Conclusions
Identify Sensor
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove Bad Bands</td>
<td>112</td>
</tr>
<tr>
<td>Map with Scene-Derived Spectra</td>
<td>112</td>
</tr>
<tr>
<td>Set Spectrum Properties</td>
<td>114</td>
</tr>
<tr>
<td>Copy Spectra to Library</td>
<td>114</td>
</tr>
<tr>
<td>Map Spectra</td>
<td>114</td>
</tr>
<tr>
<td>Compare to Example</td>
<td>115</td>
</tr>
<tr>
<td>Change Attributes</td>
<td>117</td>
</tr>
<tr>
<td>Conclusions</td>
<td>118</td>
</tr>
<tr>
<td>Close and Exit</td>
<td>118</td>
</tr>
<tr>
<td>Next</td>
<td>118</td>
</tr>
<tr>
<td><strong>Material Identification</strong></td>
<td>119</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>119</td>
</tr>
<tr>
<td><strong>Before You Begin</strong></td>
<td>119</td>
</tr>
<tr>
<td>“Simple Material Identification”</td>
<td>119</td>
</tr>
<tr>
<td>“Using Spectral Subset”</td>
<td>119</td>
</tr>
<tr>
<td><strong>Simple Material Identification</strong></td>
<td>120</td>
</tr>
<tr>
<td>Set Up Workstation</td>
<td>120</td>
</tr>
<tr>
<td>Open Analysis Image</td>
<td>120</td>
</tr>
<tr>
<td>Identify Bad Bands</td>
<td>121</td>
</tr>
<tr>
<td>Create Working Library</td>
<td>122</td>
</tr>
<tr>
<td>Save Library</td>
<td>123</td>
</tr>
<tr>
<td>Identify Sample</td>
<td>123</td>
</tr>
<tr>
<td>Identify Material</td>
<td>124</td>
</tr>
<tr>
<td>Run Material Identification</td>
<td>125</td>
</tr>
<tr>
<td>Export Results</td>
<td>127</td>
</tr>
<tr>
<td>Conclusions</td>
<td>127</td>
</tr>
<tr>
<td><strong>Using Spectral Subset</strong></td>
<td>128</td>
</tr>
<tr>
<td>Evaluate Spectra</td>
<td>128</td>
</tr>
<tr>
<td>Subset Spectra</td>
<td>129</td>
</tr>
<tr>
<td>Run Material Identification</td>
<td>130</td>
</tr>
<tr>
<td>Evaluate Results</td>
<td>130</td>
</tr>
<tr>
<td>Close and Exit</td>
<td>132</td>
</tr>
<tr>
<td>Conclusions</td>
<td>132</td>
</tr>
<tr>
<td>Next</td>
<td>132</td>
</tr>
<tr>
<td><strong>Spectral Analysis Workstation</strong></td>
<td>133</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>133</td>
</tr>
<tr>
<td><strong>Before You Begin</strong></td>
<td>133</td>
</tr>
<tr>
<td>“Create a Spectral Analysis Project”</td>
<td>133</td>
</tr>
<tr>
<td>“Using an Overlay”</td>
<td>133</td>
</tr>
<tr>
<td><strong>Create a Spectral Analysis Project</strong></td>
<td>134</td>
</tr>
<tr>
<td>Open the Analysis Image</td>
<td>134</td>
</tr>
<tr>
<td>Edit Color/Band Associations</td>
<td>135</td>
</tr>
<tr>
<td>View Sensor Information</td>
<td>135</td>
</tr>
<tr>
<td>Save the Project</td>
<td>136</td>
</tr>
<tr>
<td>Create Spatial Subset</td>
<td>136</td>
</tr>
<tr>
<td>Identify Bad Bands</td>
<td>138</td>
</tr>
<tr>
<td>Create Spectral Subset</td>
<td>141</td>
</tr>
<tr>
<td>Collect a Signature</td>
<td>143</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Change Spectrum Properties</td>
<td>145</td>
</tr>
<tr>
<td>Run Target Detection</td>
<td>146</td>
</tr>
<tr>
<td>Examine Results</td>
<td>147</td>
</tr>
<tr>
<td><strong>Using an Overlay</strong></td>
<td>148</td>
</tr>
<tr>
<td>Open Overlay</td>
<td>149</td>
</tr>
<tr>
<td>Collect Multiple Spectra</td>
<td>149</td>
</tr>
<tr>
<td>Change the Spectrum Plot</td>
<td>151</td>
</tr>
<tr>
<td>Create Spectrum Library</td>
<td>151</td>
</tr>
<tr>
<td>Create Merged Spectrum</td>
<td>152</td>
</tr>
<tr>
<td>Collect AOI Spectrum</td>
<td>153</td>
</tr>
<tr>
<td>Add and View Spectrum</td>
<td>154</td>
</tr>
<tr>
<td>Run Target Detection</td>
<td>155</td>
</tr>
<tr>
<td>Examine Average Spectrum Results</td>
<td>156</td>
</tr>
<tr>
<td>Close and Exit</td>
<td>158</td>
</tr>
<tr>
<td><strong>Conclusions</strong></td>
<td>158</td>
</tr>
<tr>
<td><strong>Next</strong></td>
<td>158</td>
</tr>
<tr>
<td>Minimum Noise Fraction</td>
<td>159</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>159</td>
</tr>
<tr>
<td><strong>Before You Begin</strong></td>
<td>159</td>
</tr>
<tr>
<td>“MNF Transform—Automated Mode”</td>
<td>159</td>
</tr>
<tr>
<td>“MNF Transform—Interactive Mode”</td>
<td>159</td>
</tr>
<tr>
<td><strong>MNF Transform—Automated Mode</strong></td>
<td>160</td>
</tr>
<tr>
<td>Identify Input File</td>
<td>160</td>
</tr>
<tr>
<td>Set MNF Options</td>
<td>162</td>
</tr>
<tr>
<td>Generate Results</td>
<td>165</td>
</tr>
<tr>
<td>Evaluate Results</td>
<td>166</td>
</tr>
<tr>
<td>Compare Results</td>
<td>168</td>
</tr>
<tr>
<td>Conclusions</td>
<td>169</td>
</tr>
<tr>
<td><strong>MNF Transform—Interactive Mode</strong></td>
<td>169</td>
</tr>
<tr>
<td>Digitize and Save AOI</td>
<td>169</td>
</tr>
<tr>
<td>Set MNF Options</td>
<td>170</td>
</tr>
<tr>
<td>Evaluate Results</td>
<td>172</td>
</tr>
<tr>
<td>Set Low-Pass Options</td>
<td>173</td>
</tr>
<tr>
<td>Evaluate Results</td>
<td>175</td>
</tr>
<tr>
<td>View Results Alone</td>
<td>175</td>
</tr>
<tr>
<td>Close and Exit</td>
<td>176</td>
</tr>
<tr>
<td>Conclusions</td>
<td>176</td>
</tr>
<tr>
<td><strong>Next</strong></td>
<td>176</td>
</tr>
<tr>
<td>Atmospheric Adjustment</td>
<td>177</td>
</tr>
<tr>
<td><strong>Introduction</strong></td>
<td>177</td>
</tr>
<tr>
<td><strong>Before You Begin</strong></td>
<td>177</td>
</tr>
<tr>
<td>“IARR”</td>
<td>177</td>
</tr>
<tr>
<td>“Modified Flat Field”</td>
<td>177</td>
</tr>
<tr>
<td>“Empirical Line”</td>
<td>178</td>
</tr>
<tr>
<td>“Evaluating Results”</td>
<td>178</td>
</tr>
<tr>
<td><strong>IARR</strong></td>
<td>179</td>
</tr>
<tr>
<td>Identify Input File</td>
<td>179</td>
</tr>
</tbody>
</table>
## Reference Material

### Data Importing

- Introduction .............................................. 219
- AVIRIS Imagery ........................................ 219
- HYDICE Imagery ....................................... 219
- ENVI Format .......................................... 220
- HDF Format ........................................... 220
- Hyperion Format ................................. 220

### Cuprite Dataset

- Introduction .............................................. 221
- Dataset .............................................. 221

### Bibliography

- Introduction .............................................. 223
- Works Cited ........................................... 223
- Recommended Reading ........................... 226

### Index

- .............................................................. 229
List of Figures

Figure 1: Spectral Response of AVIRIS Channels .................................................. 13
Figure 2: AVIRIS Data in the Spectrum Plot ....................................................... 14
Figure 3: Landsat TM Data in the Spectrum Plot ............................................... 14
Figure 4: Reflectance Spectra ........................................................................... 15
Figure 5: Ternary Model ................................................................................... 20
Figure 6: IMAGINE Spectral Analysis Workstation ........................................... 35
Figure 7: Image E1-E2 Showing Alunite in Green ............................................. 99
Figure 8: USGS Image: cuprite.95.tgif.2.2um.map .......................................... 102
Figure 9: Signature Comparison—MNF Results ............................................... 169
Figure 10: IARR Results .................................................................................. 199
Figure 11: Modified Flat Field Results .............................................................. 202
Figure 12: Empirical Line Results .................................................................... 204
List of Tables

Table 1: Interactive Tools ....................................................... 38
Table 2: Workstation Management Tools .................................. 38
Table 3: Analytical Tools ....................................................... 39
Table 4: Preprocessing Tools .................................................. 39
Introduction
Introduction

The IMAGINE Spectral Analysis module introduces the concepts, data structures, and initial image processing functionalities of imaging spectrometry to the standard ERDAS IMAGINE product. New importers have been developed to address specific hyperspectral sensors and to bring selected Spectrum Libraries into a native ERDAS IMAGINE Spectrum Library structure. Specific industry-recognized preprocessing techniques have been simplified or automated to provide a rational easy-to-use image preprocessing regimen. Several powerful analysis algorithms specific to hyperspectral datasets have been implemented via a simple graphical user interface to produce specific end products for analysis.

An overriding concept of the software is ease of use with an easy-to-follow workflow and intelligent data-derived defaults. This is based upon the philosophy that hyperspectral data is not only going to be used by experts in spectrometry. Also, the imagery is not necessarily best exploited by visual interpretation: the analyst wants derived data or results. The software workflow is designed around a set of tasks. These tasks correspond to the analyst’s specific goals. The specific tasks for this version of the software are Anomaly Detection, Target Detection, Material Mapping, and Material Identification.

The IMAGINE Spectral Analysis module is intended to address the needs of both the remote sensing expert and the novice who simply want a result extracted from a hyperspectral dataset. Each analyst may be looking for different specific materials depending upon his/her interest, but the underlying theory of spectral analysis is, in most cases, the same.

Processing

Spectral analysis is not, and never will be, simple. Aside from the inherent theoretical complexity, the different sensors and data providers ensure that each dataset must be processed a little differently. For example, some datasets are atmospherically corrected, others are not. This precludes simple processing where data in yields an answer out. However, an analysis of the evolution of hyperspectral data processing has suggested a rational standard processing regimen. The IMAGINE Spectral Analysis module provides a framework within which to make the necessary processing decisions and the tools to aid in making those decisions.
Algorithms

The IMAGINE Spectral Analysis software is built around two families of algorithms termed preprocessing and analytical metrics. The preprocessing algorithms consist of corrections or modifications to the input data to prepare it for analysis. The analytical metrics are the algorithms that process the data to produce the desired output image.

Task Workflows

The IMAGINE Spectral Analysis module allows the analyst to access all functionality via two different routes depending upon the objective and/or expertise of the analyst. These approaches include the intuitive easy-to-follow Wizard-based task workflows and the fully-functional, interactive Spectral Analysis Workstation.

Work is stored in a project file (*.iwp). This allows the analyst to define a complete process workflow before any calculations are initiated, provides a record of the decisions and processes which produced a particular output result, and allows the analyst to stop work on a particular project and return at a later time with no work loss.

For the analyst who is not expert in hyperspectral remote sensing, the task workflows provide easy access to spectral analysis tasks. For this approach, the analyst simply determines what his/her objective is. The following objectives, or tasks, are addressed:

- Anomaly Detection
- Target Detection
- Material Mapping
- Material Identification

All spectral analysis software is accessed from the main Classification menu. Click the Classifier icon on the main ERDAS IMAGINE icon panel and then select Spectral Analysis to open the Spectral Analysis menu.
The first menu items are the task workflows, which are described below.

**Anomaly Detection**
This task searches an input image to identify those pixels with a spectral signature that deviates markedly from most other pixel spectra in the image or image subset (the background spectra). The output is a gray scale (similarity) or binary (thresholded) anomaly mask.

**Target Detection**
This task searches an input image for a specific material or materials, termed the target(s), that is suspected to be present in a (very) low concentration. The output is a gray scale (similarity) or binary (thresholded) mask for each input target spectrum.

**Material Mapping**
This task searches an input image for the presence of a specific material or materials based on an input spectrum for each material of interest. The output is a gray scale map image for each input material. The digital number (DN) value of each pixel of the output image is an estimate of the concentration of the material of interest in that pixel of the input image.

**Project Wizard**
This option provides a series of dialogs used in the basic setup of an IMAGINE Spectral Analysis project file. Information includes sensor designation, bad band identification, spectral subset range, spatial subset range, Atmospheric Adjustment settings, and Minimum Noise Fraction (MNF) specification.

**Spectral Analysis Workstation**
This option provides immediate access to the IMAGINE Spectral Analysis Workstation, from which all of the preprocessing tools are available, as well as the various processing tools.
Preprocessing

In addition to the task functionalities, a series of industry-standard preprocessing steps may be prepended to the various tasks and are also available (as is all functionality) from the Spectral Analysis Workstation.

Sensor Information

Bandpass information about the sensor that created the scene under analysis is required for most spectral analysis operations. If all subsequent analysis is to be performed utilizing only scene-derived information, this information is not required.

For example, if you want to search for a particular target material whose signature is extracted from the image itself, no sensor information is required. If, however, the target material signature is taken from a Spectrum Library, this sensor-specific information is required to convolve the library spectra to the bandpasses of the sensor of interest.

Datasets imported with ERDAS IMAGINE sensor-specific importers have this information, termed the Sensor Attribute File (*.saf), already attached to the image file. If the dataset under analysis does not have this file attached, it may be possible to obtain it from the Sensor Attribute Files stored in the <IMAGINE_HOME>/etc directory. If the *.saf file does not exist within the software, it can be created by the analyst.

See "Add Sensor Information" and "Create a Sensor Attribute File" for more information.

If the analyst chooses to use sensor information via a task Wizard, the software checks the dataset under analysis for the presence of a Sensor Attribute File. If there is not one, a warning message is displayed on the screen.

Bad Bands

Bad bands refer to specific data layers that are known to be, or determined to be, numerically corrupt and therefore are not desirable to use in subsequent processing or analysis of the dataset. These layers are defined by their band numbers (for example, band 17) within the dataset of interest.

The Bad Band Selection Tool can be accessed as part of the preprocessing workflow or directly from the Spectral Analysis Workstation. Once the bad bands are identified for a particular image, this information is carried within the project file (*.iwp) and used in all subsequent analysis. Bands identified as bad are indicated in the Spectrum Plot, which is part of the Spectral Analysis Workstation, by greying-out that spectral region.
Signatures collected from the analysis image retain the bad band information if they are stored in a Spectrum Library. When these signatures are used in subsequent analysis work with a different image, the spectral region covered by the signature bad bands is not used in the analysis. If bad bands are also defined for the new analysis image, the unused spectral ranges are defined by the combination of the signature bad band file(s) and the analysis image bad band file.

**Spectral Subset**

You may wish to use only certain bands (spectral ranges) in the analysis. This may be because you have determined that the spectral discriminant for the particular application falls within a particular spectral range, or it may be that a particular spectral range is not useful for processing. You make the decision based on the dataset and the spectra of interest to the analysis. A standard atmospheric spectrum resides within the software to aid in making these decisions.

For example, the water absorbance centered at 1400 nanometers (1.4 microns) is a region of very strong water vapor absorption. Since water vapor is universally present in the atmosphere, most or all of this spectral region is absorbed during transmission through the atmosphere. There is little or no ground signal present in this spectral range. Hence, it is probably not useful to include the bands that fall into this spectral range. However, the water absorbance centered at 940 nanometers (0.94 micron) is an area of weak absorption by atmospheric water vapor. The usability of this spectral range in subsequent analysis depends upon the amount of water vapor present when the scene under analysis was acquired.

For some functions or analyses, it is desirable to separately process the different spectral regions (visible/near infrared [VIS/NIR], shortwave infrared [SWIR], and thermal [TIR]). For example, it is usually considered inappropriate to process the spectral regions together in an MNF transform.

For more information, see “Minimum Noise Fraction”.

Since the information and evaluation considerations are essentially spectral in nature, the Spectral Subset Selection Tool works with data in a spectral fashion. The software translates this spectral information into the bandpass subsets of the dataset under analysis.

*The Spectral Subset Selection Tool can be accessed via Wizards or directly from the Spectral Analysis Workstation.*
Spatial Subset

There may be occasions when you want to work with only part of the area covered by the image in-hand. For example, when using the Orthogonal Subspace Projection (OSP) algorithm to do a Target Detection, the background materials are estimated from the entire scene. If the scene consists of several different areas, it may be desirable to process these different areas separately. This tool aids and allows selection of an area within the image to be used for subsequent processing and analysis.

The Spatial Subset Tool can be accessed via Wizards or directly from the Spectral Analysis Workstation.

Atmospheric Correction

This component of the preprocessing workflow allows adjustment of the DN values of each band (layer) of the input image based on input data from known ground control as supplied by the analyst. The software includes a variety of industry-accepted techniques including scene-derived (Internal Average Relative Reflectance [IARR]) and ground truth-based (Modified Flat Field, Empirical Line) methods. In addition, the software allows plug-in of alternative techniques.

For more information, see "Algorithms and Metrics".

Datasets that have not had Atmospheric Correction applied may still be in their as-received raw DN form. While this is acceptable for in-scene processing, such imagery cannot be compared to or processed with library spectra, which are in reflectance rather than radiance units. In these circumstances, the algorithms in Atmospheric Correction can be used to convert the imagery to relative reflectance, which allows spectra-based processing. Note that it is assumed that sensor corrections (that is, conversion from received signal to at-sensor radiance), have been done either by the receiving station or by the ERDAS IMAGINE importer. Three industry-accepted techniques have been implemented for this step, one of which, IARR, requires no ground control.

The Atmospheric Adjustment Tool can accessed via Wizards or directly from the Spectral Analysis Workstation.

Minimum Noise Fraction Transform

For various external (that is, atmospheric absorption) and internal (that is, bad detector) reasons, the bands in a hyperspectral dataset have differing noise levels (that is, signal to noise ratio [S/N]). It may be desirable to filter or remove those bands. When the bands of a hyperspectral dataset have differing amounts of noise, a standard principal components (PC) transform does not produce components with a steadily increasing noise level. This makes it difficult to select a cutoff point. To achieve a components dataset that does have increasing noise (decreasing S/N), a modified PC transform, termed the Minimum Noise Fraction has been developed (Green et al. 1988, Lee et al. 1990).
The MNF transform produces a set of principal component images ordered in terms of decreasing signal quality. By performing an inverse MNF transform using only the significant images and/or filtering the poor image layers, a full image cube can be reproduced in which the noise has a Gaussian distribution and unit variance (white noise).

The Minimum Noise Fraction Tool can be accessed via the Wizards or directly from the Spectral Analysis Workstation.

Tour Guide Examples

Anomaly Detection
In “Anomaly Detection”, you can learn how to apply IMAGINE Spectral Analysis tools to locate pixels in an image that differ markedly from the remainder of the image. These pixels are termed anomalies.

Target Detection
In “Target Detection”, you can learn how to use IMAGINE Spectral Analysis tools to locate pixels within an image with specific spectral signatures.

Material Mapping
In “Material Mapping”, you can learn how to apply IMAGINE Spectral Analysis to locate a material that occurs in a significant part of an image, and represent it as a map.

Material Identification
In “Material Identification”, you can learn how to apply IMAGINE Spectral Analysis to identify the composition of an unknown pixel or AOI by comparing it to existing spectral signatures.

Spectral Workstation
In “Spectral Analysis Workstation”, you can learn how to use all of the aforementioned tools in a linear workflow, directly from the Spectral Analysis Workstation. This is the most comprehensive approach to spectral analysis offered within the IMAGINE Spectral Analysis module.

Minimum Noise Fraction
In “Minimum Noise Fraction”, you can learn how to apply the Minimum Noise Fraction Tool to remove noise from analysis images.

Atmospheric Adjustment
In “Atmospheric Adjustment”, you can learn about the different filtering methods used to lessen the adverse impact of the atmosphere on analysis.

Additional Tours
In “Additional Tours”, you can learn about a few of the tools included in IMAGINE Spectral Analysis, such as the Sensor Information Tool and the Spectrum Plot.
Many of the sections in the individual Tour Guides assume that you have completed the previous section(s). Files may be created and reused throughout the Tour Guides.
Spectral Analysis Theory
Hyperspectral Theory

Introduction

Optical sensors can be broken into three basic classes: panchromatic, multispectral, and hyperspectral. Multispectral sensors typically collect a few (3-25), wide (100-200 nm), and possibly, noncontiguous spectral bands. Hyperspectral sensors typically collect hundreds of narrow (5-20 nm) contiguous bands. The name, hyperspectral, implies that the spectral sampling exceeds the spectral detail of the target (i.e., the individual peaks, troughs, and shoulders of the spectrum are resolvable). In practice, this is not always fully achieved, particularly for gaseous spectra.

Given finite data transmission and/or handling capability, an operational satellite system must make a trade-off between spatial and spectral resolution. This same trade-off exists for the analyst or data processing facility. Thus, in general, as the number of bands increases there must be a corresponding decrease in spatial resolution. This means that most pixels are mixed pixels and most targets are subpixel in size. It is, then, necessary to develop algorithms which leverage the spectral resolution of the sensor to clarify subpixel targets or components.

Imaging Spectroscopy

Imaging spectroscopy is the science and art of applying the techniques of spectral analysis to a set of contiguous pixels. This set of contiguous pixels is, of course, an image. The image has been captured by a sensor, termed an imaging spectrometer, that records tens or hundreds of bands simultaneously. Each of these bands has a very small bandwidth, typically 10-20 nanometers, and is spaced such that there is a slight overlap between bands.

Figure 1: Spectral Response of AVIRIS Channels
An example of overlap can be seen in data from the NASA/JPL Airborne Visible/Infrared Imaging Spectrometer (AVIRIS) sensor, which is shown in Figure 1 (Green 1995). Because these bands are narrow and overlapping, the data from a single pixel can be plotted to form a continuous spectral plot or profile. An example, again from AVIRIS, is shown in Figure 2. Note the parameters plotted on the X and Y axes. The X axis is the wavelength of the center of the (narrow) band. The Y axis is a physical parameter of the material(s) imaged, which is termed the reflectance.

**Figure 2: AVIRIS Data in the Spectrum Plot**

It has, of course, always been possible to plot the data from multispectral sensors. Figure 3 shows a plot of data from the Landsat TM sensor.

**Figure 3: Landsat TM Data in the Spectrum Plot**

This plot suffers from several inherent limitations.

- The X-axis shows the band number. This is a fairly meaningless designation: band 1 of the Multispectral Scanner (MSS) is different from band 1 of the Thematic Mapper (TM) sensor, and both are different from band 1 of Advanced Very High Resolution Radiometer (AVHRR) or SPOT XS sensors. There is no way to intercompare datasets using this axis designation.

- The Y-axis, digital number or DN value, is similarly meaningless. The magnitude of this value is a function of not only the particular sensor but also the time of day, day of year, cloud cover, etc. Again, we cannot intercompare datasets using this axis designation.
Across the top of the plot in Figure 4 is the bandpass of each band. This is the range of frequencies whose intensity is measured and combined to form each band of the sensor. In comparing the bandpass widths with the width of the absorption features seen in Figure 2, it is obvious that the TM and similar sensors cannot resolve the difference between the materials as well as those seen in Figure 2.

Figure 4: Reflectance Spectra

This is not to say that attempts were not made to resolve the difference between materials. Indeed, the reason that band 7 falls between bands 5 and 6 on the wavelength scale is because band 7 was added late in the TM sensor design due to the interest of geologists in that spectral region.

Similarly, the band ratios developed for quantifying various materials (TM4/TM3 for vegetation; TM5/TM7 for clay minerals) were based on the spectral shapes of the materials of interest. However, there was a large disconnect. The broad-band sensors were collecting 10 or fewer bands while the standards being measured in the laboratory were based on hundreds of bands.
With the advent of the imaging spectrometers, it became possible to bring together, even intercompare, data from the remote sensor and the laboratory spectrometer. Imaging spectrometers also allowed intercomparison of data from different remote sensors. While the narrow bandpass characteristics of the imaging spectrometers allowed precise intercomparisons on the X-axis (frequency), the Y-axis (intensity) proved more complicated.

In the laboratory setting, the absorption spectrum of a material of interest is taken under tightly controlled conditions. The sample chamber, radiation source, and diffraction grating area are all flushed with dry nitrogen to remove the effects of the ambient air—particularly water vapor and carbon dioxide. A null, or empty, channel is measured simultaneously. The instrument is calibrated prior to each measurement. Under such controlled conditions, the measured intensities can be accurately converted to primary physical properties such as percent transmission, absorbance, or reflectance. Conversion to one of these physical parameters allows intercomparison of results taken on different days or in different laboratories. Results can be compiled for universal use.

With data from the remote sensor, correction of the sensor signal to a primary physical property has proven difficult. The first step, conversion of the raw DN value to at-sensor radiance, can be accomplished using the calibration coefficients of the sensor. This step is commonly performed before the data is distributed. Alternatively, the sensor calibration coefficients are available from the data source. At-sensor radiance, however, is affected by the factors such as: time of day and day of year (which control solar illumination), cloud cover (which causes local attenuation), and the overall content of the atmosphere. Incoming solar illumination can be modeled given knowledge of the date and time of data collection. The other parameters are more difficult to model.

The radiation received by the remote sensor has passed through the atmosphere twice. The situation for an airborne sensor is different than for a spaceborne one. An airborne sensor is below the ozone layer, may be below the stratospheric clouds, or could be below the cumulus clouds. The components of the atmosphere have had ample opportunity to absorb and/or scatter the solar radiation. The complexity arises because the composition of the atmosphere varies seasonally (winter vs. summer), regionally (maritime vs. continental), and locally (Gao et al. 1993). Correcting (removing) these atmospheric effects from each scene is required to reduce the scene to the physical parameter reflectance. Only then can different images or images and laboratory spectra be intercompared. This requirement, Atmospheric Correction, is currently a bottleneck in imaging spectroscopy.
**Atmospheric Correction**

The goal of Atmospheric Correction is to completely remove the absorption and scattering effects of the Earth’s atmosphere to allow conversion of the image data to a primary physical parameter: reflectance. The approaches to this fall into two categories: atmospheric modeling and empirical.

**Atmospheric Modeling**

The atmospheric modeling approaches attempt to quantify the exact atmospheric composition at the time of data acquisition and then calculate the probable effects. These models, termed atmospheric transmission codes, have met with considerable success.

For example, the United States Air Force Geophysics Laboratory has steadily evolved its code from LOWTRAN (Low Resolution Atmospheric Transmission Code) through MODTRAN (Moderate Resolution Atmospheric Radiance and Transmittance Model) (Berk 1989) to HITRAN (High Resolution Transmission Molecular Absorption Database). A limiting factor in the use of these codes in their pure form is the requirement of accurate input of the atmospheric composition at the time of data acquisition. Given these inputs, the transmission codes have proven quite accurate in predicting the attenuation effects on the image. With the accuracy of the transmission codes demonstrated, a next step was to investigate ways to estimate the requisite input parameters and evaluate the accuracies attained using these estimates.

Evaluation of transmission code-based Atmospheric Corrections suggests that these corrections may be as good as they can get, given the inevitable variability and uncertainty of the real world. In addition, it is being recognized that (transmission code-based) Atmospheric Correction is appropriately the responsibility of the data vendor. Additionally, imagery from airborne hyperspectral sensors is less easily addressed by the transmission codes due to variations in the altitude of flight for each data acquisition.

There have been a number of correction algorithms based on the transmission codes. These algorithms attempt to estimate some of the requisite parameters either from the data itself or through interaction with the analyst. The ATMosphere REMoval program (ATREM) was developed by the Center for the Study of Earth from Space (CSES) at the University of Colorado for use with AVIRIS imagery (Gao et al. 1996). ATMospheric CORrection (ATCOR) was developed by the German Space Agency (DLR) in conjunction with ERDAS in Germany (Richter 1996). Atmospheric CORrection Now (ACORN) was developed by ImSpec, LLC using MODTRAN 4. Fast Line-of-sight Atmospheric Analysis of Spectral Hypercubes (FLAASH) was developed in part by the Air Force Geophysics Laboratory (Alder-Golden et al. 1998).
All of these modules are commercially available as stand-alone software packages. Any of them can be used in conjunction with IMAGINE Spectral Analysis by using the (atmospherically corrected) output dataset as the analysis image. The empirical-based (ground control point [GCP]) Atmospheric Adjustment within IMAGINE Spectral Analysis can then be used to make the final precision corrections. The dataset supplied with the software, which is named `cuprite_aviris.img`, was corrected by the United States Geological Survey (USGS) using this type of sequential process.

Regardless of whether the model-based correction is done by the data vendor or subsequently, given real-world variability and uncertainty, it can never be perfect. It has been clearly and eloquently shown by Roger Clark (USGS, Denver) and others that minor adjustments using ground control, applied after transmission code-based Atmospheric Correction, enable superior results.

**Empirical**

A second category of approaches to Atmospheric Correction is those based on ground truth inputs. These algorithms rely on the use of one or more spectral control points. A spectral control point is a pixel (or collection of pixels), identifiable in the image, for which the analyst has a library spectrum of that pixel’s material composition without atmospheric effects.

The best way to get such spectral control points is to collect them in the field with a handheld field spectrometer. Alternately, the analyst may have a Spectrum Library from which an approximate spectrum can be selected if the material in the pixel is known. When the spectral control point(s) are identified, they can then be used to correct the entire image. Again, some assumptions are being made.

Several problems present themselves. Every pixel is a mixed pixel at some level and, due to sensor trade-offs (largely data volume), hyperspectral pixels tend to be relatively large: commonly 10-30 meters. At this scale, it is difficult to find pure pixels, especially of naturally occurring materials. This suggests that human-made features such as parking lots, building roofs, or golf courses should be used.

Another assumption is that the material from which the control spectrum is taken is identical to the material being imaged in the pixel. Natural materials are incredibly variable. This can greatly limit the applicability of the compiled Spectrum Libraries and also contributes to the development of specialized libraries, such as SPECMIN from Spectral International, Inc.

Once the issue of defining the spectral control points has been addressed, several similar algorithms exist. The algorithms Empirical Line, Flat Field, and Modified Flat Field are discussed in “Algorithms and Metrics”.

An approach has been proposed for instances in which the analyst has absolutely no auxiliary information. This is the IARR algorithm (See “Internal Average Relative Reflectance”). This algorithm requires several major assumptions and is therefore limited to cases where those assumptions strictly apply. Use of this approach where those assumptions do not apply can lead to very erroneous results.
Linear Mixing

A major assumption underlying many of the imaging spectroscopy algorithms is that of linear mixing. This assumption postulates that the brightness (DN at each wavelength) of an image pixel is a linear combination of the percentage of each endmember and the brightness of a pure sample of that endmember or, mathematically:

\[ \text{DN}_b = \sum f_{nb}EM_{nb} \]

Source: Adams et al. 1986

This assumption is, perhaps, analogous to the assumption of Gaussian distribution which underlies many of the traditional classification algorithms such as Maximum Likelihood and Mahalanobis Distance. While it may be of questionable validity, without it progress is difficult.

The linear mixing model is not strictly applicable for a variety of reasons. This is particularly true in the VNIR and SWIR regions. In the TIR region, the linear assumption has been shown to be significantly more valid (Ramsey et al. 1998). Linear mixing assumes that each photon interacts with only one material. However, multiple-scattering effects in the ground environment are possible, even likely. Photon scatter between vegetation and the ground or within the vegetation layer is common. If a photon interacts with more than one material, the process becomes nonlinear (Farrand and Harsanyi 1995).

It has been shown that a system of nonlinear mixing can be linearized (Ramsey and Christensen 1998). This is commonly done by converting the at-sensor radiance to single scattering albedo (Resmini et al. 1996). Shadow introduces nonlinearity (Olsen et al. 1997) and yet shadow is so ubiquitous that it must be included as an endmember within the overall endmember list for most images.

Endmembers are not constant even within a single scene. As the endmember changes within the scene, its spectrum changes. This mismatch between the defined endmember and its actual form on the ground leads to errors within the matching algorithm. It is commonly assumed that the percent contribution of an endmember to the overall radiance of a pixel is a measure of the pixel-fill of that endmember—this is not a proven conclusion (Shipman and Adams 1987). Many analytical metrics assume that the pixel compositions are uncorrelated—this is not a strictly valid assumption.

Endmembers

The use of endmembers in estimating the composition of an image pixel is analogous to their use in constructing ternary (or higher order) diagrams to explain the variable composition of mixed systems. Consider the ternary system ABC in Figure 5.
This theoretical system is composed of three pure materials: A, B, and C. These are the endmembers of this system. A member of this system composed of 100% material A would plot at the apex of this pyramid; a member with 100% B would similarly plot at point B. Any mixture of these three materials, such as X, falls somewhere within the triangle with %A, %B, and %C determining exactly where. In Figure 5, mixture X is 10% endmember A, 20% endmember B, and 70% endmember C.

In imaging spectroscopy, we have a somewhat analogous situation. We have a number of pixels, mixtures (mixed pixels) such as X in Figure 5, and we would like to know some or all of the endmembers (A, B, and C) and the percentage of some or all of the endmembers in each pixel. Clearly, the identity of the endmembers is crucial to this analysis.

Selecting endmembers for natural systems is exceedingly difficult due to the inherent variability in nature. Consider a geologically oriented analysis. In theory, one would like a spectrum of each pure mineral for the endmember spectra. However, pure minerals rarely occur in nature. Cation and/or anion substitutions are common depending on the origin of the sample. Even with identical composition, the spectrum is affected by the degree of crystallinity for each sample.

Particle size distribution affects the exact shape of the absorbance curve. As the particle size decreases, the absorption bands flatten out and tend to merge with the continuum. For this reason, the USGS, Jet Propulsion Laboratories (JPL), and Advanced Spaceborne Thermal Emission and Reflection Radiometer (ASTER) Spectrum Libraries give spectra of the same mineral at different particle sizes. Other naturally variable factors such as associated phases and degree of weathering, presence or absence of water, and degree of transparency all affect the resultant spectrum.

A similar list of variables can be compiled for vegetation spectra. Variables such as rainfall, presence or absence of minerals in the soil, phase of the growing cycle, sun-leaf orientation, etc. cause changes in the recorded spectrum.
In addition to the various endmember species, there is generally a dark endmember that represents the shade/shadow areas within the scene (See “Linear Mixing”). The shade endmember is nonzero due to atmospheric scattering. This endmember is variable with terrain relief, vegetation type and density, and viewing geometry. As it has a large scattering component, the illumination is shifted toward the blue spectral range.

The central wavelength and relative depth of absorption features are the major diagnostic features in spectral analysis. However, these are not constant for given specie, but vary with a number of factors. Band shape and depth depend on illumination and viewing geometry, particle size, and even the spectral response functions of the sensor itself. The actual signature measured by the sensor is affected by atmospheric and geometric conditions as well as noise. Thus, the signature of a uniform material can have significant variation. Atomic substitutions in the lattice of minerals cause changes to the shape and/or position of the spectral bands. This fact is exploited to measure the distribution of cation substitutions in minerals (Roger Clark, USGS).

Because of these variations and distortions, search and detect algorithms that are highly sensitive to the target spectrum (signature) are compromised or even ineffective. Candidate endmembers must be chosen so as to ensure that their distribution is unimodal and well separated from other endmembers. In practice, it is probably best if endmembers are sampled from the dataset under analysis.

The discussion of endmembers has been largely directed toward the idea of an endmember as a single material such as a mineral (chemical compound) or distinct vegetation species. For some systems or analyses, however, a scene endmember might be a combination of singular materials. For example, in the analysis of a littoral scene, one endmember might be beach. The beach endmember could be 80% silica sand, 15% marine carbonates (sea shells), and 5% vegetable material (seaweed and algae). For another analysis, an airport runway endmember might be defined as 85% cement, 14% tire rubber, and 1% a strong absorption band from spilled aviation fuel. Either of these compound endmembers could be defined by a single spectrum and represent a component of the system.

Spectral signatures are required for analysis of hyperspectral images. They provide the endmembers, Target Detection, and Material Mapping signatures, and input materials for Material Identification. The spectral signature is the information that is used in classifying a pixel.
Because of this primary role of spectral signatures, efforts have been made over the past decade to compile databases, termed Spectral Libraries, of the spectra of known materials (Clark et al. 1993b). These libraries include human-made materials, pure minerals, site-specific minerals, pure vegetation stands, and various mixed-composition spectra. Libraries have been compiled of laboratory signatures taken with spectrometers under tightly controlled conditions, handheld field spectrometers in both natural and controlled areas, and from remote sensing images (scene-derived spectra). Many of these libraries are available to the public or selected researchers.

**Archive Libraries**

Several such Spectrum Libraries are included in the IMAGINE Spectral Analysis software package. The USGS and JPL mineral libraries (Grove et al. 1992) have been compiled using standard mineral samples under laboratory analysis conditions (VIS and NIR to SWIR wavelengths). Note that standard implies that the compositions of the pure mineral samples are fully known, although this is not always the case for such compilations. These two libraries are combined with some Johns Hopkins spectrum libraries (dominantly mid-infrared wavelengths) to form the ASTER Spectrum Library.

These three libraries are accessed through the Archive Library window of the Spectral Analysis Workstation. The ASTER and JPL libraries are stored in their original American Standard Code for Information Interchange (ASCII) format and are, thus, slower to access than libraries stored in the ERDAS Spectrum Library *.spl format. If these libraries are accessed routinely, they could be stored as *.spl files for faster access.

**SITAC**

Spectral Information Technology Application Center (SITAC) libraries have been compiled for a number of human-made and other materials. Because these libraries are not freely available to the public, they are not distributed with the IMAGINE Spectral Analysis software. However, users who have access to these data can directly access libraries in the SITAC format by using the option to open a spectrum library file within the Spectral Analysis Workstation Working Library window.

**SPECMIN Spectrum Library**

As mentioned before, many of the library spectra are taken from pure or reference mineral samples. As discussed in “Endmembers”, the inherent variety within nature guarantees that there is spectral variation in the spectrum of a given material from different locations. To address this situation, libraries are being collected from specific localities and applications of interest.
One such library is the SPECMIN Spectrum Library series of minerals and geologic materials, which can be used for all geologic and natural resources applications including precious metals exploration, industrial minerals exploration and characterization, petroleum exploration, geologic mapping, soils characterization and mapping, and environmental site mapping and evaluation, to list only a few. These libraries contain ASD (Analytical Spectral Devices) spectrometer VIS, NIR, and SWIR data as well as Portable Infrared Mineral Analyser (PIMA) SWIR-region only spectra.

SPECMIN also provides the option to construct a special purpose applications library (User Generated Libraries or UGLs), using any type of conventional spectrometer data for the VIS/NIR/SWIR regions, which then can be accessed by ERDAS IMAGINE. This option additionally allows you to create libraries of spectra extracted from high-end multispectral sensors such as ASTER and hyperspectral imaging spectrometers such as Hyperion, AVIRIS, Probe, Short Wavelength Infrared Full Spectrum Imager (SFSI), Compact Airborne Spectrographic Imager (CASI), and Hyperspectral Mapping (HyMap). Existing spectra from these standard libraries or UGLs can be resampled to the spectral configurations of these satellite and airborne sensors.

The SPECMIN libraries and databases contain specific libraries of infrared-active reference minerals (about 2000 spectra), soils, hydrocarbons, mineral deposits, and environmental site case studies. The SPECMIN libraries and databases can be accessed using the option to open a spectrum library file within the Spectral Analysis Workstation Working Library window.

For more information about SPECMIN characteristics and applications, contact:

Spectral International, Inc.
303/403-8383
http://www.specmin.com

Other Libraries

You can access the Arizona State University (ASU) Thermal Emission Spectrum Library by visiting the following URL: http://emma.la.asu.edu/speclib/.

Integrated Spectronics manufactures the PIMA field-portable SWIR spectrometers and the HyMap airborne hyperspectral scanners. They offer a 300-member Spectrum Library. For more information, visit the following URL: http://www.intspec.com/.

A Spectrum Library with components of maritime pine stands and shrublands in central Portugal, including signatures of maritime pine, shrubs of several types (collected in shrublands and in maritime pine stands), pine needle litter, pine slash, forest litter, and soils can be accessed via the following URL: http://storms.cnig.pt/spectrallib.html.

The Opto-Knowledge Systems, Inc. web site contains several spectral libraries, including the Environmental Protection Agency (EPA) library of Hazardous Air Pollutants. It can be accessed at the following URL: http://www.techexpo.com/WWW/opto-knowledge/IS_resources.html.
Algorithms and Metrics

Introduction

This chapter explains the algorithms and metrics associated with the functionality of IMAGINE Spectral Analysis. The software incorporates these methods to provide you with a comprehensive spectral analysis solution from start (importing imagery) to finish (creating output maps). You can also conveniently separate the process into individual tasks, which gives you great flexibility in your analysis.

Orthogonal Subspace Projection

OSP seeks to simultaneously reduce data dimensionality, suppress the background (clutter) signal, and maximize the target spectrum S/N. In this approach, each pixel vector is projected onto a subspace which is orthogonal to the interfering signals; this minimizes the background signal. Simultaneously, this maximizes the S/N of the desired signature. This is important for automatic detection because it reduces the mixed pixel classification problem to detection of an unknown constant in the presence of white noise. If the unknown background signature is estimated from the data itself, this requires that the target spectrum be present in very low concentrations. If, however, the analyst provides the known background spectra, this requirement is relaxed. The OSP technique is very useful for detection of human-made objects in a natural environment.

In addition, it is not necessary to calibrate the input data to reflectance before using this approach—the algorithm operates directly on the measured radiance of each pixel. This obviates the need for Atmospheric Correction. Note that the task workflows that utilize this metric, Anomaly Detection and Target Detection, do not contain an Atmospheric Correction step. For Target Detection, this assumes that the target spectra are taken from the image under analysis. If the target spectra are from a Spectrum Library or a different image, the data must be calibrated to reflectance.

Constrained Energy Minimization Algorithm

The Constrained Energy Minimization (CEM) algorithm attempts to maximize the response of a target spectrum and suppress the response of the unknown background signature(s). The algorithm is not dependent on the material of interest occurring with very low probability as is OSP (Harsanyi 1994). Thus, it is appropriate to the situation where the sought material is a minor component of the scene. It is optimal for detection of distributed subpixel targets such as mineral occurrences or sparse vegetation and does not always perform well on very low probability signatures.
The CEM operator maps targets based on their spectrum without specific knowledge of the background clutter (Nielsen 1998). Pixels that occur in sufficient quantity and with sufficient spectral character are used to define the covariance of the (background) image statistics. Thus, any pixel that is rare is not nulled and may result in a false positive (Jacobsen et al. 1998).

The performance of the CEM technique for subpixel signature detection is dependent upon the structure of the image correlation matrix. A subset of the principal eigenvectors of the data correlation matrix is used to form the background (clutter) matrix. Since most of these eigenvectors do not contribute significantly to the total energy in the hyperspectral scene (or scene subset), a good estimate of the correlation matrix can be obtained by only considering the first $X$ significant eigenvectors, where $X$ is an estimate of the intrinsic dimensionality of the hyperspectral scene under consideration. However, incomplete removal of the spectral background, due to too small of a subset of the principal eigenvectors, may contribute to inaccurate abundance values or false positives.

Because the CEM operator gets its background statistics from the whole image, the algorithm is not optimal for scenes with locally varying statistics. Attempts to continually modify the background covariance matrix introduce new problems, one of which is that the outputs are no longer directly scaled to each other and, hence, pixel values are hard to intercompare. This algorithm may have problems in complicated environments such as urban areas.

The background is estimated once for the whole scene to be analyzed. You can then select subsets to reanalyze (i.e., after a first pass, AOIs can be selected for repeat analysis using the statistics of the more local area).

The standard CEM operator has a unity constraint in that the operator produces a value of one when applied to the signature itself. However, calculated abundance values can be negative or greater than one. The negative values are a result of statistical variations around the assumption of distributed noise with a zero mean. Abundances greater than one can result if the input target spectrum is not entirely pure or of exactly the same composition as pixels within the image. The CEM operator is extremely sensitive to minor differences in the target spectrum. Thus, it is useful for mapping not only different mineral groups, but also for mapping variations within those groups.

A CEM operator developed using the calibrated radiance image gives virtually identical results to those obtained when the dataset is first converted to relative reflectance (Resmini et al. 1997). This, of course, requires a scene-derived target spectrum.
Spectral Angle Mapper

The Spectral Angle Mapper (SAM) algorithm derives the angle formed between a reference spectrum and the image spectrum of each pixel. Each spectrum is treated as a vector in \( N \)-dimensional space, where \( N \) is equal to the number of bands in the image. The resulting angle can vary between 0° and 90°. SAM can also output the result as the cosine of the angle. In this presentation, values vary between zero (0) and one (1), with one representing a best match (Clark et al. 1993c; Gao and Goetz 1991; Yuhas 1992).

The spectral angle is a calculation that permits rapid comparison of the spectral similarity of two spectra. The reference spectra can be either a laboratory or field library spectra, or extracted from the image. This method assumes that the data have been reduced to apparent reflectance. This technique is sensitive only to the vector direction and not the vector length, which makes this algorithm insensitive to variations in illumination due to, for example, topography.

The output of this algorithm is a gray scale value representing the angle distance in radians (in \( N \)-dimensional space) between the reference spectrum and each pixel spectrum. Darker pixels indicate a smaller angular distance and, therefore, a better match to the reference spectrum. This suggests that the pixel values be inverted so that the best matches are bright rather than dark. For this purpose, the software optionally displays the cosine of the spectral angle.

The SAM algorithm can be shown to be mathematically equivalent to a pure impulse function between the image pixel spectrum and the reference spectrum. The mathematical formula for SAM is as follows:

\[
\alpha = \cos^{-1}\left(\frac{\Sigma XY}{\sqrt{\Sigma X} \Sigma Y}\right)
\]

Where:
- \( \alpha \) = angle formed between reference spectrum and image spectrum
- \( X \) = image spectrum
- \( Y \) = reference spectrum

Source: de Carvalho Jr. and Meneses 2000

Spectral Correlation Mapper

The Spectral Correlation Mapper (SCM) algorithm is a modification of the SAM approach wherein the data is normalized and centered on the average of the two spectra (de Carvalho Jr. and Meneses 2000). This model function affords several advantages. The basic SAM algorithm assumes that positive and negative correlators are equally valid, which is not inherently true.

The SAM algorithm was eventually presented as indifferent to shading, since it quantified only vector direction, not magnitude. In practice, this is not strictly true.
The SCM eliminates these true inconsistencies by norming each vector to the vector mean. According to de Carvalho, Jr. and Meneses: “The function cos (SAM) is similar to the Pearsonian Correlation Coefficient. The big difference is that the Pearsonian Correlation Coefficient standardizes the data, centralizing itself in the mean of x and y” (de Carvalho Jr. and Meneses 2000).

\[
R = \frac{\Sigma(X - \bar{X})(Y - \bar{Y})}{\sqrt{\Sigma(X - \bar{X})^2 \Sigma(Y - \bar{Y})^2}}
\]

Source: de Carvalho Jr. and Meneses 2000

**Empirical Line**

The Empirical Line technique is a simple slope/intercept calculation. In practice, the analyst must select two (or more) areas in the scene that are identified as specific materials for which laboratory spectra are available in the Spectrum Library.

When the analyst has two or more spectrum-AOI pairs (spectral ground control points) selected, these can be used to calculate a line, defined by its slope and intercept, for each image layer (band). In practice, it is necessary that points be selected from both high and low albedo areas (Roberts et al. 1985). Each (empirically derived) line is then used to generate a look-up table (LUT) to adjust the input DN values to the relative reflectance values defined by the ground control points.

**Flat Field**

The Flat Field technique has several variants. As originally developed, this approach requires the analyst to select an area of the image that is topographically and spectrally flat. In practice, a spectrally (and topographically) flat area is difficult or impossible to locate in most images. Given these conditions, the resultant spectra of those pixels are largely due to atmospheric scattering and absorption and the solar irradiance curve.

A subsequent evolution of this technique is the Distributed Flat Field approach (Crowley 1990). Typically, a uniform flat field area might not exist in all images. Pixels that approximate the flat field assumption are selected (by various techniques) from all over the image and averaged to get the desired flat field spectrum.

With either of the two approaches to selecting the flat field area, once selected, an average spectrum is calculated from all the flat field (*.aoi) input pixel spectra. Each image spectrum (pixel) is then divided by the flat field spectrum to calculate a relative reflectance. Either of these approaches can be implemented in ERDAS IMAGINE by using the capabilities of the AOI tool to define the flat field AOI.
**Modified Flat Field**

A more sophisticated approach, termed the Modified Flat Field technique, requires that the analyst know the material in the (distributed) field and have a spectrum of that material in a library. While any spectrum of the material in the selected pixel can be used, the best results are obtained if the library spectrum is a field-determined spectrum of the actual material as it occurs in the selected pixel (Green 1990).

Each input pixel spectrum is divided by the (flat) field spectrum and then multiplied by the spectrum. This should remove the atmospheric effects on the image. Given the requisite ground truth information, the modified version is superior since the likelihood of a true (spectrally) flat field is low.

**Internal Average Relative Reflectance**

The IARR technique is a variant of the Flat Field technique and should be used when the analyst has no knowledge of the surface materials and, therefore, cannot tie pixels to Spectrum Library signatures. The original technique calculates a relative reflectance by dividing each spectrum (pixel) by the scene average spectrum (Kruse 1988).

The applicability of this algorithm is predicated on the assumption that a scene contains many and various materials. Therefore, averaging them results in the flat field spectrum. An adaptation of the IARR technique implemented in the IMAGINE Spectral Analysis software is to select an area within the scene (*.aoi file) from which to calculate the internal average. If the selected AOI is thought to be spectrally flat, a water body for example, the calculation should be the (distributed) Flat Field approach.

If a spectrally flat area cannot be defined, you may simply choose to select an area that does not contain the material of interest. This eliminates a shortcoming of the IARR technique. In particular, the average spectrum could contain absorption features related to target materials of interest. The algorithm could then overcompensate for (i.e., remove) these absorbance features. The average spectrum should be visually inspected to check for this possibility. If a scene contains very few materials or a lot of a particular material, this condition fails. This approach should only be used as a last resort, and the implications of the averaging assumption understood. Properly applied, this technique can remove the majority of atmospheric effects.

A modification of this approach first normalizes the data cube by scaling each (pixel) spectrum to a scene constant. Normalization is necessary if there is topographic shading present in the scene (Bowles et al. 1998).
Pixel albedo is affected by sensor look angle and local topographic effects. For airborne sensors, this look angle effect can be large across a scene. It is less pronounced for satellite sensors. Some scanners look to both sides of the aircraft. For these datasets, the average scene luminance between the two half-scenes can be large. To help minimize these effects, an equal area normalization algorithm can be applied (Zamudio and Atkinson 1990). This enhancement must be used with a consideration of whether this assumption is valid for the scene. For an image that contains two (or more) distinctly different regions (e.g., half ocean and half forest), this may not be a valid assumption. Correctly applied, this normalization algorithm helps remove albedo variations and topographic effects.

In a final adaptation, the IARR correction can be done in log-space; this is the log residuals algorithm. This modification is of interest to the mineral exploration community.

### Log Residuals

The log residuals technique models the at-sensor radiance as the result of two factors, illumination and topography, acting on the surface reflectance. The log residuals technique was originally described by Green and Craig (1985), but has been variously modified by researchers. The version implemented here is similar to the approach of Lyon (1987). The algorithm can be conceptualized as:

\[
\text{Output Spectrum} = (\text{input spectrum}) - (\text{average spectrum}) - (\text{pixel brightness}) + (\text{image brightness})
\]

All parameters in the equation are in logarithmic space, hence the name. This algorithm corrects the image for atmospheric absorption, systematic instrumental variation, and illuminance differences between pixels.

The algorithm is implemented in the ERDAS IMAGINE Image Interpreter HyperSpectral module.

### Minimum Noise Fraction

When the bands of a hyperspectral dataset have differing amounts of noise, a standard PC transform does not produce components with a steadily increasing noise level. To achieve a components dataset that does have increasing noise, a modified PC transform, the MNF, has been developed (Green et al. 1988).
The MNF transform produces a set of principal component images ordered in terms of decreasing signal quality. By performing an inverse MNF transform utilizing only the significant images, a full image cube can be reproduced in which the noise has a Gaussian distribution and unit variance (white noise). The MNF transform whitens the noise (zero mean and Gaussian distributed) and compresses the spectral information into fewer bands if the number of bands exceeds the number of classes (i.e., if the dataset is hyperspectral).

The MNF transform requires an input estimate of the noise in each image band. An accepted calculation technique is the shift-difference technique. In this technique, simply subtract from each pixel the DN value of the pixel offset by one in both X and Y. The options are to use the full image or to select a subset area. In practice, since you want to estimate the noise variance, not the scene variance, it is desirable to select a homogenous subset area for the noise calculation.

The MNF algorithm then uses the noise estimate vector to transform the dataset into a coordinate system in which the noise is uncorrelated and equal in each component. A standard PC transform is then applied to the noise-adjusted image. The resultant MNF bands are then plotted and displayed in the Minimum Noise Fraction Tool plot.

To convert the input dataset to a noise-reduced full-band dataset, the noise in all bands above the selected threshold must be reduced. Data layers above the MNF band threshold can be altered in one of several ways:

- **Fill Noise Bands with Zeros** replaces the undesired MNF layers with layers of all zero values.

- **Fill Noise Bands with their Mean** replaces the undesired MNF layers with layers of the mean of that MNF layer.

- **Low-pass Filter Noise Bands** applies a lowpass filter to each of the undesired MNF layers. The size of the lowpass moving window is selected by the analyst.

The inverse transform(s) are then applied to produce a noise-reduced version of the original input dataset.

For more information, see "Minimum Noise Fraction".
Tour Guides
Introduction

One way to access the functionality of the IMAGINE Spectral Analysis software is the Spectral Analysis Workstation. This Workstation provides an interactive interface to all workflow tasks and preprocessing functions. The Workstation is started from the same menu, Spectral Analysis, as the workflow tasks. To start the application, click the Classifier icon in the main IMAGINE icon panel, then select Spectral Analysis from the Classification menu. Select Spectral Analysis Workstation from the Spectral Analysis menu to open the Workstation.

The Spectral Analysis Workstation provides the analyst with an environment to work with both hyperspectral imagery and spectral libraries. The Spectral Analysis Workstation allows access to viewing tools for interactively analyzing the image, spectral signatures, and other data displays. The basic layout of the Spectral Analysis Workstation is shown Figure 6. However, the actual layout varies with the selected task or your preferences.

Figure 6: IMAGINE Spectral Analysis Workstation

Menus

File

New. This opens a new Spectral Analysis Workstation. The software allows multiple Spectral Analysis Workstations to be open at the same time.

Open Project. This opens an existing project file (*.iwp), loads the appropriate analysis image into the views, and populates the appropriate preprocessing parameters.
**Open Analysis Image.** This loads an image into the views and designates it as the image under analysis in the Spectral Analysis Workstation.

**Open Overlay.** This loads an image, usually an ERDAS IMAGINE *.img image, into the views and designates it as being for comparison purposes only. It is not possible to operate on this image except through the view tools, which are accessed via a right-click.

**Load Selectors From AOI.** This loads a previously digitized AOI into the Workstation so that the AOI can be used for spectral analysis.

**Save.** This saves all decisions made within the Spectral Analysis Workstation to the project file (*.iwp) that is currently loaded.

---

### What Is Saved With the *.iwp File

The following information is saved with an IMAGINE Spectral Analysis *.iwp file:

- the file path, band combination, and display order of the analysis image
- the list of all opened files, their band combination settings, and their display order
- the display order and the corresponding preprocess name of the preprocessed image, if it exists
- the Spectral Analysis Workstation layout
- the spectral contents in the Working Library
- the sensor information of the analysis image
- the settings of the preprocess steps (bad bands, spatial subset, spectral subset, atmospheric adjustment, and MNF) that have been edited either in the current session or in previous sessions
- the settings of all tasks (Anomaly Detection, Target Detection, Material Mapping, and Material Identification) that have been executed either in the current session or in previous sessions

**Save As.** This saves all decisions made within the Spectral Analysis Workstation to the project file (*.iwp) that is designated by you.

**Save Preprocessed Image.** This option saves a preprocessed image, which is generated by use of the View -> Preprocess menu, to a permanent file. An example is when you select View -> Preprocess -> MNF. The resulting MNF image is generated with an eisw_ extension and is a temporary file unless you save it.

**Save Selectors to AOI File.** This saves AOIs you have digitized in the Workstation to a file (*.aoi) so that they can be reloaded for future use.
**Close.** This closes the current Spectral Analysis Workstation.

**Close All.** This closes all Spectral Analysis Workstations currently open.

---

**Edit**

**Sensor Information.** This opens the Sensor Information Tool. You can also access the tool via the toolbar. Use this dialog to specify the type of sensor that collected the data.

**Bad Bands.** This opens the Bad Band Selection Tool. You can also access the tool via the toolbar. Use this dialog to remove poor absorption (noisy) bands from analysis.

**Spectral Subset.** This opens the Spectral Subset Selection Tool. You can also access the tool via the toolbar. Use this dialog to include only certain spectral ranges in analysis.

**Spatial Subset.** This opens the Spatial Subset Tool. You can also access the tool via the toolbar. Use this dialog to subset a portion of the analysis image for processing.

**Atmospheric Correction.** This opens the Atmospheric Correction Tool. You can also access the tool via the toolbar. Use this dialog to correct anomalies in the dataset due to atmospheric effects.

**Minimum Noise Fraction (MNF).** This opens the Minimum Noise Fraction Tool. You can also access the tool via the toolbar. Use this dialog to reduce noise in the data.

---

**View**

**General Workstation Mode.** This option deactivates any other selected mode.

**Anomaly Workstation Mode.** This option puts the Workstation in the mode to find areas that differ markedly from the majority of the image.

**Target Detection Mode.** This option puts the Workstation in the mode to find areas of a specific material.

**Material Mapping Mode.** This option puts the Workstation in the mode to map areas of a specific material by using a spectrum.

**Material Identification Mode.** This option puts the Workstation in the mode to identify an area by comparing its spectrum to a list of candidate spectra.

**Preprocess.** Select this option, then select an item from the preprocessing list, such as MNF. That process is executed, along with any processes that precede it, such as bad band removal.

**Preset RGB Combinations.** Select this item to choose from many commonly used band combinations, such as **True Color** and **False Color IR.**

**Reset Viewers.** This option returns the display in the views to the default zoom and rotation.

---

**Help**

**About Spectral Analysis Workstation.** This option opens the On-Line Help for the IMAGINE Spectral Analysis module.
Toolbars

The first two icons in the upper left of the toolbar are standard Open and Save functions.

The next series of icons contains the interactive tools.

### Table 1: Interactive Tools

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="select_icon" alt="Select" /></td>
<td><strong>Select.</strong> Click this icon to select items in the views, such as the Link Cursor, or in the Spectrum Plot, such as the color-to-band designators.</td>
</tr>
<tr>
<td><img src="create_point_icon" alt="Create Point" /></td>
<td><strong>Create Point.</strong> Click this icon, then click a point in one of the views to collect the spectrum for that point. The spectrum displays in the Spectrum Plot.</td>
</tr>
<tr>
<td><img src="line_aoi_icon" alt="Line AOI" /></td>
<td><strong>Line AOI.</strong> Click this icon to draw a line AOI in a view.</td>
</tr>
<tr>
<td><img src="polygon_aoi_icon" alt="Polygon AOI" /></td>
<td><strong>Polygon AOI.</strong> Click this icon, then click inside a view to collect vertices of a polygonal AOI.</td>
</tr>
<tr>
<td><img src="reshape_aoi_icon" alt="Reshape AOI" /></td>
<td><strong>Reshape AOI.</strong> Click this icon to reshape an existing AOI in a view. Click, hold, and drag a vertex to its new position.</td>
</tr>
<tr>
<td><img src="lock_unlock_icon" alt="Lock/Unlock" /></td>
<td><strong>Lock/Unlock.</strong> Click this icon for repeated use of a particular tool. Click again to disable that functionality.</td>
</tr>
<tr>
<td><img src="color_chooser_icon" alt="Color Chooser" /></td>
<td><strong>Color Chooser.</strong> Click this icon to change the color of the points you place in the Workstation. This icon works in conjunction with the Create Point icon and the AOI tools.</td>
</tr>
</tbody>
</table>

The other icons on the upper toolbar are for management of the Workstation.

### Table 2: Workstation Management Tools

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="archive_lib_icon" alt="Archive Libraries" /></td>
<td><strong>Archive Libraries.</strong> When you select this icon, you display of the Archive Library files (*.spl) for use in processing. Toggle the icon off so that the Archive Libraries are not displayed.</td>
</tr>
<tr>
<td><img src="working_lib_icon" alt="Working Libraries" /></td>
<td><strong>Working Libraries.</strong> When selected, this icon allows display of all of the Working Libraries (*.spl) associated with a project. Toggle the icon off so that the Working Libraries are not displayed.</td>
</tr>
</tbody>
</table>
The next icons correlate to specific analytical tasks. Clicking on one of these icons sets the operational mode of the Spectral Analysis Workstation. This determines the required inputs, appropriate metrics, and display mode of the analysis results.

### Table 3: Analytical Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Anomaly Detection.</strong></td>
<td>Anomaly Detection searches an input image and identifies those pixels that have a spectral signature that deviates markedly from the majority of the other pixel spectra in the image.</td>
</tr>
<tr>
<td><strong>Target Detection.</strong></td>
<td>Target Detection searches an input image for a specific material of interest, the target, which is supposedly present in very low concentrations.</td>
</tr>
<tr>
<td><strong>Material Mapping.</strong></td>
<td>Material Mapping searches an input image for the presence of a specific material or materials based on an input spectrum for the material(s) of interest.</td>
</tr>
<tr>
<td><strong>Material Identification.</strong></td>
<td>Material Identification identifies the material of a pixel or an AOI by comparing it to a list of candidate spectra.</td>
</tr>
</tbody>
</table>

The next icons launch the preprocessing tools.

### Table 4: Preprocessing Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sensor Information.</strong></td>
<td>The Sensor Information Tool provides the mechanism to add bandpass information about the sensor that collected the analysis image. Sensor Attribute Files (*.saf) are provided for the most common sensors (e.g., RADARSAT and AVIRIS).</td>
</tr>
<tr>
<td><strong>Bad Band.</strong></td>
<td>The Bad Band Selection Tool allows you to designate, band by band, those bands to permanently remove from spectral analysis that may corrupt results.</td>
</tr>
<tr>
<td><strong>Spectral Subset.</strong></td>
<td>With the Spectral Subset Selection Tool, you can identify specific bands or spectral ranges to be used in analysis and exclude others.</td>
</tr>
</tbody>
</table>
Table 4: Preprocessing Tools (Continued)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Spatial Subset.</strong></td>
<td>The Spatial Subset Tool allows you to use a portion of the input image in processing and analysis.</td>
</tr>
<tr>
<td><strong>Atmospheric Adjustment.</strong></td>
<td>The Atmospheric Adjustment Tool corrects atmospheric effects, such as water absorption, that may degrade the quality of the reflected spectra.</td>
</tr>
<tr>
<td><strong>Minimum Noise Fraction.</strong></td>
<td>The Minimum Noise Fraction Tool is used to reduce the noise in an input image.</td>
</tr>
<tr>
<td><strong>Execute.</strong></td>
<td>Click this icon to start the actual calculation process. Whenever this icon is clicked, the options dialog for the selected mode (e.g., Target Detection) opens.</td>
</tr>
</tbody>
</table>

The view in the Spectral Analysis Workstation is a standard ERDAS IMAGINE embedded view with a shortened list of standard ERDAS IMAGINE Viewer functions. The tools are intended to make visualization and interpretation convenient: they are not for data manipulation.

The right mouse button provides access to the view functions:

**Inquire Cursor.** Select this option to open the Inquire Cursor, which enables you to identify and locate specific pixels in an image.

**Inquire Box.** Select this option to open an Inquire Box, which enables you to identify and locate corners (ULX, ULY, LRX, LRY) of a specific region in an image. You can also use it to change the color of the Inquire Cursor.

**Arrange Layers.** Select this option to open the Arrange Layers dialog, which enables you to adjust the order of layers (e.g., raster and vector) in a view.

Selecting this option in any of the Spectral Analysis Workstation views provides additional right-click functionality to be applied to the individual image layers displayed. These are: **Raise to Top, Lower to Bottom, Delete Layer, Save Layer, Save Layer As, Layer Visibility, Fit Layer to Window, Brightness/Contrast, Piecewise Contrast, Breakpoints, Band Combinations**, and **Transparent Background**.

*All of the Arrange Layers options are described in the On-Line Help.*

**Blend.** This function allows you to blend two layers together. You select a percentage by which to blend the layers.
**Swipe.** Select this option to open the Viewer Swipe tool, which allows you to view portions of a layer overlaying another layer. This tool is useful if you apply it in conjunction with the Arrange Layers tool.

**Flicker.** This function allows you to quickly switch between the top two layers displayed in a view. It can function automatically using a Speed value, or manually, which is controlled by you.

**Zoom.** Zoom further expands to allow: **Zoom in By 2, Zoom Out By 2, Default Zoom,** and **Rotate and Magnify Area.**

---

**Libraries**

The Spectral Analysis Workstation has space for two types of libraries: Archive Libraries and Working Libraries.

**Archive Libraries**

This window in the Spectral Analysis Workstation allows access to various spectral signature libraries that are stored within the software. These libraries are from the USGS, Johns Hopkins, and JPL. Signatures from these libraries can be transferred to the Working Library window or the Spectrum Plot.

**Working Libraries**

This window in the Spectral Analysis Workstation contains the signatures and signature libraries frequently used in the analysis of an image.

---

**Spectrum Plot**

The Spectral Analysis Workstation layout includes a Spectrum Plot. It is possible to have more than one Spectrum Plot open within a single Spectral Analysis Workstation. You activate a Spectrum Plot by clicking in the title bar. The activated plot has three vertical lines. The lines indicate the spectral position of the Red, Green, Blue (RGB) layers plotted in the views. These lines are red, green, and blue to indicate which band is displayed in which color. Sliding these lines to a different band/wavelength position causes the selected band/wavelength to be displayed in the designated color.

---

*All of the Zoom options are described in the On-Line Help.*
Like other ERDAS IMAGINE modules, the IMAGINE Spectral Analysis module has preferences that control its behavior. You access these preferences by selecting **Session | Preferences | Spectral Analysis** from the ERDAS IMAGINE menu bar. Each preference is described in the On-Line Help.
Introduction

Anomaly Detection is the process of searching an input image to identify pixels that have a spectral signature that deviates markedly from most other pixel spectra in the image (the background spectra).

The simplest scenario is one where neither the signature of the material of interest nor the signature of the surrounding environment is known. The question can be asked, "Is there anything unusual in this scene?" Examples would be vehicles in an uninhabited area, a hydrothermal outcrop in a shale deposit, or vegetation in desert terrain.

In Anomaly Detection, you have no requirements beyond the desired preprocessing steps. After calculation of the anomaly mask, you can display that layer (mask) over the input image for analysis with the Viewer Swipe tool.

Before You Begin

This Tour Guide provides the most straightforward approach to Anomaly Detection. It does not employ any of the preprocessing steps or additional features, such as project files. The goal here is to produce an anomaly mask as quickly as possible.

“Simple Anomaly Detection”

In the first section of this Tour Guide, you are going to perform the following basic steps:

- Specify an input file
- Name the output file—

  cuprite_ad_th6.img

- Compute the results
- Analyze the results with the Viewer Swipe tool

Approximate completion time for this portion of the Tour Guide is 10 minutes.

The output of this example, cuprite_ad_th6.img, is an anomaly mask depicting areas in the input image that are markedly different from their surroundings.

“Bad Band Identification”

In the next series of steps, you:

- Specify an input file
- Name the output file—

  cuprite_ad_bb.img
Simple Anomaly Detection

Identify the bad bands
Save the bad band data—\texttt{aviris_badbands.bbl}
Compute the results
Analyze the results with Arrange Layers
Close and exit

\begin{quote}
\textit{Approximate completion time for this portion of the Tour Guide is 15 minutes.}
\end{quote}

The output of this exercise, \texttt{cuprite\_ad\_bb.img}, shows that the removal of bad bands can improve the resulting anomaly mask. You also create a Bad Band List File to use in future analyses, \texttt{aviris\_badbands.bbl}.

\section*{Simple Anomaly Detection}

\subsection*{Start IMAGINE Spectral Analysis}

ERDAS IMAGINE must be running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select \textbf{Spectral Analysis} from the \textbf{Classification} menu.

\begin{itemize}
\item \texttt{aviris_badbands.bbl}
\item \texttt{cuprite\_ad\_bb.img}
\end{itemize}
3. Click the **Anomaly Detection** button on the **Spectral Analysis** menu.

The Anomaly Detection Wizard — Project Specification dialog displays.

4. Select the **Use an Image Only** radio button.
   This is the quickest way to begin processing an image.

**Choose Input File**

1. Click the Open icon and navigate to `<IMAGINE_HOME>/examples`, then select `cuprite_aviris.img` for the input image.

2. Click **OK** in the File Selector to transfer the image name back to the Anomaly Detection Wizard — Project Specification dialog.
3. Click **Next** in the Anomaly Detection Wizard — Project Specification dialog.

**Name Output File**

The Anomaly Detection Wizard — Output Specification dialog displays.

1. Select the **Yes/No** radio button to generate a binary thresholded output image.
   
The **Threshold** number displays. For this exercise, keep the default value of **6.00**. When this value is lower, a greater number of anomalies may be determined and vice versa.

2. Enter **cuprite_ad_th6.img** for the **Output File Name**.

   *The output image is written to the location set in your preferences (User Interface & Session -> Default Output Directory) by default. If you wish to write to a different location, click the Open icon and select a new directory.*

**Compute Results**

1. Click **Finish** in the Anomaly Detection Wizard — Output Specification dialog.
   
   A dialog displays for you to specify what to do when processing is finished.

   *Click this radio button to open a Workstation once processing is complete*

2. Select the **Create Output File and Proceed to Workstation** radio button, then click **OK**.
Analyze Results—Swipe

When processing is complete, the Spectral Analysis Workstation opens, and the anomaly mask displays on top of the input image, cuprite_aviris.img. You should see several small, white areas on a black background. This is the anomaly mask.

1. Right-click in the Main View and select **Swipe** from the **Quick View** menu.

   This starts the Viewer Swipe tool and exposes half of the underlying analysis image.
2. Click on the slider in the Viewer Swipe tool and drag it to the right.

Notice that the extent of the anomaly mask matches the input image, and view where the anomalies (white areas in the mask) correspond to the input image. You may find it easier to view the anomalies if you zoom in to a smaller portion of the image (right-click, select **Zoom -> Zoom In By 2**).
Close

1. Select File -> Close from the Spectral Analysis Workstation, if you wish.

2. Click No in the Attention dialog prompting you to save changes.

Conclusions

This Anomaly Detection scenario is intended as a quick and simple first look at this functionality; there is much more you should do. For example, removing bad bands from the analysis should typically be done. (See "Identify Bad Bands".)

Additionally, the algorithm used for this process, OSP, allows you to enter supportive information and/or modify the character of the OSP operator. Both options are available through the Spectral Analysis Workstation.

For more information about OSP, see "Orthogonal Subspace Projection".

Bad Band Identification

In the previous analysis, all input bands in the dataset are used in the processing. However, it is not uncommon for there to be bands within the dataset that have a low signal-to-noise ratio (S/N), or are otherwise corrupt. This could be due to absorption of particular wavelengths by gasses in the atmosphere, or by problems with the sensor detectors.

The incorporation of these bad bands into the metric algorithms can corrupt calculation and lead to poor results. To avoid this, it is preferable to prepare a list of bands that are not to be used during calculation.

Choose Input File

ERDAS IMAGINE must be running.

1. Click the Anomaly Detection button on the Spectral Analysis menu.

2. Click to select the Use an Image Only radio button in the Anomaly Detection Wizard — Project Specification dialog.

3. Click the Open icon and navigate to <IMAGINE_HOME>/examples, then select cuprite_aviris.img for the input image.

4. Click OK in the File Selector to transfer the image name back to the Anomaly Detection Wizard — Project Specification dialog.

Name Output File

1. Select the Yes/No radio button to generate a binary thresholded output image, and keep the default Threshold value of 6.00.

2. Enter cuprite_ad_bb.img for the Output File Name.


Identify Bad Bands

The Anomaly Detection Wizard — Bad Band Specification dialog displays.

1. Click the Exclude Bad Bands radio button.

2. Click the Bad Band Selection Tool icon.

   The Bad Band Selection Tool dialog opens.
The **Current Band** indicator is set to band 1. The image, data **Histogram**, and **Mean Plot** of **Band 1** display in the Bad Band Selection Tool dialog.

**NOTE:** The image preview and data histogram are very noisy. Band 1 and 2 of AVIRIS data are known to have a low S/N. These are bad bands.

3. Click the up arrow of the **Current Band** nudger twice to select band 3.
4. In the CellArray, click in the **Bad** cells of bands **1** and **2** to mark them as a bad bands and remove them from subsequent analyses and processes.

5. Click on the Forward Arrow icon of the Movie Player.

   The software moves through the bands at **1.0 Seconds/Frame** displaying each band image and histogram. As the bands approach the 1400 nm water absorption region, the quality of the bands degenerates. Unacceptable bands may have extreme noise, an irregular histogram, or lack identifiable features.
6. As soon as an unacceptable band is viewed, click the Stop Movie Player icon.

7. Click in the > cell of the CellArray corresponding to bands 108 through 113 to view them one at a time.

8. Click in the Band cell for row 108 and drag through band 113 to select the rows in the CellArray.

Notice the corresponding highlighting over those bands in the Mean Plot.
To select single bands, hold the Shift key down on your keyboard and click each one. You can also drag the mouse to select a continuous range of bands. Click in the **Bad** column of any selected band to mark all selected bands.

9. Click in the highlighted **Bad** column corresponding to band **108**.

   The remainder of the highlighted bands are also marked as bad bands.

10. Mark bands **13**, **153** through **166**, and **221** through **224** as bad bands by clicking in the **Bad** column to place an **X**.

   **NOTE:** In this particular dataset, band 13 has been noted to have a slight spatial misregistration, so it is also marked as a bad band.

11. Right-click in the **Band** column and choose **Select None** from the **Row Selection** menu.

   Notice that the ranges marked as bad bands now appear as orange stripes in the **Mean Plot**.
Save Band Data

You can save the information regarding bad bands identified in the Bad Band Selection Tool to an ASCII file for later use. The file is a Bad Band List File (*.bbl).

1. In the Bad Band Selection Tool dialog, click the **Save As** button.
2. Navigate to a directory in which you have write permission.
3. Name the file `aviris_badbands.bbl`, then click **OK** in the File Selector.
4. Make sure that the **Use** checkbox, located in the upper-right corner, is selected in the Bad Band Selection Tool dialog.
5. Click **OK** in the Bad Band Selection Tool dialog to transfer bad band information to the Anomaly Detection Wizard—Bad Band Specification dialog.

Compute Results

1. Click **Finish** in the Anomaly Detection Wizard—Bad Band Specification dialog.
   
   A dialog displays for you to specify what to do when processing is finished.

2. Select the **Create Output File and Proceed to Workstation** radio button, then click **OK**.
When processing is complete, the Spectral Analysis Workstation opens and the anomaly mask displays on top of the input image. You should see several small, white areas on a black background.

1. In the Spectral Analysis Workstation, select **File -> Open Overlay**.

2. In the File Selector, navigate to the directory where you saved **cuprite_ad_th6.img**.

   *NOTE: This is the file you generated in the exercise "Simple Anomaly Detection", "Name Output File".*

3. Select **cuprite_ad_th6.img**, then click **OK** in the File Selector.

4. Right-click in the Main View and choose **Arrange Layers** from the **Quick View** menu.

   The Arrange Layers dialog allows you to easily change the order of images in the Spectral Analysis Workstation for analysis purposes.
5. Click, hold, and drag `cuprite_ad_th6.img` to the bottom of the stack, then click **Apply**.

6. Use the Viewer Swipe tool and Arrange Layers to compare the results of the two Anomaly Detection analyses (`cuprite_ad_bb.img` and `cuprite_ad_th6.img`) to the analysis image you selected, `cuprite_aviris.img`.

   For instructions on how to launch the Viewer Swipe tool, see "Analyze Results—Swipe".

   With the use of the Bad Band Selection Tool, there are more detected anomalous areas. This suggests that those anomalies detected without application of the Bad Band Selection Tool may be false positives. That is, they were identified because of irregularities in the noisy bands, and not because of legitimate anomalies in the good bands.

7. Click **Close** in the Arrange Layers dialog and **Cancel** in the Viewer Swipe dialog.

**Close and Exit**

1. Select **File -> Close** in the Spectral Analysis Workstation, if you wish.

2. Click **No** in the Attention dialog prompting you to save changes.

3. Select **Session -> Exit IMAGINE** from the ERDAS IMAGINE menu, if you wish.
**Conclusions**

When comparing the two results, note that they are quite similar. Removing the bad bands from the analysis has increased the size of the previously detected anomalies and found additional clusters in the same area. This is because bad bands, when included in analysis, can corrupt results.

Note that, for this exercise, you have analyzed the whole image at one time. Thus, these points are anomalous to a background estimated from the spectra of the whole image. Analyzing the image as subsets selected by visual inspection of the scene could find additional anomalies. In addition, the OSP operator can be refined to give better results.

---

*If you perform Anomaly Detection via the Spectral Analysis Workstation instead of the Anomaly Detection Wizard, you have access to other, advanced options. These options include a choice the method used for analysis and background estimation. The On-Line Help describes all of the Anomaly Detection options.*

---

**Next**

Next, you are going to learn how to use the Target Detection mode of the IMAGINE Spectral Analysis module.
Target Detection

**Introduction**

Target Detection is the process of searching an input image for a specific material (termed the target) suspected to be present in very low concentrations.

In a typical analysis scenario, the analyst knows the spectral signature of a low probability material of interest (the target), but does not have background spectra and does not wish to generate them. This is a good task for the Target Detection workflow.

**Before You Begin**

This Tour Guide provides instructions to isolate specific spectra for Target Detection. The three sections of the Tour Guide are as follows:

**“Simple Target Detection”**

In the first section of this Tour Guide, you are going to perform the following basic steps:

- Set up the project—**target_detection_tour.iwp**
- Identify the target spectra
- Name the output file—**buddingtonite_target.img**
- Compute and analyze the results

*Approximate completion time for this portion of the Tour Guide is 10 minutes.*

The output of the Target Detection, which uses an ERDAS IMAGINE Spectrum Library to select the target material, is named **buddingtonite_target.img**. This file is part of the IMAGINE Spectral Analysis project **target_detection_tour.iwp**, which you also create in this section.

**“Using Library Signatures”**

In the next series of steps, you:

- Set up the project—**target_detection_lib.iwp**
- Select the target spectrum
- Name the output file—**buddingtonite_target_lib.img**
- Add sensor information
- Identify the bad bands
Simple Target Detection

Set Up Project

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

You can perform simple Target Detection using the Target Detection Wizard.

The output of this Target Detection, which uses the USGS Spectrum Library, is an image file named *buddingtonite_target_lib.img*. This file is part of the IMAGINE Spectral Analysis project *target_detection_lib.iwp*. You also create a Working Library of your own, which is called *buddingtonite_spectra.spl*.

**“Spectral Subsetting”**

In the next series of steps, you:

- Open an existing project—*target_detection_lib.iwp*
- Select a Spectrum Library
- Name the output file—*target_specsub.img*
- Compute and compare the results
- Close and exit

The output of this subsetting operation, *target_specsub.img*, is incorporated into an existing IMAGINE Spectral Analysis project *target_detection_lib.iwp*.
2. Select **Spectral Analysis** from the **Classification** menu.

3. Click the **Target Detection** button on the **Spectral Analysis** menu. The Target Detection Wizard—Project Specification dialog displays. **Create a New Project** is selected by default.

4. Enter **target_detection_tour.iwp** for the **Project File Name**.

5. Enter or select **cuprite_aviris.img**, which is located in the /examples directory for the **Image File Name**. If necessary, click the Open icon and browse to locate the file.

6. Click **Next** in the Target Detection Wizard—Project Specification dialog.

**Identify Target Spectra**

The Target Detection Wizard — Target Spectrum Selection dialog displays.

1. Right-click in the Spectrum Library window and select **Open a spectrum library file** from the **Spectrum TreeView** menu.

2. Navigate to /examples and select **buddingtonite_scenederived.spl**, then click **OK**.

3. Click the Plus symbol + to expand the **Buddingtonite Scene Derived** list.
4. Select the **buddingtonite_scenederived** spectrum by clicking the Spectrum symbol `[A]`. Clicking the Spectrum symbol `[A]` identifies this signature as the target material. A mask you generate identifies areas composed of Buddingtonite.

5. Click **Next** in the Target Detection Wizard — Target Spectrum Selection dialog.

### Name Output File

The Target Detection Wizard — Output Specification dialog displays.

1. Select the **Yes/No** radio button to generate a binary thresholded output image.

   The **Threshold** number displays. For this exercise, keep the default value of **6.00**. When this value is lower, a greater number of targets may be determined and vice versa.

2. Enter **buddingtonite_target.img** for the **Output File Name**.

   *NOTE: In this instance, the target signature (buddingtonite_scenederived) and the analysis image are both from the same sensor (AVIRIS), so the sensor information is not required. Signatures and the analysis image must have wavelength information on the X-axis. An image without sensor information only has sequential numbers on the X-axis, and cannot be used in analysis.*

### Compute Results

1. Click **Finish** in the Target Detection Wizard — Output Specification dialog.
2. Select the **Create Output File and Proceed to Workstation** radio button, then click **OK**.

**Analyze Results**

When processing is complete, the Spectral Analysis Workstation opens, and the target mask displays on top of the input image.

You should see several small clumps of white on a black background. This is the target mask.

1. Right-click in the Main View and select **Swipe** from the **Quick View** menu.

This starts the Viewer Swipe tool and exposes half of the underlying input image.
2. Click, hold, and drag the slider on the Viewer Swipe tool to the right. You can see the target mask overlay the input image, and you can see where the targets (white areas in the mask) correspond to the analysis image.

NOTE: The OSP algorithm is a subpixel detector (see “Algorithms and Metrics”). This means that every masked pixel need not be entirely or even largely composed of the target material.

Close

1. Select **File -> Close** from the Spectral Analysis Workstation, if you wish.

2. Click **Yes** in the Attention dialog to save the changes to **target_detection_tour.iwp**.

Conclusions

This first example of Target Detection shows how quickly a simple detection can be performed. However, there are preprocessing steps that may be used to aid in your Target Detection. For example, if the target signature is not derived from the Analysis Image, Sensor Information will be needed to compare the various signatures. Or perhaps some of the bands in your dataset have a very low signal-to-noise ratio (s/n) or are otherwise of poor quality; the Bad Band Tool could be used to eliminated these from the analysis. For more rigorous analysis, you can use Spectral Library signatures.
Using Library Signatures

In the previous analysis, the target spectrum, Buddingtonite, was obtained by selecting a pixel from `cuprite_aviris.img` that had been classified as Buddingtonite in another image, `cuprite_classified_map.img`. However, a scene-derived spectrum such as this is probably a mixed pixel (that is, it is not a spectrum of the pure mineral Buddingtonite—it has other component materials).

Perhaps using a laboratory-derived spectrum is a better way to map this mineral. To use signatures from Spectrum Libraries, or from images taken by other sensors, it is necessary to have the sensor information (band to wavelength relationship) for the image under analysis.

Set Up Project

ERDAS IMAGINE must be running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

![Classifier Icon]

2. Select Spectral Analysis from the Classification menu.

3. Click the Target Detection button on the Spectral Analysis menu. The Target Detection Wizard — Project Specification dialog displays. Create a New Project is selected by default.

![Target Detection Wizard - Project Specification]

4. Enter `target_detection_lib.iwp` for the Project File Name.

5. Enter or select `cuprite_aviris.img` for the Image File Name.


Select the Target Spectrum

The Target Detection Wizard — Target Spectrum Selection dialog opens.
1. Click the Plus symbol to expand the **USGS** Spectrum Library.

2. Click the Spectrum symbol to select **Buddingtonite NHB2301**.

3. Click **Next** in the Target Detection Wizard — Target Spectrum Selection dialog.

**Name Output File**

The Target Detection Wizard — Output Specification dialog opens.

1. Click the **Yes/No** radio button to generate a thresholded image. The **Threshold** defaults to a value of **6.00**, which is appropriate for this analysis.

2. Enter **buddingtonite_target_lib.img** for the **Output File Name**.

3. Click **Next** in the Target Detection Wizard — Output Specification dialog.

**Add Sensor Information**

The Target Detection Wizard — Sensor Info Specification dialog displays.
1. Click the **Use Sensor Information** radio button.

2. Click the Sensor Information Tool icon [Image].

   The Sensor Information Tool dialog opens. It displays information about the sensor that acquired the image, which is obtained from the header of the image file.

   Notice that the **Sensor Name** field shows **Aviris**. This is the correct sensor associated with the Cuprite dataset used in this example.

3. Click **OK** in the Sensor Information Tool dialog.

   This loads the band-to-wavelength mapping parameters for the analysis AVIRIS image and returns to the Target Detection Wizard — Sensor Info Specification dialog.

   *You can also create a sensor attribute file via this dialog. See "Create a Sensor Attribute File" for more information.*

Identify Bad Bands

The Target Detection Wizard — Bad Band Specification dialog displays.

1. Click the **Exclude Bad Bands** radio button.

   ![Bad Band Selection Tool icon](image)

2. Click the Bad Band Selection Tool icon.

3. Click the **Load** button on the Bad Band Selection Tool dialog.

4. Navigate to the directory where you saved the Bad Band List File, *aviris_badbands.bbl*.

   NOTE: You created this file in "Bad Band Identification", "Save Band Data".

   *If you did not complete the exercise, then refer to "Identify Bad Bands" to mark bad bands using the Bad Band Selection Tool.*

5. Select the file *aviris_badbands.bbl*, then click **OK** in the File Selector.
The specific bands targeted for removal are identified in both the CellArray and the **Mean Plot** of the Bad Band Selection Tool.

6. Click **OK** in the Bad Band Selection Tool to transfer this information to the project and Target Detection Wizard.

**Compute Results**

1. Click **Finish** in the Target Detection Wizard — Bad Band Specification dialog.

2. Click the **Create Output File and Proceed to Workstation** radio button, then click **OK**.

**Compare Results** When processing is complete, the Spectral Analysis Workstation opens and the target mask displays on top of the analysis image, **cuprite_aviris.img**.
1. In the Spectral Analysis Workstation, select **File -> Open Overlay**.

2. In the File Selector, select the results of the previous exercise, `buddingtonite_target.img`, then click **OK**.

   *NOTE: You generated this file in "Simple Target Detection", "Name Output File".*

3. Use the Viewer Swipe tool and Arrange Layers dialog to compare the two Target Detection results.

   For information about how to use the Viewer Swipe tool, see "Analyze Results—Swipe". For information about the Arrange Layers dialog, see "Analyze Results—Arrange Layers".

### Add an Overlay

1. In the Spectral Analysis Workstation, select **File -> Open Overlay**.

2. Select `/examples/cuprite_classified_map.img` in the File Selector, then click **OK**.
The truth image, `cuprite_classified_map.img`, displays over the target masks and analysis image in the Spectral Analysis Workstation.

This is the truth image for the analysis. In this classified map, there are three clusters of Buddingtonite. They are colored pink and located at the following File coordinates:

- **X**: 345, **Y**: 215
- **X**: 344, **Y**: 225, and
- **X**: 349, **Y**: 231.

If you wish, you can use the Inquire Cursor, which is accessed by right-clicking and choosing Inquire Cursor from the Quick View menu, to view each of the three areas of Buddingtonite. Be sure to select File from the coordinate type popup list in the Inquire Cursor dialog.

See “Cuprite Dataset” for information about the truth image.

3. Right-click in the main view and select **Arrange Layers**.
4. In the Arrange Layers dialog, adjust the ordering of layers in the view by dragging them to a new level in the stack, then click Apply.

5. Right-click in the Main View and choose Zoom -> Zoom In By 2 as many times as necessary to see details in the truth image.

6. Use both the Viewer Swipe tool and Arrange Layers to compare the two Target Detection results (that is, `buddingtonite_target_lib.img` and `buddingtonite_target.img`) to the truth image.

   ![](image)

   For instructions on how to use the Viewer Swipe tool, see “Analyze Results—Swipe”. For information about the Arrange Layers dialog, see “Analyze Results—Arrange Layers”.

   While the results of the Target Detection are not an exact match of the truth image, more accurate results can be obtained using a scene-derived spectrum. This one, however, will be derived from a larger sample of target pixels.

7. In the Arrange Layers dialog, move the truth image, `cuprite_classified_map.img`, to the top of the list, then click Apply.

8. Click Cancel on the Viewer Swipe dialog and Close on the Arrange Layers dialog.

**Compare Spectral Plots**

   Note that, while the two results are similar, they are not identical. This is because the input target signatures are not identical: one is from the USGS Spectrum Library and the other is derived from a single pixel in the image.

   NOTE: At this time, you may want to click the Maximize icon so the Spectral Analysis Workstation fills the entire screen. Resize other Workstation components to your liking.
1. In the Archive Libraries window of the Spectral Analysis Workstation, expand the USGS library by clicking on the Plus symbol +.

2. Click and hold the Spectrum symbol for Buddingtonite NHB2301, then drag and drop it into the Spectrum Plot at the bottom of the Spectral Analysis Workstation.

The Spectrum Plot displays the spectrum for Buddingtonite and adds it to the Legend at the right. You can use Legend Editor to change the display of the wavelength and to alter the name of the spectrum in the Spectrum Plot Legend.

3. In the Zoom View, right-click and select Inquire Cursor from the Quick View menu.

   To change the color of the Inquire Cursor in a view, right-click and select Inquire Box from the Quick View menu. Click the Color Chooser icon next to Box Color and select a different color.

4. In the fields, enter a Map X value of 373 and a Map Y value of -578.

   NOTE: The values you enter are modified slightly to account for image resampling.

   The image redisplays in the Zoom View with the Inquire Cursor at the coordinates you entered.
5. Right-click in the Zoom View and select **Zoom -> Zoom in By 2** as many times as necessary to comfortably see the intersection of the Inquire Cursor in the view.

6. In the Spectral Analysis Workstation, click the Color Chooser icon , then select **Red**.

7. Click the Create Point icon , then click at the intersection of the Inquire Cursor in the Zoom View to collect the spectrum of **Map pixel 373, -578**.

   A point displays in each view and the spectrum, labeled **Sample 1**, shows in the Spectrum Plot.
This is the pixel spectrum used in `buddingtonite_scenederived.spl`, which is in the /examples directory, with the difference that now the project has sensor information. You added the sensor information when you confirmed the *.saf file for AVIRIS data in “Add Sensor Information”. This allows scene-derived spectra to be plotted with library spectra.

For more information on altering the Spectrum Plot, see "Optimize the Spectrum Plot".

**Change Spectrum Properties**

You may change the properties of any spectrum in the Spectrum Plot.

1. Click to select **Sample 1** in the Legend of the Spectrum Plot.

2. Right-click and select **Spectrum Properties** from the **Options** menu.

3. Click in the **Name** field and rename the spectrum `budd_scenederived`.

4. Click **OK** in the Sample 1 Properties dialog.

   *NOTE: The dialog becomes the `budd_scenederived` Properties dialog, since it is based on the spectrum name.*

5. Right-click on the Legend and choose **Select None**.

6. Compare the plotted spectra of Buddingtonite from the USGS Spectrum Library, **Buddingtonite NHB2301**, and that collected from the scene itself, `budd_scenederived`.
Create a Working Library

Working Libraries are those that are directly applicable to the dataset you are analyzing. They display in the Working Library window of the Spectral Analysis Workstation for quick, easy use.

1. One by one, drag and drop the two displayed spectra (Buddingtonite NHB2301 and budd_scenederived) on to the empty Material List 1 in the Working Libraries window. (You can also right-click and choose Select All from the legend Options menu.)

   NOTE: Make sure that Material List 1 is highlighted before dropping a spectrum on to it.

2. Click the Plus symbol + to expand the Working Library, Material List 1.

3. Click the Book symbol for Material List 1, then right-click and select Rename from the Spectrum Library menu.

4. In the Spectrum Library Name field, type Buddingtonite Spectra.

5. Click OK in the Rename Spectrum Library dialog.

6. Click on the Book symbol for the Buddingtonite Spectra Working Library, then right-click and select Save As.

7. Navigate to a directory where you have write permission.

8. In the File name field, type buddingtonite_spectra.spl, then click OK.

   You can now use this Spectrum Library file in other analyses targeting the mineral Buddingtonite.
Conclusions

Note that the two Buddingtonite spectra are similar in the spectral region > 1800 nm and quite different in the region < 1800 nm. It appears that the diagnostic features for Buddingtonite are located in the >1800nm region. The region < 1800nm has broad features that are similar to the broad absorbances of non-Buddingtonite pixels in this scene. This suggests that analyses run using spectral subsets might prove more accurate.

See "Collect Multiple Spectra“ for a more in-depth analysis of various Buddingtonite spectra.

Note, too, that the Target Detection results are not in agreement with the truth image. One possible explanation is that the target spectra used in these analyses are different from the spectrum of the mineral at this location just as they are different from each other.

Another possible explanation is that the background being suppressed by the OSP algorithm (see “Algorithms and Metrics”) contains much of the character of Buddingtonite, and thus this character is being suppressed.

While the Target Detection results are not in good agreement with the truth image, the Target Detection results are not random. The two detections are in good agreement with each other. In addition, the false positives are not random or widely distributed—they cluster well and are relatively near to mapped Buddingtonite locations.

Close

1. Select File -> Close All in the Spectral Analysis Workstation, if you wish.
2. Click Yes in the Attention dialog to save changes to target_detection_lib.iwp.

Spectral Subsetting

Set Up Project

Spectral subsetting includes only the bands you specify in Target Detection analysis.

ERDAS IMAGINE must be running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.
2. Select Spectral Analysis from the Classification menu.
3. Click the Target Detection button on the Spectral Analysis menu.
   The Target Detection Wizard — Project Specification dialog displays. Create a New Project is selected by default.
4. Enter `target_detection_specsub.iwp` for the **Project File Name**.
5. Enter or select `cuprite_aviris.img` for the **Image File Name**.
6. Click **Next** in the Target Detection Wizard — Project Specification dialog.

**Select the Target Spectrum**

The Target Detection Wizard — Target Spectrum Selection dialog opens.

1. Click the Plus symbol + to expand the **USGS** Spectrum Library.
2. Click the Spectrum symbol ![spectra_icon] to select **Buddingtonite GDS85 D-206** and then hold the Shift key and select **Buddingtonite NHB2301**.
3. Click **Next** in the Target Detection Wizard — Target Spectrum Selection dialog.
Name Output File

The Target Detection Wizard — Output Specification dialog opens.

1. Click the Yes/No radio button to generate a thresholded image.

2. Use the increment nudger, or type a new Threshold of 3.00.

The threshold of 3 has been selected to give a number of detected target pixels similar to the previous results. This number can be varied to give various numbers of hits. A hit is just a user-defined level of similarity between the pixel and target spectra.

3. Enter target_specsub.img for the Output File Name.


Add Sensor Information

The Target Detection Wizard — Sensor Info Specification dialog displays.

1. Click the Use Sensor Information radio button.

2. Click the Sensor Information Tool icon.

The Sensor Information Tool dialog opens. It displays information about the sensor that acquired the image, which is obtained from the header of the image file.
Notice that the **Sensor Name** field shows **Aviris**. This is the correct sensor associated with the Cuprite dataset used in this example.

3. Click **OK** in the Sensor Information Tool dialog.

   This loads the band-to-wavelength mapping parameters for the analysis AVIRIS image and returns to the Target Detection Wizard — Sensor Info Specification dialog.

   You can also create a sensor attribute file via this dialog. See "Create a Sensor Attribute File" for more information.


**Identify Bad Bands**

The Target Detection Wizard — Bad Band Specification dialog displays.

1. Click the **Exclude Bad Bands** radio button.

2. Click the Bad Band Selection Tool icon.

Identify bad bands using the Bad Band Selection Tool, which is accessed here
3. Click the **Load** button on the Bad Band Selection Tool dialog.

4. Navigate to the directory where you saved the Bad Band List File, *aviris_badbands.bbl*.

   *NOTE: You created this file in "Bad Band Identification", "Save Band Data".*

   If you did not complete the exercise, then refer to "Identify Bad Bands” to mark bad bands using the Bad Band Selection Tool.

5. Select the file *aviris_badbands.bbl*, then click **OK** in the File Selector.

   Using the Load option populates the Bad Band Selection Tool with pre-defined bad band data.

   The specific bands targeted for removal are identified in both the CellArray and the **Mean Plot** of the Bad Band Selection Tool.

6. Click **OK** in the Bad Band Selection Tool to transfer this information to the project and Target Detection Wizard.

7. Click **Next** in the Target Detection Wizard — Bad Band Specification dialog.

   **Specify Spectral Subset**

   The Target Detection Wizard — Spectral Subset Specification dialog displays. From the previous exercise, we know we would like to focus on the wavelengths above 1800 nm.

   1. Click the **Use Spectral Subset Tool** radio button.
2. Click the Spectral Subset Tool icon.

3. Click in the Band cell for row 1 and drag through band 150 to select these rows in the CellArray. Notice the corresponding highlighting over those bands in the Mean Plot.

4. Click in the highlighted Omit column corresponding to band 150. You can click in the Omit column of any row that is not already marked. All selected rows will be marked; previously marked rows are unchanged. Previously marked rows are the bad bands.

5. Click OK.

Compute Results


2. Select the Create Output File and Proceed to Workstation option, then click OK. When processing is complete, the target mask displays in the Spectral Analysis Workstation.
Compare Results

1. In the Spectral Analysis Workstation, select **File -> Open Overlay** from the main menu.

2. Select `<IMAGINE_HOME>/examples/cuprite_classified_map.img`, then click **OK** in the File Selector.
   This is the truth image for analysis of the Target Detection results.

3. Use both the Viewer Swipe tool and Arrange Layers to compare the output, **target_specsub.img**, to the truth image, **cuprite_classified_map.img**.

   For information about how to use the Viewer Swipe tool, see "Analyze Results—Swipe". For information about the Arrange Layers dialog, see "Analyze Results—Arrange Layers”.

   You can right-click on the **target_specsub.img** bar in the Arrange Layers dialog and select the Band Combinations option to switch between displaying band 1 and band 2.
Conclusions

Comparison of the two Target Detections (bands 1 and 2 of target_specsub.img which correspond to the two spectra from the USGS library) shows that those two target masks are similar to each other. Interestingly, the results are now very comparable to the truth image. This supports the thesis that the >1800 nm region is better for mapping this material.

Note that there are, as has always been the case in these analyses, false detections to the east (right) of the mapped Buddingtonite. These detections may be a result of imperfect target signatures or inappropriate background suppression. Another possibility is that these are unmapped Buddingtonite occurrences. This possibility is strongly supported by the structure of the Cuprite site.

The hydrothermal alteration zone here is a classic bull’s-eye centered near File coordinates X: 400, Y: 230. Given this structure, the target detections at File coordinates X: 441, Y: 205 and X: 442, Y: 194 are consistent with the aureole position of the mapped Buddingtonite occurrences. Because the OSP algorithm is a subpixel detector, these analyses are indicating that these pixel positions have some Buddingtonite content, not that they are pure Buddingtonite.

If you perform Target Detection via the Spectral Analysis Workstation instead of the Target Detection Wizard, you have access to other, advanced options. These options include a choice of the method used for analysis and background estimation. The On-Line Help describes all of the Target Detection options.

Close and Exit

1. In the Spectral Analysis Workstation, select File -> Close All.

2. Click Yes in the Attention dialog to save changes to target_detection_specsub.iwp.

3. Select File -> Exit IMAGINE from the ERDAS IMAGINE menu, if you wish.

Next

In the next Tour Guide, you can learn about the Material Mapping functionality in IMAGINE Spectral Analysis.
Material Mapping

Introduction

Material Mapping is the process of searching an input image for the presence of a specific material or materials based on an input spectrum for the material(s) of interest.

The CEM algorithm attempts to maximize the response of a target spectrum and suppress the response of the unknown background. This algorithm is not intended to respond to low probability signatures (that is the role of the OSP algorithm and Target Detection). Thus, this algorithm is appropriate to the situation where the sought material is a significant component of the scene. The standard CEM operator has a unity constraint (i.e., the operator produces a value of 1 when applied to the signature itself). Most other pixels have values below this.

This matched filter algorithm is optimal for detection of distributed subpixel targets such as mineral occurrences or sparse vegetation. The CEM algorithm maps materials based on their spectrum without prior knowledge of the background clutter. Pixels that occur in sufficient quantity and with sufficient spectral character define the covariance of the (background) image statistics. Thus, any pixel that is suitably rare is not nulled and may result in a false positive.

For more information, see “Constrained Energy Minimization Algorithm”.

Before You Begin

This Tour Guide provides information about how to use spectra and band information to delineate materials of interest in an image.

In the first section of this Tour Guide, you are going to perform the following basic steps:

+ Set up the project—material_mapping_tour.iwp
+ Select spectra
+ Name the output file—cem_alunite_gds82.img
+ View the sensor information
+ Identify the bad bands
+ Compute and analyze the results
+ Compare the output to the truth image
+ Arrange the layers
The output of the Material Mapping, which uses the USGS Spectrum Library, is `cem_alunite_gds82.img`. The image is part of the IMAGINE Spectral Analysis project `material_mapping_tour.iwp`.

In this section of this Tour Guide, you are going to perform the following basic steps:

- View and save USGS data—`cuprite95map.gif` and `cuprite95map.img`
- Compare the raster images
- Change image attributes

In this section, you save an image from the internet, `cuprite95map.gif`, and use ERDAS IMAGINE to save it in *.img format, `cuprite95map.img`.

In the next series of steps, you:

- Set up the project—`material_mapping_tour.iwp`
- Create a spectrum library—`alunite_matmap.spl`
- Copy spectra
- Name the output file—`cem_alunite_6.img`
- Compute and analyze the results
- Open images
- Open a library file

After some preliminary conclusions, the exercise continues with the following steps:

- Identify the sensor
- Remove the bad bands
- Map with scene-derived spectra
- Set spectrum properties
- Copy spectra to a library
- Map the spectra—alunite_232695_map.img
- Compare to an example
- Change image attributes
- Close and exit

Approximate completion time for this portion of the Tour Guide is 30 minutes.

The library output of this exercise, alunite_matmap.spl, is used in subsequent analysis of materials. The file cem_alunite_6.img is the result of mapping with that Spectrum Library. The file alunite_232695_map.img is obtained using a scene-derived spectrum.

## Simple Material Mapping

ERDAS IMAGINE must be running.

### Set Up Project

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select **Spectral Analysis** from the **Classification** menu.

3. Click the **Material Mapping** button on the **Spectral Analysis** menu.

   The Material Mapping Wizard — Project Specification dialog displays. **Create a New Project** is selected by default.
4. Enter `material_mapping_tour.iwp` for the **Project File Name**.

5. Enter or select `cuprite_aviris.img` for the **Image File Name**.

   **NOTE:** This file is located in the `/examples` directory.

6. Click **Next** in the Material Mapping Wizard — Project Specification dialog.

**Select Spectra**


1. Click the Plus symbol `+` to expand the **USGS** Spectrum Library.

2. Click the Spectrum symbol ` взгляд` to select **Alunite GDS82 Na82**.


**Name Output File**


1. In a directory where you have write permission, enter `cem_alunite_gds82.img`.

2. Click **Next** in the Material Mapping Wizard — Output Specification dialog.
**View Sensor Info**


Since you have elected to use a signature that is not from the analysis image, which is identified as `cuprite_aviris.img`, it is necessary for the software to convolve the analysis signature bandpass characteristics to conform to the image bandpass characteristics. This requires that the sensor information for the analysis image be present.

1. Click the **Use Sensor Information** radio button.
2. Click the Sensor Information Tool icon 📊.

Notice that the **Sensor Name** field shows *Aviris*. This information is derived from the header data of the analysis image, `cuprite_aviris.img`.

3. Click **OK** in the Sensor Information Tool dialog.
The advantages of removing corrupt data layers (bands) from the analysis have been discussed in both “Anomaly Detection” and “Target Detection”. The same considerations apply to Material Mapping.

1. Click the **Exclude Bad Bands** radio button.

2. Click the Bad Band Selection Tool icon .

3. Mark bands 1, 2, 13, 108 through 113, 153 through 166, and 221 through 224 as bad bands, or you can click the **Load** button in the Bad Band Selection Tool dialog and select the Bad Band List File you created, `aviris_badbands.bbl`.

   NOTE: You created the *.bbl file in “Bad Band Identification”, “Save Band Data”.

   For instructions about how to mark bad bands, see “Identify Bad Bands”.

4. Click **OK** to transfer this information to the Material Mapping Wizard.

**Compute Results**

1. Click **Finish** in the Material Mapping Wizard — Bad Band Specification dialog.

2. Select the **Create Output File and Proceed to Workstation** radio button, then click **OK**.

**Analyze Results**

When processing is complete, the Spectral Analysis Workstation opens and the material map displays on top of the input image.
The accuracy of this analysis can only be determined by comparison of these results to results from other work in the Cuprite area, preferably field work. As discussed in “Cuprite Dataset”, this area has been extensively studied to create accurate geological maps. For this particular analysis, the classification map located in the /examples directory and/or two on-line articles can be used for verification.

**Compare Output to Truth Image**

1. In the Spectral Analysis Workstation, select **File -> Open Overlay** to display a File Selector.

2. Select **cuprite_classified_map.img**, then click **OK** in the File Selector.

   *NOTE: The file is located in the /examples directory.*

The classified image of the Cuprite area displays on top of the calculated material map.
3. In the Main View, right-click and select **Arrange Layers**.

4. In the Arrange Layers dialog, right-click on **cuprite_classified_map.img**.
5. Select **Attribute Editor** from the **PseudoColor Options** menu. A Raster Attribute Editor dialog opens with a CellArray displaying **Histogram** data, which indicates the number of pixels and **Color** information about classes represented in this image.

6. In the Raster Attribute Editor CellArray, right-click in the **Row** column and choose **Select All** from the **Row Selection** menu.

7. Click in the **Color** column, then select **Black**.

8. Right-click in the **Row** column and choose **Select None**.

9. In the CellArray, click **Row 59**, then click in the **Color** cell and select **Red**.

10. In the CellArray, click **Row 80**, then click in the **Color** cell and select **Red**.
The Cuprite truth image, `cuprite_classified_map.img`, redisplay in the Main View.
Do not save the changes to the color table for `cuprite_classified_map.img`.

**Arrange Layers**

1. In the Arrange Layers dialog, click `cem_alunite_gds82.img` and drag it to the top of the list.

   *NOTE: You created this image in "Simple Material Mapping", "Name Output File".*

2. Click **Apply** in the Arrange Layers dialog.

3. In the Arrange Layers dialog, right-click on `cem_alunite_gds82.img`.

4. Select **Attribute Editor** from the **PseudoColor Options** menu.

   *The file `cem_alunite_gds82.img` must be loaded into the Workstation as a pseudo color image. If not, the **Attribute Editor** option is not available. If your preferences are set to load it as another type, such as gray scale, you must first delete the layer. Then add it as an overlay, making sure that the display is set to pseudo color.*
A Raster Attribute Editor dialog opens with a CellArray containing **Histogram** and **Color** information about this image. The **Value** column provides the DN value of the pixel(s).

5. Click, hold, and drag in the **Row** column to select rows **103** through **255**.

   *Alternately, select rows **0** through **102**, right-click on the **Row** column, then choose **Invert Selection**.*

The decision to make the lower end cutoff at column **103** was subjective. For example, if you select columns **100** through **101** and make them also green, many of the additional points are scattered randomly throughout the image, so this may represent too low of a threshold.

6. Click in a highlighted **Color** cell and select the color **Green**.

All selected classes appear green in the material map you created, **cem_alunite_gds82.img**.
Green areas in the material map are classified as Alunite

7. Right-click in the Main View and select **Swipe**.
8. Use the Viewer Swipe tool and Arrange Layers to compare the two pseudo color layers (cem_alunite_gds82.img, which is the material map, and cuprite_classified_map.img, which is the truth image).

For information about how to use the Viewer Swipe tool, see "Analyze Results—Swipe". For information about the Arrange Layers dialog, see "Analyze Results—Arrange Layers".

9. Close the Attribute Editors by clicking the Close icon in each one.

10. Click No in each of the Verify Save on Close dialogs.

Close

1. In the Spectral Analysis Workstation, select File -> Close All.

2. Click Yes in the Attention dialog to save material_mapping_tour.iwp.
Conclusions

This example of Material Mapping shows how easily you can map a specific material of interest in an analysis image. You compare your results to a truth image in the next example. Then, you can learn how to use multiple signatures in your analysis.

Compare to On-Line Images

In the article “Mapping Minerals with Imaging Spectroscopy” (Clark et al. 1993a), the image E1-E2 shows the mineral Alunite mapped in green. Comparison to this image is performed in the following section.

See “Bibliography” for the full reference and URL to this image.

Figure 7: Image E1-E2 Showing Alunite in Green

Set Up

ERDAS IMAGINE must be running.

1. Click the Viewer icon on the ERDAS IMAGINE icon panel.

   If necessary, select the type of Viewer you want to work with.

2. From the Viewer menu, select File -> Open -> Raster Layer.
3. Select the file `cem_alunite_gds82.img`.

   *NOTE: This image was created in “Simple Material Mapping”, “Name Output File”.*

4. Click the **Raster Options** tab at the top of the File Selector.

5. Click the **Display as** popup list and click to select **Pseudo Color**.

6. Confirm that **Fit to Frame** is checked.

7. Click **OK** in the File Selector. The file displays in the Viewer with no obvious attributes.

8. From the Viewer menu, select **Raster -> Attributes**.

   A Raster Attribute Editor dialog opens containing a CellArray with the **Histogram** and **Color** information about this image.

9. Click, hold, and drag to select **Rows 103** through **255**.

10. Click in the **Color** column of a highlighted cell, then select the color **Green**. Right click in the Row column and select **Invert Selection** and then select the color **Black**.
All the selected pixels appear green in the displayed image; the rest are black. This image now compares favorably with the image pictured in Figure 7.

**View USGS Data**

In the article “*Imaging Spectroscopy Material Maps: Cuprite Introduction*” (Clark and Swayze 1998), the third image shows the mineral Alunite mapped in red.

1. In your internet browser, enter the following URL: http://speclab.cr.usgs.gov/map.intro.html.
2. Click on the third image, which is labeled **273K GIF**, to display it in your browser window.
Compare to On-Line Images

Figure 8: USGS Image: cuprite.95.tgif.2.2um.map

3. Select **File -> Save As** from the browser menu bar.

4. Navigate to a directory where you have write permission.

5. In the **File name** field, type the name **cuprite95map.gif**, then click **Save** in the dialog.

6. Minimize your browser window by clicking the Minimize icon ☐.

   *NOTE: If you do not have access to this article, the image cuprite_classified_map.img in /examples is a subset of cuprite95.tgif.2.2um.map.*

**Compare Raster Images**

1. Open a Viewer by clicking the Viewer icon on the ERDAS IMAGINE icon bar.

   ![Viewer](image)

   If necessary, select the type of Viewer you want to work with.

2. In the Viewer, click on **File -> Open -> Raster Layer**.

3. In the File Selector, click the **Files of type** dropdown list and choose GIF (*.gif).

4. Select the image you just saved, **cuprite95map.gif**, then click **OK**.
The Viewer displays images in *.gif format directly—there is no need to import them. However, to manipulate the raster attributes in the following exercise, it is necessary to create an ERDAS IMAGINE *.img file.

5. In the Viewer displaying cuprite95map.gif, select File -> Save -> Top Layer As.

6. In the File Selector, navigate to a directory in which you have write permission.

7. Name the file as cuprite95map.img, then click OK.
   A Job Status dialog opens, tracking the progress of the save operation.

8. Click OK in the Job Status dialog when the process is 100% complete.

The presence of the Job Status dialog after processing is complete is dependent on a preference setting in the User Interface & Session category, Keep Job Status Box.

Change Attributes

1. In the Viewer, which now displays cuprite95map.img, click on Raster -> Attributes.
A Raster Attribute Editor containing a CellArray opens with the Histogram and Color information about this image.

2. In the Row column, right-click to access the Row Selection menu, then click Select All.

3. In the Color column, click and select Black for all classes.

4. Right-click in the Row column and choose Select None.

5. In the CellArray, click in the Color column and make classes 59 and 80 Red.

These are the results from the USGS survey of the Cuprite, Nevada area.

6. Compare the results in cuprite95map.img with the results in cem_alunite_gds82.img.

NOTE: You created cem_alunite_gds82.img in “Simple Material Mapping”, ”Name Output File”.
Close

1. Select **Session -> Close All Viewers** from the ERDAS IMAGINE menu bar.

2. Click **No** in the dialogs when prompted to save changes.

Conclusions

The two classified images are similar but not identical. As we found in Target Detection, the results are very dependent upon the input signature. For this analysis, one of the USGS Spectrum Library spectra was selected. Selection of a different input signature yields slightly different results.

Material Mapping with Multiple Signatures

It may be desirable to map a number of materials (spectra) at the same time. These could be different spectra of the same material (as in this exercise), or they could be spectra of different materials such as a soils type, two vegetation spectra, and a cement pavement spectrum.

Set Up Project

ERDAS IMAGINE must be running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select **Spectral Analysis** from the **Classification** menu.

3. Click the **Material Mapping** button on the **Spectral Analysis** menu.

4. Click the **Use an Existing Project** radio button.

5. Enter **material_mapping_tour.iwp** for the **Project File Name**. If necessary, click the Open icon to access a File Selector and browse for the project file.

   *NOTE: This project was created in "Simple Material Mapping", "Set Up Project".*

6. Click **Next** in the Material Mapping Wizard — Project Specification dialog.

Create Spectrum Library


1. Right-click in the Spectrum Library window to access the **Spectrum TreeView** menu.

2. Click to select **Create a blank spectrum library**.

The New Spectrum Library dialog opens.
3. Type **Alunite** in the **Spectrum Library Name** field, then press Enter on the keyboard.

4. Click **OK** in the New Spectrum Library dialog.

5. In the Spectrum Library window, right-click on Book symbol 📚 for the **Alunite** library, then select **Save As**.

6. Navigate to a directory where you have write permission.

7. Type **alunite_matmap.spl** in the **File name** window of the File Selector, then click **OK**.

### Copy Spectra

1. Click the Plus symbol + to expand the **USGS** Spectrum Library.

2. Select all six **Alunite** spectra by clicking the Spectrum symbol 📈 of the first entry, then holding down the Shift key as you click the last one.

3. Right-click and choose **Copy** from the **Spectrum Item** menu.

4. Scroll down and right-click on the Book symbol 📚 for the spectrum library you just created, **Alunite**.

5. Select **Paste** from the **Spectrum Library** menu.

6. Right-click again on the **Alunite** library, and select **Save** from the **Spectrum Library** menu.

7. Click the Plus symbol + to expand the **Alunite** Spectrum Library file.

8. Select all six **Alunite** spectra by clicking the first entry, then holding down the Shift key as you click the last one.

---

*Alternately, just click the Book symbol 📚 for the **Alunite** library to include all spectra in that library.*

**Name Output File**


1. In a directory where you have write permission, enter `cem_alunite_6.img`, then click **OK**.

   *NOTE: The sensor information and bad band files for this image are stored in the project file, `material_mapping_tour.iwp`, so it is not necessary to re-enter this information.*

**Compute Results**


2. Keep the default setting of **Create Output File and Exit**.

3. Click **OK** in the Material Mapping dialog.

   A Job Status dialog opens to track the progress of the Material Mapping.

**Analyze Layers**

Once the computation is complete, indicated by the closing of the Job Status dialog, you can view the results in a multilayer arrangement.

1. Click the Viewer icon on the ERDAS IMAGINE icon panel.
2. In the Viewer, click on **File -> Open -> Multi Layer Arrangement.**

3. Select **cem_alunite_6.img**, then click **OK** in the File Selector.

   *NOTE: You just created this image in “Material Mapping with Multiple Signatures”, “Name Output File”.*

   Seven Viewers display. The uppermost Viewer displays the input image as a 3-band composite.

4. Close the uppermost Viewer by clicking the Close icon \( \times \).

5. From the ERDAS IMAGINE menu bar, click on **Session -> Tile Viewers.**

   The six remaining Viewers redistribute across the screen.

   ![Six Viewers Distribution](image)

   It is now possible to visually compare the results of Material Mapping with the six different USGS Alunite signatures. Clearly, selection of the input signature has a significant effect on the mapping results.

6. Click the Close icon \( \times \) in each Viewer except the Viewer that contains Layer 5.

---

**Open Images**

1. In the **Spectral Analysis** menu, select **Spectral Analysis Workstation.**

2. Select **File -> Open Analysis Image.**
3. Choose `cuprite_aviris.img` from the `/examples` directory, then click OK in the File Selector.

4. Select File -> Open Overlay and choose `cem_alunite_gds82.img`.

   **NOTE:** This is the file you created in “Simple Material Mapping”, “Name Output File”.

5. Click the Raster Options tab and select Pseudo Color in the Display as field, then click OK in the File Selector.


7. Choose `cuprite_classified_map.img` from the `/examples` directory, then click OK in the File Selector.

8. Use the cursor to expand the corners of the Spectral Analysis Workstation to fill the entire screen, or click the Maximize icon.

9. Move the mouse over the edge of the Spectrum Plot until it becomes a double-headed arrow.

10. Click and drag upward so that the Spectrum Plot fills half of the Spectral Analysis Workstation.

11. Resize the other components of the Spectral Analysis Workstation to your liking.

**Open Library File**

1. Right-click in the Working Libraries window (the bottom library window) and select Open a spectrum library file.

2. Select `alunite_matmap.spl` from the directory in which you saved it.

   **NOTE:** You created this file in “Material Mapping with Multiple Signatures”, “Create Spectrum Library”.

3. Click OK in the File Selector.

4. Drag and drop the Alunite library, which contains the six USGS Alunite spectra, into the Spectrum Plot at the bottom of the Spectral Analysis Workstation.

   The six Alunite spectra are displayed. Note the differences and similarities between these mapping input spectra.

   If some spectra are displayed in colors that make visual interpretation difficult, highlight the problem spectrum in the Legend and right-click to select Legend Editor, then change the color.
Alunite HS295.3B shows an absorbance at 1002 nm that the other spectra do not have. Its absorbance at 1266 nm is stronger than most. In the 450-650 nm region, it seems to have a weak absorbance not as pronounced as in some of the other Alunite spectra.

5. Click on the Minimize icon in the upper right of the Spectral Analysis Workstation to shrink it and reveal the Viewer with the individual mapping layer.

Layer 5 of cem_alunite_6.img, which displays in Viewer #6, corresponds to the Alunite HS295.3B input spectra (the fifth input spectra in the library used in Material Mapping). Note how the differences in the spectrum translate into a different mapping pattern.
6. Select **Session -> Close All Viewers** from the ERDAS IMAGINE menu bar.

**Preliminary Conclusions**

The results of the Alunite mapping are in good agreement with each other and, importantly, in agreement with published results. As with Target Detection, selection of the input material spectrum has a significant effect on the output Material Mapping results.

As discussed in “**Spectral Analysis Theory**”, the variability of materials in nature is nearly infinite. In this particular instance, a mineral (Alunite) is being mapped. The exact spectral shape of a mineral is determined by factors such as ionic substitutions in the mineral lattice, degree of crystallinity of the sample, and particle size. All of these vary not only between sites but even within a particular site.

A second, and synergistic, factor affecting this analysis is that the CEM algorithm is a subpixel detector. Thus, given a constant material composition, the magnitude of the response (DN value) is a function of the percent of that material in the (mixed) pixel. However, in a natural setting these two factors, endmember variability and pixel concentration (pixel fill), are interwoven.

For example, a pixel that is half filled with material whose spectrum exactly matches the input signature spectrum could give the same response magnitude as a pixel that is, say, three-fourths filled with the same mineral, but has a lot of trace element substitutions and poor crystallinity.
The interpretation of the intensity of the response, or the setting of a threshold, is affected by these two synergistic factors and they cannot be separated. For this reason, scene-derived input spectra are nearly always preferable. Here, we are discussing the spectra of naturally occurring materials. Human-made materials, such as a particular paint, can be quite homogenous and consistent from place to place. For such materials, a library spectrum can very representative.

**Identify Sensor**

1. Return to the Spectral Analysis Workstation, which currently displays the truth image, cuprite_classified_map.img, as the top layer.

2. Click the Sensor Information Tool icon in the toolbar of the Spectral Analysis Workstation.

3. Click OK in the Sensor Information Tool dialog to confirm the Aviris_1995 sensor is correct.

**Remove Bad Bands**

1. Click the Bad Band Selection Tool icon in the toolbar of the Workstation.

2. In the Bad Band Selection Tool dialog, click the Load button.

3. Choose the Bad Band List File you created, aviris_badbands.bbl, then click OK in the File Selector.

   *NOTE: You created this file in "Bad Band Identification", "Save Band Data".*

   If you did not complete the exercise, then refer to "Identify Bad Bands" to mark bad bands using the Bad Band Selection Tool.

4. Click OK in the Bad Band Selection Tool dialog to transfer this information to the Workstation.

**Map with Scene-Derived Spectra**

Given concerns about the applicability of library spectra for mapping of mineral occurrences, the previous analysis, "Material Mapping with Multiple Signatures" should be redone using a scene-derived spectrum as the Material Mapping input.

1. In the Zoom View, right-click and select Inquire Cursor from the Quick View menu.

2. Enter the Map pixel X coordinate 232, and a Y coordinate -695.

   *NOTE: The values you enter are modified slightly by the software to account for image resampling.*
3. Right-click in the Zoom View and select **Zoom | Zoom In By 2** as many times as necessary to clearly see the identified pixel in the view.

The Inquire Cursor displays at the pixel coordinates you entered.

![Image of pixel coordinates](image1.png)

> Remember, you can change the color of the Inquire Cursor in the view by first selecting Inquire Box from the Quick View menu, then choosing a new Box Color.

4. In the Spectral Analysis Workstation toolbar, click the Color Chooser icon 🔨, then select the color **Black**.

5. Click the Create Point icon ⌛ in the Spectral Analysis Workstation toolbar.

6. Click at the intersection of the Inquire Cursor to collect the spectrum of Map pixel **232, -695**.

The spectrum of that pixel appears in the Spectrum Plot and is labeled **Sample 1**.
NOTE: The classified map image has been used as a guide to aid in the selection of a pixel spectrum to use for this Alunite mapping. Even though the overlay image is on top in the view, the spectrum is taken from the underlying analysis image.

Set Spectrum Properties

1. Click to select Sample 1 in the Spectrum Plot Legend.
2. Right-click and select Spectrum Properties from the Options menu.
3. Rename Sample 1 to alunite_scenederived in the Name field.
4. Click OK in the dialog to accept the new name.

Copy Spectra to Library

1. Click and hold on alunite_scenederived in the Spectrum Plot Legend.
2. Drag it to Material List 1 in the Working Library window.

Map Spectra

1. Click the Plus symbol to expand Material List 1.
2. Click on the Spectrum symbol of **alunite_scenederived** to indicate that it is the material to be mapped.

3. Click the Material Mapping icon to put the Spectral Analysis Workstation in the Material Mapping mode.

4. Click the Execute icon to initiate the Material Mapping analysis.

The Material Mapping Options dialog opens.

The default values in the Material Mapping Options dialog are appropriate for this analysis.

5. Confirm that the **Method** is set to **Constrained Energy Minimization**.

6. Type the **Output File** name **alunite_232695_map.img**, then press Enter on the keyboard.

7. Click **OK** in the Material Mapping Options dialog to start the Material Mapping process.

When the analysis is finished, which is indicated by the Status Bar at the bottom of the Spectral Analysis Workstation, the output Alunite map displays in the views.

**Compare to Example**

The file **alunite_232695_map.img** displays as the top layer in the Spectral Analysis Workstation.

1. In the Main View, right-click and select **Arrange Layers**.

2. In the Arrange Layers dialog, right-click on **alunite_232695_map.img** and select **Attribute Editor**.

   If the image is not loaded in Pseudo Color, add it as an overlay and choose **Pseudo Color** display on the **Raster** tab.

A Raster Attribute Editor containing a CellArray opens with the **Value, Histogram**, and **Color** information about this image.
3. Click, hold, and drag in the Row column to select rows 100 through 255.

NOTE: After row 150, most of the Histogram values, which correspond to number of pixels in a class, are 0.

4. Click in a highlighted Color cell and select the color Red.

5. Right click in the Row column and select Invert Selection from the options menu.

6. Change these pixels in rows 0 through 99 to Black to increase the contrast.

The decision to make the lower end cutoff at column 100 is subjective. For example, select columns 97 through 99 and make them also red. A lot of the additional points are now seen to be scattered throughout the image, so this may represent too low of a threshold.

7. In the Arrange Layers dialog, move cuprite_classified_map.img to the top of the Arrange Layer stack.

8. Click Apply in the Arrange Layers dialog.

Changes you make in the Attribute Editor appear in the view from which you started the Arrange Layers dialog
Change Attributes

1. In the Arrange Layers dialog, right-click on cuprite_classified_map.img and select Attribute Editor. A Raster Attribute Editor containing a CellArray opens with the Histogram and Color information about this image.

2. In the CellArray, right-click in the Row column to access the Row Selection menu.

3. Click Select All.

4. In the Color column, click and make all classes Black.

5. Right-click and choose Select None from the Row Selection menu.

6. In the CellArray, click rows 59 and 80, then click in the Color cell and select Red.

7. Use the Viewer Swipe tool and Arrange Layers to compare cuprite_classified_map.img, which is the truth image, and alunite_232695_map.img, which is the scene-derived image.

For instructions on how to use the Viewer Swipe tool, see "Analyze Results—Swipe". For information about the Arrange Layers dialog, see "Analyze Results—Arrange Layers".
Conclusions

The two classified map images, alunite_232695_map.img and cem_alunite_gds82.img, are now strikingly similar. Taking the spectrum of the material to be mapped from the image being classified is clearly preferable. In this analysis, the spectrum of just one pixel is used. In practice, an average of multiple pixels might be preferable since this better represents the variability of the material in the area under study.

Close and Exit

1. Select File -> Close All from the Spectral Analysis Workstation menu.
2. Click No in the Attention dialog to save changes to the file.
3. Close any remaining Viewers and dialogs by clicking the Close icon.
4. Select Session -> Exit IMAGINE if you wish.

Next, you learn how to perform Material Identification using the IMAGINE Spectral Analysis module.
Material Identification

**Introduction**

Material Identification is an algorithmic approach to determining the material composition of a pixel by comparing the unknown pixel spectrum to a list of candidate materials for which the spectra are known. The algorithm calculates a mathematical similarity index value comparing the unknown spectrum to each of the known spectra. The results are displayed in a ranked list.

**Before You Begin**

In the next series of steps, you learn how to use sample spectra to identify similar spectra in your analysis images.

“Simple Material Identification”

In this section of the Tour Guide, you are going to perform the following basic steps:

- Set up the Workstation
- Open an analysis image
- Identify bad bands
- Create a Working Library
- Save the Working Library—*alunite_matid.spl*
- Identify the sample
- Identify material
- Run Material Identification process
- Export results—*alunite.dat*

Approximate completion time for this Tour Guide is 10 minutes.

One output of this Material Identification is a Working Library that you can apply to other analysis images. This library, *alunite_matid.spl*, contains only spectra for the material Alunite, which were derived from pre-existing Archive Libraries. The other output is a data file (*.dat), *alunite.dat*, that contains the match ranking of the library spectra to a sample you identify in the image.

“Using Spectral Subset”

In this section of the Tour Guide, which is a continuation of the previous section, you perform the following basic steps:

- Evaluate spectra
- Subset spectra
- Run Material Identification process
- Evaluate results
- Save the project—\texttt{matid\_tour.iwp}
- Close and exit

\textit{Approximate completion time for this Tour Guide is 10 minutes.}

This portion of the exercise shows you how to apply the Spectral Subset Selection Tool to use only specific wavelength ranges for Material Identification analysis. You save the results to an IMAGINE Spectral Analysis project file, \texttt{matid\_tour.iwp}.

\section*{Simple Material Identification}

\subsection*{Set Up Workstation}

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select \textbf{Spectral Analysis} from the \textbf{Classification} menu.

3. Click the \textbf{Spectral Analysis Workstation} button on the \textbf{Spectral Analysis} menu.

   The Spectral Analysis Workstation displays.

4. Click the Maximize icon so that the Workstation fills your screen, and adjust the size of the Spectrum Plot so that it occupies about half of the Workstation.

5. Resize other components of the Spectral Analysis Workstation to your liking.

\subsection*{Open Analysis Image}

1. Select \textbf{File -> Open Analysis Image} from the Workstation menu bar.

2. Navigate to the /examples directory, and select \texttt{cuprite\_aviris.img}.

3. Click \textbf{OK} in the File Selector.
4. Select **View -> Preset RGB Combinations | True Color**.
The analysis image redisplay in the Spectral Analysis Workstation.

Identify Bad Bands

Identifying bad bands can improve the Material Identification results.

1. Click the Bad Band Selection Tool icon on the Spectral Analysis Workstation toolbar.

2. Using the Bad Band Selection Tool, mark bands 1, 2, 13, 108 through 113, 153 through 166, and 221 through 224 as bad bands, or click **Load** and select the *.bbl file you created in “Save Band Data”, aviris_badbands.bbl.

   **NOTE:** You created this file in “Bad Band Identification”, “Save Band Data”.

   If you did not complete the exercise, then refer to “Identify Bad Bands” to mark bad bands using the Bad Band Selection Tool.

3. Click **OK** in the Bad Band Selection Tool dialog to transfer the information back to the Spectral Analysis Workstation.
Create Working Library

1. In the Archive Libraries window, click on the Plus symbol + to open the USGS Spectrum Library.

2. Click the first Alunite entry, then hold down the Shift key on the keyboard and click and last Alunite entry. This selects all entries.

3. Hold down the mouse button and drag those entries to the Working Library, Material List 1.

4. Click the Plus symbol + next to Material List 1 to see the Alunite spectra that have been copied to the Working Library.

5. Right-click the Book symbol for Material List 1 and select Rename from the Spectrum Library menu.

6. In the Rename Spectrum Library dialog, type the name Alunites, then click OK.

7. Return to the Archive Libraries window and click the Plus symbol + next to JPL.

8. Use the Shift-click method to select all of the Alunite spectra in that library.

9. Drag the spectra to the Alunites Working Library.
The **Alunites** Working Library now has nine spectra you can use in Material Identification.

### Save Library

1. Right-click the Book symbol for the **Alunites** Working Library and select **Save As** from the **Spectrum Library** menu.

2. In the File Selector, navigate to a directory and folder where you have write permission.

3. Type the name `alunite_matid.spl`, then click **OK** to save the Spectrum Library file.

4. Click the Book symbol to select the **Alunites** Working Library. Selecting the library indicates that this is the list of candidate spectra for Material Identification.

### Identify Sample

In this example, it helps to change the color of the Inquire Cursor.

1. Right-click in the Zoom View and select **Inquire Box** from the Quick View menu.

2. In the **Box Color** section of the dialog, click the Color Chooser icon.

3. Select the color **Red**.

4. Click **Apply**, then **Close** in the Inquire Box dialog.

5. Right-click in the Zoom View and select **Inquire Cursor** from the Quick View menu.

6. In the Inquire Cursor dialog, type the following **Map** coordinates into the **X** and **Y** fields, respectively: **232, -698**.

   *NOTE: The values you enter are modified slightly to account for image resampling.*
7. Right-click in the Zoom View and select **Zoom -> Zoom In By 2** as many times as necessary in order to see the exact pixel beneath the Inquire Cursor.

The sample pixel is at the intersection of the Inquire Cursor

**Identify Material**

1. Click the Color Chooser icon 🖌️, then select **Red**.

2. Click the Create Point icon �idental, then select the **Map** pixel located at coordinates **232, -698** displayed in the Zoom View.

💡 You may use the Status Bar at the bottom of the Spectral Analysis Workstation, which displays pixel coordinates, to help you place the point.
Notice that the spectrum for this particular pixel, or sample, is added to the Spectrum Plot at the bottom of the Spectral Analysis Workstation.

The point is identified in each of the views (shown here inside the three red circles)

3. Click **Close** in the Inquire Cursor dialog.

4. Click the Material Identification icon in the Spectral Analysis Workstation toolbar.
   The Material Identification cursor displays in the Spectral Analysis Workstation.

5. Click and hold the intersection of the Material Identification Inquire Cursor, then move it over the pixel you selected, **Sample 1**.

Run Material Identification

1. Click the Execute icon to initiate Material Identification.
   The Material Identification Options dialog opens.
2. In the **Rank the Best Materials** field, enter the number of Alunite spectra in the **Alunites** Working Library you created, **9**.

3. Click **OK** in the Material Identification Options dialog.

   The Material Identification yields a CellArray, which displays at the bottom of the Spectral Analysis Workstation. You may want to resize the CellArray so it only occupies as much of the bottom of the Workstation as is necessary.

   In this CellArray, you can see which of the Alunite spectra are most closely matched to the sample you collected in the analysis image. The spectra in the Working Library, **Alunites**, are ranked from best to worst (that is, 1 through 9).

4. In the **Alunites** Working Library, click the Spectrum symbol for the best match, **Alunite GDS82 Na82**, and drag it to the Spectrum Plot.

5. In the **Alunites** Working Library, click the Spectrum symbol for the worst match, **Alunite HS295.3B**, and drag it to the Spectrum Plot.
To improve the display of the spectra in the Spectrum Plot, see "Optimize the Spectrum Plot".

Export Results

You can save the results so that you can refer to them later.

1. In the Results from Material Identification CellArray, right-click the title of the Material column heading and select Export from the Column Options menu.

2. In the Export Column Data dialog, navigate to a directory and folder where you have write permission, then name the file alunite.dat.

3. Click OK in the Export Column Data dialog.

4. Continue on to the next portion of the Tour Guide, "Using Spectral Subset".

Conclusions

This simple exercise has shown you how easy it is to select a pixel in the analysis image and then identify similar areas throughout the image.
Using Spectral Subset

**NOTE:** To complete this exercise, you must first complete the preceding exercise, “Simple Material Identification”. You must also have a Spectral Analysis Workstation open, which displays the analysis image, cuprite_aviris.img and the Working Library Alunites.

**Evaluate Spectra**

ERDAS IMAGINE must be running.

1. Click the Plus symbol \( + \) next to the ASTER Archive Library.

   **NOTE:** Because of its size and ASCII format, this library takes a few moments to load.

2. Scroll through the list until you find the Alunite entries.

3. Click the Spectrum symbol \( \text{ Spectrometer Symbol } \) of the first Alunite spectra, Alunite (ammonioalunite) \( \text{NH}_4\text{Al}_3(\text{SO}_4)\text{H}_6 \), and drag it to the Spectrum Plot.

   An ASTER spectrum only contains spectral information at the far infrared range. Most sensors do not cover the full VIS, NIR, SWIR, and TIR spectral range.

4. Use the Shift-click method to select all of the Alunite spectra in the ASTER Archive Library.

5. Drag the spectra to the Alunites Working Library.

6. Right click the book symbol \( \text{ Save Symbol } \) for the Alunites Working Library, then select **Save**.

   The Alunites Working Library now has 25 spectrum entries for the mineral Alunite.
**Subset Spectra**

The Spectral Subset Selection Tool is similar to the Bad Band Selection Tool in that it allows you to mark specific bands for analysis. The Bad Band Selection Tool is used to “permanently” remove bands from analysis; the Spectral Subset Selection Tool is used to identify only certain bands to use in analysis.

1. Click on the Spectral Subset Selection icon in the Spectral Analysis Workstation toolbar.

   The Spectral Subset Selection Tool dialog opens. Here, you can select specific bands and wavelengths to use in Material Identification.

2. Scroll to the bottom of the Spectral Subset Selection Tool dialog CellArray.

3. Click and hold in the row labeled Band number 224 and drag upward to Band number 182.

   The bands are highlighted in the CellArray.

4. Right-click in the Band column and select Invert Selection from the Row Selection menu.

5. Click in any highlighted Omit cell to omit all of the selected bands.

   *NOTE: Some bands are already omitted from analysis due to use of the Bad Band Selection Tool. The Spectral Subset Selection Tool does not affect those bands’ status.*

6. Right-click in the Band column and select Select None from the Row Selection menu.
7. Make sure that the **Use** checkbox is checked in the top right corner of the dialog.

8. Click **OK** in the dialog to transfer this information back to the Spectral Analysis Workstation.

---

### Run Material Identification

1. In the Working Libraries window, click the Book symbol 📚 to select the **Alunites** library.

2. Click the Execute icon 🔄 to initialize the Material Identification.

3. In the Material Identification Options dialog, enter the new number of materials in the **Alunites** Working Library, **25**, in the **Rank the Best** window.
   
   All of the remaining defaults are appropriate for this analysis.

4. Click **OK** in the Material Identification Options dialog to initiate the identification.

---

### Evaluate Results

The results are displayed in the CellArray.
Notice the spectra that most closely matches that of the sample you collected from the analysis image. Also notice the worst-ranked spectra.

5. Click, hold, and drag the best spectra from the Alunites Working Library to the Spectrum Plot.

If you wish, you can change the Chart Options to improve the display of the spectra in the Spectrum Plot.
If you want to export the contents of the Material Identification CellArray to a *.dat file, follow the instructions in "Export Results".

Close and Exit

1. Select File -> Close All in the Spectral Analysis Workstation, if you wish.
2. Click Yes in the Attention dialog to save changes to the project file.
3. Navigate to a directory where you have write permission, then name the file matid_tour.iwp.
4. Select Session -> Exit IMAGINE from the ERDAS IMAGINE menu, if you wish.

Conclusions

Using the Spectral Subset Selection Tool, you have more control over the accuracy of your results. Also, you can use many Spectral Library entries in your analysis.

Next

Next, you can see how IMAGINE Spectral Analysis is used in a complete workflow.
Spectral Analysis Workstation

**Introduction**

This chapter presents a cohesive approach to spectral analysis, rather than task-by-task as in previous chapters.

*For general information about the Spectral Analysis Workstation components, see “Spectral Analysis Workstation”.*

**Before You Begin**

This Tour Guide is divided into sections.

“Create a Spectral Analysis Project”

In the first section of this Tour Guide, you are going to perform the following basic steps:

- Open the analysis image
- Edit color and band assignments
- View sensor information
- Save the project—`cuprite_tour.iwp`
- Create a spatial subset
- Identify bad bands
- Create a spectral subset
- Collect a spectral signature
- Run Target Detection—`target_372_578.img`
- Examine results

*Approximate completion time for this portion of the Tour Guide is 30 minutes.*

The output of this exercise, `cuprite_tour.iwp`, is used in subsequent analyses and applications. You also create a target spectra that is used in the Target Detection process to create `target_372_578.img`.

“Using an Overlay”

In this section, you perform the following basic steps:

- Open an overlay
• Collect multiple spectra
• Change the Spectrum Plot
• Create spectrum library—**budd_aoi.spl**
• Create merged spectrum
• Collect AOI spectrum
• Add and view spectrum
• Run Target Detection
• Examine results—**budd_average.img**
• Close and exit

Approximate completion time for this portion of the Tour Guide is 25 minutes.

You create a Spectrum Library file in this exercise, **budd_aoi.spl**. An AOI with average spectra information is used to make **budd_average.img**.

---

**Create a Spectral Analysis Project**

**Open the Analysis Image**

ERDAS IMAGINE must be running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select **Spectral Analysis** from the **Classification** menu.

3. From the **Spectral Analysis** menu, select **Spectral Analysis Workstation**.
   The Spectral Analysis Workstation displays.

4. Click the Maximize icon so that the Workstation fills your desktop, and adjust the Workstation components’ size to your liking.

5. From the **File** menu, select **Open Analysis Image**.

6. Select `/examples/cuprite_aviris.img`, then click **OK**.
The image displays in the Spectral Analysis Workstation in all three views. You can alter the red, green, and blue components to change the display of the image in the Spectral Analysis Workstation. Also, you can set a preference in the Spectral Analysis category of the Preference Editor, RGB Band Combination Preference, which determines the settings used when images are loaded into the Spectral Analysis Workstation.

**Edit Color/Band Associations**

1. In the Workstation, select View -> Preset RGB Combinations -> False Natural Color.
   The image redisplay in the Workstation with the new color/band associations.

2. Select View -> Preset RGB Combinations -> True Color.

**View Sensor Information**

1. Click the Sensor Information Tool icon on the Spectral Analysis Workstation toolbar.
The Sensor Information Tool dialog opens.

The sensor type is determined from the image

The bands and their characteristics are listed in the CellArray

The Sensor Information Tool dialog is populated with the AVIRIS sensor data, which is read by the software from the analysis image.

For information on creating *.saf files for sensors that are not listed in the /etc directory, see “Create a Sensor Attribute File”.

2. Click OK in the Sensor Information Tool dialog.
   This loads the band-to-wavelength mapping parameters for an AVIRIS image into the Spectral Analysis Workstation.

   NOTE: Cursor location, when positioned inside the Spectrum Plot, is also displayed as band number in the Status Bar.

Save the Project

1. In the Spectral Analysis Workstation, select File -> Save As to open a File Selector.

2. Navigate to your work directory and name the project file cuprite_tour.iwp, then click OK.

Create Spatial Subset

You do not necessarily have to use the entire image in processing. The Spatial Subset Tool allows you to select specific portions of the image for processing.

1. Click the Spatial Subset icon on the Spectral Analysis Workstation toolbar.
   The Spatial Subset Tool dialog opens.
2. Adjust the size of the Inquire Box by typing the following coordinates: **ULX: 116; ULY: -390; LRX: 550; and LRY: -767**.

3. Click the **Apply** button in the Spatial Subset Tool dialog. The size of the Inquire Box adjusts in the Spatial Subset Tool dialog as follows:

4. Click **OK** in the Spatial Subset Tool dialog to transfer the information back to the project.
The spatial subset area is not evident in the Spectral Analysis Workstation. However, if you select View -> Preprocess, you can see that it has been added to the list of preprocessing activities.

5. Click the Save icon to save changes to the project file.

**Identify Bad Bands**

It is not uncommon for there to be bands within the dataset that have a low S/N ratio or are otherwise corrupt. This could be due to absorption of particular wavelengths by gasses in the atmosphere, or by problems with the sensor detectors. The incorporation of these bad bands into the metric algorithms can corrupt the calculation and lead to poor results. To avoid this, you should prepare a list of bands that are not to be used during calculations. This improves accuracy and performance.

1. Click the Bad Band Selection Tool icon in the Workstation toolbar.

The Bad Band Selection Tool dialog opens.

The Bad Band Selection Tool is a tool used to identify bands that should be excluded from analysis. It allows for the selection of bands based on various criteria such as S/N ratio or wavelength. The tool includes features such as an image preview, data histogram, cell array, movie player, and mean plot, which help in visualizing and analyzing the spectral data.
The **Current Band** indicator is set to band 1. The image and data histogram of band 1 display in the Bad Band Selection Tool.

*NOTE: The image preview and data histogram are very noisy (that is, not clear). Band 1 and 2 of AVIRIS are known to have a low S/N. These are bad bands.*

2. Click the **Current Band** nudger twice to select band 3.
   
   Note the presence of good data in the image preview and data histogram.

3. In the CellArray, click in the **Bad** cell corresponding to bands 1 and 2 to remove them from analysis.

4. Click on the Forward Arrow icon of the Movie Player.
   
   The software steps through the bands at **1.0 Seconds/Frame**, displaying each band image and histogram. As the bands approach the 1400 nm water absorption region (about band 107), the quality of the bands degenerates.

5. As soon as an unacceptable band is viewed, band 107, click the Movie Player Stop icon.
   
   An unacceptable band typically has a “salt and pepper” effect, displays an irregular (non-Gaussian) histogram, or lacks recognizable features.

6. In the CellArray, click in the **Bad** cells to mark bands 13, 107 through 114, 153 through 168, and 221 through 224 as bad bands, or you can click the **Load** button in the Bad Band Selection Tool dialog and select the Bad Band List File you created, *aviris_badbands.bbl*.
   
   *NOTE: You created the *.bbl file in “Bad Band Identification”, “Save Band Data”.*
Note the orange shading over those areas on the **Mean Plot**. Orange designates bad bands.

To select multiple bands, hold the Shift key down. Either click individual bands or hold the left mouse button and drag to select a continuous range of bands. Click in the **Bad** column of any highlighted band to mark all selected bands.

7. Make sure that the **Use** checkbox is checked in the top right corner of the dialog.

8. Click **OK** in the Bad Band Selection Tool dialog to transfer this information to the Spectral Analysis Workstation.

The bad bands are identified by grey shading on the Spectrum Plot.

Band 107 has poor data
9. In the Spectral Analysis Workstation, click the Save icon to save this information in the project file.

   After each modification to this project, save the changes to keep the .iwp project file updated.

Create Spectral Subset

There may be occasions when you prefer not to use all spectral ranges in the dataset for a particular purpose. For example, based on an evaluation of the Target Material spectrum and the probable background material spectra, there may be specific spectral ranges that contain the differentiating bands. To facilitate this evaluation, it is possible to display spectral signatures in the Spectral Subset Selection Tool.

Additionally, some of the preprocessing or analytical metrics are, theoretically, best applied independently to different wavelength ranges (VIS/NIR, SWIR, or TIR). To define the particular wavelengths to be used for an analysis, the Spectral Subset Selection Tool should be used.

1. Click on the Spectral Subset Selection icon on the Spectral Analysis Workstation toolbar.

   The Spectral Subset Selection Tool dialog opens. Here, you can identify bands and their associated wavelengths to use, or exclude, in analysis.
2. Scroll to the bottom of the CellArray in the Spectral Subset Selection Tool dialog.

3. Click and hold in the row labeled Band number 224 and drag upward to and including Band number 182.

4. Right-click in the Band column and select Invert Selection from the Row Selection menu.

5. Click in any highlighted Omit cell to omit all of the selected bands.

   **NOTE:** Some bands are already omitted from use of the Bad Band Selection Tool. Use of the Spectral Subset Selection Tool does not affect those bands’ status.

6. Right-click in the Band column and choose Select None from the Row Selection menu.

All of these bands are excluded from analysis.
7. Make sure that the **Use** checkbox is checked in the top right corner of the dialog.

8. Click **OK** in the Spectral Subset Selection Tool dialog to transfer this information back to the project file.

9. Click the **Save** icon to save this information in the project file.

**Collect a Signature**

You may collect a signature from an image being analyzed using the Create Point icon.

1. Right-click in the Zoom View and select **Inquire Box** from the Quick View menu.

2. In the **Box Color** section of the dialog, click the Color Chooser icon.

3. Select the color **Red**.

4. Click **Apply**, then **Close** in the Inquire Box dialog.

5. Right-click in the Zoom View and select **Inquire Cursor** from the Quick View menu.
6. Enter the X and Y Map coordinates of 372 and -578, respectively.

   NOTE: The values you enter are modified slightly by the software to account for image resampling.

7. Right-click in the Zoom View and select **Zoom -> Zoom in By 2** as many times as necessary to clearly see the intersection of the Inquire Cursor in the view.

8. Click the Color Chooser icon , then select Red.

9. Select the Create Point icon .

10. Position the crosshair cursor over the Inquire Cursor crosshair intersection, and click to collect the signature for Map pixel 372, -578.

   A collection point symbol is placed over the pixel of interest in each of the three views. The spectrum of the pixel of interest displays in the Spectrum Plot.
11. Click **Close** in the Inquire Cursor dialog.

**Change Spectrum Properties**

1. In the Spectrum Plot Legend, click on **Sample 1** to highlight it.

2. Right-click and select **Spectrum Properties** from the **Options** menu.

   The signature header dialog, Sample 1 Properties, opens.
3. Select the contents of the **Name** row and rename the sample by typing **target_372_578** over the default, then click **OK**.

**Run Target Detection**

Next, use the spectrum of this single signature as the target to find other occurrences within the image.

1. Drag and drop **target_372_578** onto **Material List 1** in the Working Libraries window.

2. Click the Plus symbol (+) to display the contents of **Material List 1**.

3. Click the Spectrum symbol (amenti) to select **target_372_578**.
   This specifies the spectrum to be used as the target in the next step.

4. Click the Target Detection icon (target) to put the Spectral Analysis Workstation in that mode.

5. Click the Execute icon (execute) to initiate the Target Detection analysis.
   The Target Detection Options dialog opens.
6. Click the **Method** popup list and select **Constrained Energy Minimization**.

7. Click the **Yes/No** radio button and keep the default **Threshold** value of **0.50**.

8. In the **File Name** window, type **target_372_578.img**.

9. Click **OK** in the **Target Detection Options** dialog.

   A progress meter displays at the bottom of the Spectral Analysis Workstation to show the status of the Target Detection.

**Examine Results**

   After calculation, the detected target image and the Target Detection Results CellArray display in the Spectral Analysis Workstation.

   Notice that only the area you designated as the spatial subset is used in Target Detection analysis; the remainder of the analysis image is not affected by the Target Detection.

1. In the Workstation, resize the Target Detection Results CellArray so that it only occupies as much room as is necessary.
The resulting CellArray contains a list of the detected targets with the X, Y pixel coordinates and the number of pixels in the target clump. Selecting a pixel at random to use as the target material does not guarantee that the selected pixel is a pure example of that material even when the target pixel is identified from a classification image. Actually, most pixels are mixed pixels.

Thus, there may be pixels within the image that are more pure examples of the target material, and these pixels rate higher in the analysis. Therefore, depending on what threshold is set, the selected pixel may or may not be highlighted. Additionally, if the selected target material pixel contains materials other than the desired material, these too are mapped by the algorithm.

2. Continue on to the next section, “Using an Overlay”.

**Using an Overlay**

*NOTE: To complete this section, you must complete the previous section, “Create a Spectral Analysis Project”.*

You may want to use an ancillary image as a guide in selecting image pixels to view or to use as reference spectra. Examples are a scanned map or a classified image. In these cases, the ancillary layer can be opened on top of the analysis image.
Open Overlay

ERDAS IMAGINE must be running.

1. From the Spectral Analysis Workstation menu, select **File | Open Overlay**.

2. Navigate to /examples and select **cuprite_classified_map.img**, then click **OK** in the File Selector.

The classified image displays on top of the target mask. The overlay image is used to assist in the collection of points. The actual spectra, however, are collected from the underlying analysis image, **cuprite_aviris.img**.

Collect Multiple Spectra

1. If necessary, adjust the Inquire Box in the Main View so that it covers the sample you collected, **target_372_578**.

2. Zoom in to or out of the area centered on **Map pixel 372, -578** such that you can clearly see the other two areas of Buddingtonite, which appear as pink pixel clusters.
To zoom to the area with Buddingtonite, either drag a corner of the Inquire Box, or right-click and select one of the Zoom options.

3. Click the title bar of the Spectrum Plot to make it active.

4. Click the Create Point icon and the Lock icon, which becomes .

5. Click to select six pixel spectra from the three pink clusters in this area, selecting a different color for each one.

   **NOTE:** Clicking the Color Chooser icon does not affect use of the Lock icon.

Notice a great similarity in the shapes of the spectra. Shape defines material; measurement (intensity) defines the amount of frequency absorbed, scattered, or transmitted. This is perhaps best illustrated by collecting several points within the class containing the target (that is, the pink pixels).
You can see that the shapes of these spectra are also very similar except for the relative strength. This tells us that the pixels do not contain pure signals, but represent a mixture of different materials at differing concentrations.

**Change the Spectrum Plot**

1. Right-click in the Spectrum Plot and choose **Chart Options** from the **Options** menu.

2. Click the **Y Axis** tab in the Chart Options dialog.

![Chart Options dialog](image)

   *Make changes to the display of the Y-axis on this tab*

   *Change the Min value*

3. Change the **Min** value to **2.2**, then click **Apply**.

![Spectrum Plot with Min value set](image)

   *The minimum value in the Spectrum Plot changes according to the changes made on this tab*

By changing the **Min** value, you make better use of the Spectrum Plot area so that small spectrum differences are more visible.

4. Click **Close** in the Chart Options dialog.

**Create Spectrum Library**

1. Right-click in the Spectrum Plot Legend and choose **Select All** from the **Options** menu.

2. Click, hold, and drag the selection to the blank area of the Working Libraries window.
This creates **Material List 2** in the Working Library window.

3. Right-click on the Book symbol 📚 for **Material List 2** and choose **Rename** from the **Spectrum Library** menu.

4. Rename the library **Budd_aoi** in the Rename Spectrum Library dialog, then click **OK**.

5. Click the Plus symbol + to expand the **Budd_aoi** Working Library.

![All AOI spectra are contained in this new Working Library](image)

6. Right-click on the Book symbol 📚 for **Budd_aoi** and choose **Save As** from the **Spectrum Library** menu.

7. In the File Selector, navigate to a directory where you have write permission.

8. Name the library file **budd_aoi.spl**, then click **OK** in the File Selector.

9. Right-click in the Spectrum Plot Legend and choose **Select None** from the **Options** menu.

**Create Merged Spectrum**

One way to improve the quality of the analysis is to obtain an average spectrum for the target material rather than rely on a single random pixel.

1. Click the Book symbol 📚 to select the **Budd_aoi** Working Library.

2. Right-click and select **Merge** from the **Spectrum Library** menu.

3. In the Merge Spectrum Library dialog, type the name **distributed_aoi_merged**, then press Enter on your keyboard.

   IMAGINE Spectral Analysis calculates a new spectrum which is the mean of all the spectra in this library file and adds it to the **Budd_aoi** Working Library.

4. Click on the Spectrum symbol 🌆 for **distributed_aoi_merged** and drag it to the Spectrum Plot.
5. Click on each Sample, not target_372_578 and distributed_aoi_merged, then right-click and choose Delete Selection from the Options menu.

Collect AOI Spectrum

1. In the Zoom View, zoom in on the pink area, Buddingtonite, containing pixel 372, -578.

2. Click the Color Chooser icon and select Blue.

3. Click the Polygon AOI icon and digitize inside and around the pink pixels only.

4. Double-click to terminate collection of the polygon.
Polygon collection termination is controlled by a preference, Polyline/Polygon termination button, which is in the Viewer category of the Preference Editor.

A spectrum calculated from the AOI appears in the Spectrum Plot along with plus and minus two standard deviation lines, which display as dashed lines.

5. In the Spectrum Plot Legend, click to select the new Sample, which corresponds to the AOI you digitized.

6. Right-click and choose Spectrum Properties from the Options menu.

7. Type the name budd_north_aoi in the Name field for the new sample.

8. Click OK in the Properties dialog.

Add and View Spectrum

1. Drag and drop budd_north_aoi to the Book symbol for the Working Library Budd_aoi.

2. Right-click on the Book symbol for Working Library Budd_aoi and choose Save from the Spectrum Library menu.
3. Right-click in the Legend and choose **Select All** from the **Options** menu.

4. Right-click and choose **Delete Selection** from the **Options** menu.

5. Drag and drop the Working Library **Budd_aoi** into the Spectrum Plot.

   *NOTE: You may want to adjust the Chart Options to better see the spectra in the Spectrum Plot.*

![Image of Spectrum Plot]

*Change the X-axis and the Y-axis defaults to view the spectra*

The two average spectra (**distributed_aoi_merged** and **budd_north_aoi**) display along with the scene-derived Buddingtonite samples in the Spectrum Plot. You might choose to delete the other samples from display and adjust the Plot Options to focus on only those spectra.

**Run Target Detection**

Next, view the result of using the average target spectrum.

1. Click the Book symbol of the **Budd_aoi** Working Library to select it.

2. Ensure that the Target Detection icon is selected.

3. Click the Execute icon to initiate the Target Detection analysis.

   The Target Detection Options dialog opens.
4. Click the **Method** popup list and select **Orthogonal Subspace Projection**.

5. Click the **Yes/No** radio button.

6. Change the **Threshold** value to **3.00**.

7. Click in the **File Name** field and type **budd_average.img** for the name.
   
   The output file is named **budd_average.img** because it is generated from all the spectra in the **Budd_aoi** Working Library, which were selected from Buddingtonite samples in the analysis image.

8. Click **OK** in the Target Detection Options dialog.
   
   A progress meter displays at the bottom of the Spectral Analysis Workstation to show the status of the Target Detection.

**Examine Average Spectrum Results**

After calculation, the target image displays in the Spectral Analysis Workstation.
1. Use the Viewer Swipe tool to compare the Target Detection results to the truth image, cuprite Classified_map.img.

   For instructions on how to use the Viewer Swipe tool, see “Analyze Results—Swipe”.

2. Right-click in the Main View and select Arrange Layers from the Quick View menu.

3. Move budd_average.img to the bottom of the list, then click Apply.

4. Move the image target_372_578.img to the top of the list, then click Apply.

5. Compare target_372_578.img to the truth image.

   For instructions on how to use Arrange Layers, see “Analyze Results—Arrange Layers”.

You should notice that the number of targets remains about the same, but that the area of each one is slightly larger in the results using the average of the spectra, budd_average.img.
Close and Exit

1. Select File -> Close All from the Spectral Analysis Workstation, if you wish.

2. Click Yes in the Attention dialog to save changes to cuprite_tour.iwp.

3. Select File -> Exit IMAGINE from the ERDAS IMAGINE menu bar, if you wish.

Conclusions

Based on the previous analyses, several conclusions can be reached.

- Removing bad bands from the analysis improves results.

- Using an average spectrum for the target is more realistic than selecting one pixel at random to represent the target material. However, if you have other information about the area like classified maps or access to the ground, then perhaps a particular pixel could be selected.

- Using a known background Spectrum Library yields superior results. A known background also processes faster since the software does not need to calculate background materials.

The definition of background materials (spectra) does not require that you have a precise knowledge of those materials on the ground. You could create a classified image using the traditional classifiers within ERDAS IMAGINE. These major component spectra can then be used as the known background even though their actual identity is not known. They are merely the majority background components to be suppressed during the Target Detection.

These techniques are discussed under “Orthogonal Subspace Projection”.

Next

In the next Tour Guide, you learn how to apply the Minimum Noise Fraction Tool.
Minimum Noise Fraction

Introduction

This chapter presents information about the Minimum Noise Fraction Tool and its application.

Before You Begin

“MNF Transform—Automated Mode”

In the first section of this Tour Guide, you are going to perform the following basic steps:

- Identify the input image
- Set MNF options
- Compute and evaluate results—\textit{mnf\_auto.img}
- Compare results

\textit{Approximate completion time for this portion of the Tour Guide is 15 minutes.}

The output of this exercise is a temporary file that is prefixed with \textit{eisw\_}, which is saved to a permanent file, \textit{mnf\_auto.img}. You can use it to collect samples and compare results with the truth dataset.

“MNF Transform—Interactive Mode”

In this section of the Tour Guide, you are going to perform the following basic steps:

- Digitize and save an AOI—\textit{cuprite\_aoi\_mnf.aoi}
- Set MNF options
- Evaluate results—\textit{cuprite\_covariance.mtx}
- Set low-pass filter options
- Evaluate results—\textit{mnf\_interactive.img}
- Close and exit

\textit{Approximate completion time for this portion of the Tour Guide is 60 minutes, which includes processing time and is dependent on your system resources.}
An AOI is used in this example, `cuprite_aoi_mnf.aoi`. This AOI file is used to calculate a covariance matrix, `cuprite_covariance.mtx`, for the input image. The output of this exercise is a temporary file containing MNF data, `mnf_interactive.img`. It can be used to evaluate signatures in your analysis images and improve your spectral analysis results.

MNF Transform—Automated Mode

For some analyses, it may be desirable to decrease the noise (increase S/N) in an image under analysis. For example, the S/N of the dataset may be just near the detection point for the material of interest and an increase in S/N could be essential to yield accurate results. Another possibility is that the material of interest may have characteristic absorption bands in a spectral region degraded by atmospheric absorption. In these circumstances, the MNF transform may significantly improve the analysis.

Reading "Minimum Noise Fraction" prior to executing this Tour Guide can help you understand MNF concepts.

The Minimum Noise Fraction Tool can be used in two different ways: totally automatic and with interaction by the analyst.

In the fully automated approach, the analyst makes a few basic processing decisions. These are stored in the *.iwp file. During the actual analysis calculation, these parameters are used to define how the MNF preprocessing step is applied—the analyst never sees or interacts with the MNF images themselves.

In the step-wise approach, the analyst is allowed to view both the MNF images and the MNF eigenvalues to aid in deciding where to define the cutoff between useful and noise MNF layers.

The step-wise approach is described in "MNF Transform—Interactive Mode".

Identify Input File

You must have ERDAS IMAGINE running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select Spectral Analysis from the Classification menu.

3. From the Spectral Analysis menu, select Spectral Analysis Workstation.
You may want to use the Spatial Subset Tool to process a small portion of the image. Otherwise, processing could take several minutes, depending on your system resources.

For information about the Spatial Subset Tool, see “Create Spatial Subset”.

1. Display a project file, such as `cuprite_tour.iwp` in the Spectral Analysis Workstation.

   NOTE: You created `cuprite_tour.iwp` in “Spectral Analysis Workstation”, “Create a Spectral Analysis Project”, “Save the Project”.

   In this example, use the whole image in analysis.

2. Click the Spectral Subset Selection icon.

3. Click to deselect the Use checkbox, then click OK in the dialog.

4. Click on the MNF icon in the Spectral Analysis Workstation.

   The Minimum Noise Fraction Tool dialog opens.
Set MNF Options

Three methods of defining the image noise are available. The decision to calculate the noise from the whole image or from a subset (AOI) depends on the nature of the image itself and your knowledge of the image. The goal of this step is to quantify and parameterize the statistics of the noise content underlying the image itself. It may be desirable to minimize the contribution from the statistics of the image content. Thus, it is often preferable to calculate noise statistics from a homogenous subset of the image and assume that the noise was the same throughout the full image.

See "Algorithms and Metrics" for more information.

Both the Compute Noise Covariance from Whole Image option and the Compute Noise Covariance from AOI option compute the noise statistics using the same technique.
The third option, **Read Noise Covariance from File**, allows you to utilize noise statistics generated earlier and saved in a Matrix Text File (*.mtx) file. This would be appropriate if you have saved the noise statistics during an earlier analysis of the same image, or, less assuredly, have noise statistics from a comparable image such as an adjoining image from a given data collection series.

1. Note that the **Noise Statistics Method** defaults to **Compute Noise Covariance from Whole Image**.
   At this time, ignore the **Max MNF Bands to Display** option. In the automatic mode, it is not necessary to set this value.

2. Using the increment nudger or by typing, set the **Covariance Skip Factor** to **2**.
   This skip factor is used to set the sampling grid for the noise covariance calculation. Choice of this parameter is determined by the size of the image (or AOI) and the nature of the image itself. Since we are using the whole image in this example, including only one-fourth of the pixels in the statistics (skip factor of 2 in both columns and rows) is presumed valid.

3. Click the checkbox for **Preset Filtering Method**.
   Two default parameters, **Noise Filtering Method** and **First Noise Band**, activate.

4. Note that the radio button for **Fill Noise Bands with their Mean** is selected by default.
   The MNF-transformed bands are going to be divided into two categories: information layers and noise layers. You must decide what to do to the noise layers prior to applying the reverse MNF transform. The reverse MNF transform returns the dataset to the spectral space it was originally in for analysis. Several options are available, as described in the following aside.
5. Notice that the **First Noise Band** is set to 1. Keep this default setting.

This parameter defines the decision point between MNF layers that are to be considered information and those to be considered noise. Leaving this value at 1 passes the decision making back to the software. Since if the first and all subsequent bands (layers) were noise, there would be no information layers, this is an impossible case. The software automatically replaces this default with the number of the first MNF band to contain less than 1% of the scene variance.

> **Warning:** Setting this default to any other value overrides this automatic default calculation. This value should only be altered when using the Minimum Noise Fraction Tool in the step-wise function discussed in "MNF Transform—Interactive Mode", or if you know enough about the data to override the data-derived default.

6. Click **OK** in the Minimum Noise Fraction Tool dialog.

This passes the parameters selected by you to the *.iwp file, in this case **cuprite_tour.iwp**, to be used during the analysis calculation and returns you to the Workstation. During the actual analysis, the MNF filtering is done as an intermediate step of the calculation. If you want to look at or evaluate the MNF-filtered image, it must be generated as a separate operation.
Generate Results

1. In the Spectral Analysis Workstation, select View -> Preprocess -> MNF.

This displays a sequential list of the preprocessing operations currently defined by you in the *.iwp file. Selecting one of the listed steps, such as MNF, initiates calculation of an intermediate image using the preprocessing steps up to and including the step selected. The resultant intermediate image is displayed in the Spectral Analysis Workstation. This new dataset has fewer bands than the input image because the bad bands were not included in the calculation.

After you choose MNF, a progress meter at the bottom of the Spectral Analysis Workstation displays, which tracks the status of the operation.

NOTE: This process may take several minutes, depending on your system resources.

The result of the MNF function displays in the Spectral Analysis Workstation. Note that the extent of the results corresponds to the entire image. If you have defined a spatial subset using the Spatial Subset Tool, then only the area defined therein is MNF-processed.

2. In the Workstation, select File -> Save Preprocessed Image.

3. Navigate to a directory where you have write permission.

4. In the File Selector, type the name mnf_auto.img in the File name field.

5. Click OK in the File Selector.
Evaluate Results

1. In the Main View, right-click and select Arrange Layers from the Options menu.

2. In the Arrange Layers dialog, right-click on the top MNF image, mnf_auto.img, and select Band Combinations.
3. Change the bands for the MNF-filtered layer to a different band, such as 25.

4. Click Apply, then Close in the Band Combinations dialog. The results display in the Spectral Analysis Workstation.

5. Right-click in the Main View and select Swipe from the Options menu.

See "Analyze Results—Swipe" for instructions on using the Viewer Swipe tool.

6. In the Arrange Layers dialog, drag cuprite_aviris.img below mnf_auto.img, then click Apply.

7. Visually compare the analysis image, cuprite_aviris.img, and the MNF-filtered image, mnf_auto.img.
8. Click **Cancel** in the Viewer Swipe dialog and **Close** in the Arrange Layers dialog.

**Compare Results**

An analytical evaluation of the MNF filtering can be done by comparing the spectra of selected points before and after MNF filtering. To do this comparison, it is necessary to use two Spectral Analysis Workstations.

1. Select **File | New** in the Spectral Analysis Workstation.

2. In the new Spectral Analysis Workstation, select **File -> Open Analysis Image**.

3. Navigate to the directory into which you saved `mnf_auto.img`, select it, then click **OK** in the File Selector.

Because you have designated some input bands as bad by using the Bad Band Selection Tool, the MNF image does not contain the same number of bands as the input image. It is not possible to attach a sensor information node to the MNF image. For a rigorous band-wise evaluation of the effect of MNF filtering, it would be necessary to create a *.saf file for the MNF-filtered image.

   For more information, see "Create a Sensor Attribute File".

4. In both Workstations, use the Inquire Cursor and apply the Create Point icon to select the same exact pixel, such as Alunite Hill, at **Map coordinates 232, -698**.

   It is now possible to visually evaluate the effect of the MNF filtering.

5. Examine the different signatures in the Spectrum Plots.

   In **Figure 9**, the first Spectrum Plot shows the Alunite signature derived from the analysis image, `cuprite_aviris.img`, located in the project file `cuprite_tour.iwp`. The second Spectrum Plot shows the Alunite signature derived from the MNF-filtered image, `mnf_auto.img`. 
Figure 9: Signature Comparison—MNF Results

6. Select **File -> Close All** to close the Spectral Analysis Workstations.

Conclusions

This exercise has demonstrated how you can quickly generate MNF-filtered images to use in analysis. Removing noise bands likely improves your analysis results.

**MNF Transform—Interactive Mode**

In the interactive mode, you can view the MNF layers prior to running the process. This allows you to make decisions regarding the true first noise band to ignore in analysis.

**Digitize and Save AOI**

ERDAS IMAGINE must be running.

1. Click the **Spectral Analysis Workstation** button on the **Spectral Analysis** menu to open a new Workstation.

2. Open an IMAGINE Spectral Analysis project file in the Spectral Analysis Workstation, such as /examples/cuprite_basic.iwp.

3. Select **View -> Preset RGB Combinations -> True Color**.

4. Click the Color Chooser icon and choose **Red**.

5. Click the Polygon AOI icon and digitize a uniform area in the image.

The playa visible in the center of the right margin of the image is an excellent area to use.
6. Make sure the Selector icon is active, then click inside the AOI to select it.

7. Select File -> Save Selectors To AOI File.

8. Navigate to a directory to which you have write permission.

9. Name the file cuprite_aoi_mnf.aoi, then click OK in the File Selector.

Set MNF Options

1. Click on the MNF icon in the Spectral Analysis Workstation.

   The Minimum Noise Fraction Tool dialog opens.

   In this example, the playa is a spectrally flat area and good for MNF processing.
2. Select **Compute Noise Covariance from AOI**.

3. In the file field, choose the AOI you just created, `cuprite_aoi_mnf.aoi`.

4. Confirm the **Max MNF Bands to Display** option is set to 30.

   This parameter sets the number of MNF bands to be generated. In the case of an AVIRIS image, this number can be as high as 224, but frequently the majority of the information is contained in the lower band numbers.

   After computation, the MNF bands are displayed in the **MNF Rotated Image** area of the dialog, and the eigennumber-eigenvalue plot for these bands is displayed at the bottom of the dialog.

   You want to generate enough MNF layers to correctly define the break between MNF layers that contain information and MNF layers to be designated as noise. Generating more layers than necessary consumes time and disk space.
5. Confirm the **Covariance Skip Factor** is set to **1**.
   This skip factor is used to set the sampling grid for the noise covariance calculation. Choice of this parameter is determined by the size of the image (or AOI) and the nature of the image itself.

6. Click the **Compute** button.
   This initiates calculation of the noise covariance matrix (using only the area of the image within the selected AOI) and the first **30** MNF layers. When these are computed, they are displayed in the Minimum Noise Fraction Tool dialog.

   *This process may take several minutes to complete, depending on your system resources.*

**Evaluate Results**

A preview of the First Noise Band displays here

Data for the band displays in the plot

Note that the **First Noise Band** has defaulted to the first band contributing less than 1% of the scene variance, which is **18** in this example. Results vary depending on the AOI used.
1. Click the increment nudger for **First Noise Band** and view all of the MNF layers.

*The preview shows that the noise has increased with increasing band number*

Note that the lower number layers are less noisy than the higher numbers. Using the eigenplot and the MNF layer images, you must decide where to set the line between layers with image information and layers to be designated as noise.

1. Click on the **Save Cov.** button in the Minimum Noise Fraction Tool dialog.

2. Navigate to a directory where you have write permission.

3. Name the Matrix Text File `cuprite_covariance.mtx`, then click **OK** in the File Selector.
   
   This allows you to access the noise covariance statistics for later use.

**Set Low-Pass Options**

1. Set the **First Noise Band** field to band 18 (the number that is originally identified as the **First Noise Band**).

2. Select the **Low-pass Filter Noise Bands** radio button.
Selecting this option activates the window size option. This sets the size of the moving window to be used in the filtering operation.

**Low-Pass Filter Noise Bands**

Selection of this value is subjective. To get a feel for the effect of the low-pass operation, it is possible to filter the image outside the Spectral Analysis Workstation environment.

1. In a separate IMAGINE Viewer, display the MNF image. This is a temporary image stored in the directory designated in Preferences. It has a prefix `eisw`. Use the **Save Top Layer As** option to save the MNF image as an *.img file.
2. Use the **Image Interpreter -> Spatial Convolution** functionality to process the MNF image with a 3x3, 5x5, and 7x7 low-pass filter.
3. Open four IMAGINE Viewers. On the main ERDAS IMAGINE menu bar, select **Session -> Arrange Layers**.
4. Open the original MNF image in one Viewer and open the three low-pass filtered MNF images in the other Viewers. When opening the files, use the **Raster Options** to select **Gray Scale** and **Fit to Frame**. Using the **Raster Band Combinations** option of each Viewer, it is possible to evaluate the effect of the various low-pass windows on the MNF layers.

3. Click the popup list and select the low window size of **5 x 5**.

4. Make sure that the **Use** checkbox is checked in the top right corner of the dialog.

5. Click **OK** in the Minimum Noise Fraction Tool dialog.

This passes the parameters selected to the **cuprite_basic.iwp** file to be used during the analysis calculation and returns you to the Spectral Analysis Workstation.

During the actual analysis, the MNF filtering is done as an intermediate step of the calculation. If you wish to look at or evaluate the MNF-filtered image, it must be generated as a separate operation.

6. In the Spectral Analysis Workstation, select **View -> Preprocess -> MNF**.

This displays a sequential list of the preprocessing operations currently defined in the *.iwp file. Selecting one of the listed steps initiates calculation of an intermediate image using the preprocessing steps up to and including the step selected. The resultant intermediate image displays in the Spectral Analysis Workstation when computation is complete.

---

*This process may take several minutes, depending on your system resources.*
<table>
<thead>
<tr>
<th>Evaluate Results</th>
<th>The MNF-filtered image displays in the Spectral Analysis Workstation.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Right-click in the Main View to access the Quick View menu, then select <strong>Arrange Layers</strong>.</td>
<td></td>
</tr>
<tr>
<td>2. Right-click on the temporary file generated by MNF, which begins with the prefix <strong>eisw</strong>, then select <strong>Save Layer As</strong>.</td>
<td></td>
</tr>
<tr>
<td>3. Navigate to a directory where you have write permission, name the file <strong>mnf_interactive.img</strong>, then click <strong>OK</strong> in the File Selector.</td>
<td></td>
</tr>
</tbody>
</table>

⚠️ **This process may take several minutes, depending on your system resources.**

<table>
<thead>
<tr>
<th>View Results Alone</th>
<th>Now, you can view the results obtained using a low-pass filter.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the Viewer icon in the ERDAS IMAGINE toolbar.</td>
<td></td>
</tr>
</tbody>
</table>

If necessary, select the type of Viewer you want to use.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Click the Open icon and navigate to the directory where you saved the file <strong>mnf_interactive.img</strong>.</td>
<td></td>
</tr>
<tr>
<td>3. Select the file, then click <strong>OK</strong> in the File Selector.</td>
<td>The MNF-filtered image displays in the Viewer.</td>
</tr>
</tbody>
</table>
Close and Exit

1. Select **File -> Close All** from the Spectral Analysis Workstation, if you wish.

2. Click **No** in the Attention dialog to save **cuprite_basic.iwp**.

3. Close any remaining dialogs by clicking the Close icon.

4. Select **File -> Exit IMAGINE** from the ERDAS IMAGINE menu bar, if you wish.

Conclusions

To truly evaluate the MNF-filtered image, you should compare the full spectrum of pixels between the input image and the MNF-filtered image. Ultimately, you want to suppress noise in the spectrum, but not desirable features. Setting the MNF-filtered image to the same band to color assignments can also help you evaluate the quality of the MNF-filtered image.

Next

In the next chapter, you can learn how to atmospherically adjust images. Atmospheric Adjustment can improve the analysis results.
Atmospheric Adjustment

**Introduction**

In the IMAGINE Spectral Analysis software, Atmospheric Adjustment is used to describe empirical algorithms, and Atmospheric Correction is used when discussing atmospheric model-based algorithms. All of the techniques in the current software are atmospheric adjustments.

**Before You Begin**

“**IARR**”

In the first section of this Tour Guide, you are going to perform the following basic steps:

- Identify the input file
- View sensor information
- Identify bad bands
- Save band data—`cuprite_hyperion.bbl`
- Save the project—`hyperion_basic.iwp`
- Apply Atmospheric Adjustment
- Compute results—`hyperion_iarr.img`

Approximate completion time for this portion of the Tour Guide is 10 minutes.

The primary output of this exercise, `hyperion_iarr.img`, is the result of Atmospheric Correction using the IARR method. It is derived from the project file `hyperion_basic.iwp`. You also generate a Bad Band List File, `cuprite_hyperion.bbl`, which you can use in other applications using Hyperion data.

“**Modified Flat Field**”

In this section of the Tour Guide, you are going to perform the following basic steps:

- Apply Atmospheric Adjustment
- Open a library file
- Identify sample
- Identify reference
• Compute results—hyperion_mff.img

**Approximate completion time for this portion of the Tour Guide is 15 minutes.**

The output of this exercise, hyperion_mff.img, is the result of Atmospheric Correction using the Modified Flat Field method.

**“Empirical Line”**

In this section of the Tour Guide, you are going to perform the following basic steps:

• Apply Atmospheric Adjustment

• Open a library file

• Identify sample

• Identify reference

• Collect other samples

• Compute and compare results—hyperion_el.img

**Approximate completion time for this portion of the Tour Guide is 20 minutes.**

The output of this exercise, hyperion_el.img, is the result of Atmospheric Correction using the Empirical Line method, which is the most rigorous type of Atmospheric Adjustment.

**“Evaluating Results”**

In this section of the Tour Guide, you are going to perform the following basic steps:

• Evaluate IARR results compared to truth data and library data—aviris_alunitehill.spl and iarr_alunitehill.spl

• Evaluate Modified Flat Field results compared to truth data and library data—mff_alunitehill.spl

• Evaluate Empirical Line results compared to truth data and library data—el_alunitehill.spl

• Close and exit

**Approximate completion time for this portion of the Tour Guide is 25 minutes.**
Output of this exercise is a series of Spectrum Library files, `aviris_alunitehill.spl`, `iarr_alunitehill.spl`, `mff_alunitehill.spl`, and `el_alunitehill`, which is used to compare different results you get with each method. This is best viewed in the Spectrum Plot in the Workstation.

**IARR**

The IARR method of Atmospheric Adjustment is best used when you have no knowledge of the image that can be used to define spectral control points.

**Identify Input File**

ERDAS IMAGINE must be running.

1. Click the Classifier icon on the ERDAS IMAGINE icon panel.

2. Select **Spectral Analysis** from the **Classification** menu.

3. Click the **Spectral Analysis Workstation** button on the **Spectral Analysis** menu.

4. In the Spectral Analysis Workstation, select **File -> Open Analysis Image**.

5. Navigate to the `/examples` directory and select the file `cuprite_hyperion.img`, then click **OK** in the File Selector.

   The image may display in the Workstation as a white box. In the next section, you change the band combinations to make it display in a more usable form.

**Change Band Combinations**

1. Right-click in the Main View and select **Arrange Layers** from the **Quick View** menu.

2. In the Arrange Layers dialog, right-click on the layer `cuprite_hyperion.img`.

3. Select **Band Combinations** from the **TrueColor Options** menu.
4. Set the **Red**, **Green**, and **Blue** display to bands 202, 115, and 93, respectively.

5. Click **Apply**, then **Close** in the Set Layer Combinations dialog.

---

**View Sensor Information**

1. Click the Sensor Information Tool icon 📋 to open the Sensor Information dialog.
Notice that the **Sensor Name** field displays **Hyperion**. This information is derived from the analysis image, `cuprite_hyperion.img`.

2. Click **OK** in the Sensor Information Tool dialog to accept the **Hyperion** sensor information.

**Identify Bad Bands**

1. Click the Bad Band Selection Tool icon to open the Bad Band Selection Tool dialog.

   *NOTE: The first seven bands do not display an image preview or histogram.*

2. Click in the > cell for **Band 8** to see an image preview and histogram data.

3. In the Bad Band Selection Tool dialog, mark the following bands for exclusion from analysis: 1 through 9, 56 through 82, 94, 99, 116, 121 through 130, 165 through 181, 185 through 186, 203, and 220 through 242.

   *See "Identify Bad Bands" for instructions on how to use the Bad Band Selection Tool.*

4. Right-click in the **Band** column and choose **Select None** from the **Row Selection** menu.
Save Band Data

1. Click the **Save As** button in the Bad Band Selection Tool dialog.

2. Navigate to a directory where you have write permission.

3. Name the Bad Band List File `cuprite_hyperion.bbl`, then click **OK** in the File Selector.

4. Click **OK** in the Bad Band Selection Tool dialog to transfer the information back to the Workstation.

Save the Project

1. In the Spectral Analysis Workstation, click the **File -> Save As**.

2. In the File Selector, navigate to a directory where you have write permission.

3. Name the file `hyperion_basic.iwp`, then click **OK** in the File Selector.

Apply Atmospheric Adjustment

1. In the Spectral Analysis Workstation, click the Atmospheric Adjustment icon.

The Atmospheric Adjustment Tool dialog opens.
2. Click the **Method** dropdown list and select the **Internal Average Relative Reflectance** option.

   Note that, for this algorithm, no additional inputs are required. While this technique has obvious advantages in that it does not have any required inputs, it does suffer from shortfalls due to the necessary assumptions.

3. Click **OK** in the Atmospheric Adjustment Tool dialog to transfer the information to the Workstation.

**Compute Results**

1. In the Spectral Analysis Workstation, select **View -> Preprocess -> Atmospheric Adjustment**.

   The progress of the Atmospheric Adjustment is tracked by the Status Bar at the bottom of the Workstation.
Selecting this option processes the analysis image through the preprocessing steps of bad band identification and Atmospheric Adjustment, and displays the processed image in the Spectral Analysis Workstation. Note that the resulting image is a temporary file—if you wish to keep this intermediate image, you must save it. It displays in the Spectral Analysis Workstation when processing is complete.

2. Select File -> Save Preprocessed Image from the Spectral Analysis Workstation menu.

3. Navigate to a directory where you have write permission.

4. Name the file hyperion_iarr.img, then click OK in the File Selector. Note that the preprocessed image only has 150 bands, which you can determine from the Set Layer Combinations dialog, since the input bands labeled as bad bands have not been processed.

The new dataset does have its correct band-to-wavelength relationship, but there are now voids in the dataset where bands have been removed. Since all data processing within the IMAGINE Spectral Analysis software is wavelength-based, this causes no problems when the datasets are analyzed.

5. Proceed to the next section, "Modified Flat Field".

## Modified Flat Field

*NOTE: This section of the Tour Guide assumes that you have completed the previous section, "IARR".*

As discussed in "Flat Field", use of the Flat Field technique assumes that you can define a region in the image that is spectrally flat. This is a very tenuous assumption. A more precise assumption would be that you have a reflectance spectrum of an area or material in the scene. The best results would be obtained if the reference spectrum was obtained using a handheld field spectrometer at the exact time of the overflight. This is often not the case. A more likely scenario would be a field-derived spectrum taken at a different date. Lacking that, a spectrum from an Archive Spectrum Library can be used.

### Apply Modified Flat Field Adjustment

ERDAS IMAGINE must be running.

1. Return to the Spectral Analysis Workstation displaying cuprite_hyperion.img.

2. In the Arrange Layers dialog, right-click on the previously generated atmospherically corrected image, select Delete Layer, then click Apply.

Now, only cuprite_hyperion.img displays in the Spectral Analysis Workstation.
3. In the Spectral Analysis Workstation, click the Atmospheric Adjustment icon.

4. Click the Method popup list and select the Modified Flat Field option.

5. Right-click in the Main View and select Zoom In By 2 from the Options menu.

Identify Sample

1. Adjust the position of the Link Box in the Main View so that Alunite Hill is visible in the Zoom View.
2. Right-click in the Zoom View and select **Zoom In By 2** as many times as necessary to see the feature clearly.

3. Click the Color Chooser icon and select the color **Red**.

4. Click the Polygon AOI icon in the AOI tools.

5. Digitize inside the area of Alunite Hill, which displays as fairly a uniform blue feature near the bottom left corner of the image. Double-click to complete the AOI.

   The average spectrum of the pixels within the AOI displays in the Spectrum Plot at the bottom of the Workstation, and is labeled **Sample**.

6. Resize the area occupied by the Spectrum Plot in the Atmospheric Adjustment Tool dialog to enlarge it.

   Note that the Spectrum Plot has the average spectrum and the +/- 2 standard deviation curves, which display as dashed lines. Since the goal is to select a relatively uniform region for an average spectrum, these curves help in deciding the boundaries of the AOI. This AOI can be resized or moved. If necessary, you can create another AOI and overwrite the initial one.
7. Resize other components of the dialog to your liking.

**Identify Reference**

1. Click the Plus symbol \( + \) next to the **USGS** Spectrum Library.

2. Click the Spectrum symbol \( \mathcal{S} \) to select **Alunite GDS82 Na82**.

3. Drag the **Alunite GDS82 Na82** spectrum to the Spectrum Plot. The spectrum displays and is labeled **Reference**.

![Image of the Atmospheric Adjustment Tool dialog with spectrum plots]

*The Sample spectrum is derived from the analysis image; Reference spectrum is derived from the Spectrum Library*

When doing atmospheric adjustments, it is critical that the Reference spectrum matches the material on the ground as well as possible. As discussed in the theory section, natural materials have a tremendous variability depending upon locale. The spectrum used here, Alunite GDS82 Na82, is believed to be representative of the material found at Cuprite. This conclusion is evaluated at the end of this exercise.

4. Click **OK** in the Atmospheric Adjustment Tool dialog to transfer the information to the project.

**Compute Results**

1. In the Spectral Analysis Workstation, click on **View -> Preprocess -> Atmospheric Adjustment**.
This processes the analysis image through the selected preprocessing steps and displays the processed image in the Spectral Analysis Workstation. You can watch the progress of the operation in the Status Bar at the bottom of the Spectral Analysis Workstation.

Note that the resulting image is a temporary file—if you wish to retain this intermediate image, you must save it.

2. Click the **File -> Save Preprocessed Image** in the Spectral Analysis Workstation menu bar.

3. Navigate to a directory where you have write permission.

4. Name the file **hyperion_mff.img**, then click **OK** in the File Selector.

   Note that, as in the previous example, the processed image only has 150 bands since the input bands labeled as bad bands have not been processed.

5. Continue on to the next section, “Empirical Line”.

---

**Empirical Line**

**NOTE: This section of the Tour Guide assumes that you have completed the previous sections, “IARR” and “Modified Flat Field”.

In the Empirical Line technique, you use several spectral pairs. These are used to plot a regression line that is used to modify the input dataset. Since the goal of this algorithm is to define the required regression line, you should use spectra from both bright and dark areas. These points can best constrain and define a line.

**Apply Empirical Line Adjustment**

**ERDAS IMAGINE** must be running.

1. Return to the Spectral Analysis Workstation displaying **cuprite_hyperion.img**.

2. In the Arrange Layers dialog, right-click on the previously generated atmospherically corrected image, select **Delete Layer**, then click **Apply**.

   Now, only **cuprite_hyperion.img** displays in the Workstation.

3. In the Spectral Analysis Workstation, click the Atmospheric Adjustment icon  .

4. Click the **Method** dropdown list and select **Empirical Line**.

5. Right-click in the Main View and select **Zoom In By 2**.

6. Expand the size of the Spectral Plot at the bottom of the Atmospheric Adjustment Tool dialog.

7. Resize the other components of the dialog to your liking.
Open Library File

1. In the Spectrum Library window of the Atmospheric Adjustment Tool dialog, right-click to access the Spectrum TreeView menu.

2. Select Open a spectrum library file.

3. Navigate to the /examples directory and choose the Spectrum Library named cuprite_aviris_spectra.spl, then click OK in the File Selector.

Identify Sample

1. Adjust the position of the Link Box in the Main View so that Alunite Hill is visible in the Zoom View.

   See “Identify Sample” for the location of Alunite Hill if you cannot locate the area.

2. Right-click in the Zoom View and select Zoom In By 2 to see the feature clearly.

3. Click the Color Chooser icon and select the color Red.

4. Click the Polygon AOI icon in the AOI tools.

5. Digitize inside the area of Alunite Hill, which displays as fairly a uniform blue feature near the bottom left corner of the image. Double-click to complete the AOI.
The average spectrum of the pixels within the AOI displays in the Spectral Plot at the bottom of the Workstation, and is labeled **Sample**.

**Identify Reference**

1. Click the Plus symbol + to expand the **USGS** Spectrum Library.

2. Click the Spectrum symbol to select **Alunite GDS82 Na82**.

3. Drag the **Alunite GDS82 Na82** spectrum to the Spectral Plot.

The Alunite Hill AOI spectrum is labeled Reference in the Spectral Plot

The spectrum appears labeled as **Reference**. Note the regression plot in the upper-right quadrant of the Spectrum Plot displaying the plotted information for **Band 1**. Since **Band 1** has been designated a bad band, the plot has a red X overplotted.

4. Change the **Band** field to a band that is not excluded from analysis, such as **15**.

**Collect Other Samples**

In the Empirical Line method, wherein image data is forced to match the selected field reference spectra, at least two sample/reference pairs are required. Three or more pairs can improve results. A regression line is calculated for each band using these pairs.

Next, you collect other samples to use in the Atmospheric Adjustment process.

1. Using the Status Bar at the bottom of the Atmospheric Adjustment Tool dialog as a guide, locate the bright feature, which displays as a “line,” at about **Map pixel 185, -315**.
This Stonewall Playa area, which can typically be used as a spectrally flat area, is flooded in this dataset. However, you can still see the ridge of the playa displayed as a bright area. Use the Line AOI tool to collect a sample from the ridge.

2. Click the Line AOI icon , then click to collect the spectrum of the ridge. Double-click to end collection.

3. Click the Plus symbol + to expand the Cuprite AVIRIS Spectra Spectrum Library.

4. Click the Spectrum symbol 𝔦 for stonewall_playa_aoi and drag it to the Spectral Plot.
   The new point appears in the regression plot, and the slope-intercept parameters of the line for the selected band display.

5. Use the Status Bar at the bottom of the Atmospheric Adjustment Tool dialog to locate the Black Ridge, which located at Map pixel 49, -303.
6. Position the Link Box over the area.

7. Click the Polygon AOI icon , then digitize inside the Black Ridge. Double-click to complete collection.

8. Click the Spectrum symbol for black ridge 290-550, which is in the Cuprite AVIRIS Spectra Spectrum Library, and drag it to the Spectral Plot.

This is the third spectral pair to be used in Atmospheric Adjustment

The spectra in the Spectrum Library Cuprite AVIRIS Spectra were collected from the cuprite_aviris.img image using the AOI tools in the Spectral Analysis Workstation. Their accuracy is dependant upon the quality of the correction applied to that dataset.

9. Use the Status Bar at the bottom of the Atmospheric Adjustment Tool dialog to locate the Black Talus, which located at approximately pixel 204, -375.

10. Position the Link Box over the area.
11. Click the Polygon AOI icon , then digitize inside the black talus. Double-click to end collection.

12. In the Cuprite AVIRIS Spectra Spectrum Library, click the Spectrum symbol for SE black talus and drag it to the Spectral Plot.

It is now possible to scroll through the bands using the Band increment nudger and see the calculated regression (slope/intercept) line for each band. It is also possible to review the spectral pairs by clicking the Up Arrow icon and the Down Arrow icon . If one point seems far off the line, perhaps the AOI should be collected again, or a different reference spectrum used.

13. Click OK in the Atmospheric Adjustment Tool dialog to transfer the details to the project file.
**Evaluating Results**

*NOTE: This section assumes the other sections in this chapter have been completed.*

The *cuprite_hyperion.img* dataset was chosen for this exercise because the dataset you have used so far, *cuprite_aviris.img*, can be used as a truth dataset. As discussed in “Cuprite Dataset”, the Cuprite dataset has been expertly corrected at the USGS Spec Lab.

**IARR Results**

ERDAS IMAGINE must be running.

**Open Project File**

1. Click **Spectral Analysis Workstation** in the **Spectral Analysis** menu.

2. Click the Open icon , and navigate to the /examples directory.

3. Select the file *cuprite_basic.iwp*, then click OK in the File Selector.

4. Select **View -> Preset RGB Combinations -> True Color**.

**Select and Save Sample from Truth Image**

1. Use the Status Bar at the bottom of the Workstation to locate the Map pixel 232, -698, which is Alunite Hill.
2. Position the Link Box over Alunite Hill in the Main View.

3. Click the Color Chooser icon and select the color **Red**.

4. Click the Polygon AOI icon on the Spectral Analysis Workstation toolbar.

5. In the Zoom View, click to digitize inside Alunite Hill, which is located roughly at **Map pixel 232, -698**.
   The spectrum for the area you selected displays in the Spectrum Plot.

6. Right-click on the spectrum Legend, **Sample 1**, and select **Spectrum Properties** from the **Options** menu.

7. In the **Name** field, type **aviris_alunitehill**, then click **OK** in the dialog.

8. Click and hold on the **aviris_alunitehill** spectrum in the Legend, then drag it to **Material List 1** the Working Library window.

9. Right-click on the Book symbol for **Material List 1** and select **Rename** from the **Spectrum Library** menu.

10. Type **aviris_alunitehill** in the **Spectrum Library Name** field, then click **OK**.

11. Right-click on **aviris_alunitehill** and select **Save As** from the **Spectrum Library** menu.

12. Navigate to a directory where you have write permission.

13. Name the file **aviris_alunitehill.spl**, then click **OK** in the File Selector.

14. In the Workstation, select **File -> Close**.

15. Click **No** in the Attention dialog prompting you to save the file.

**Select Sample in IARR Corrected Image**

1. Click the **Spectral Analysis Workstation** button on the **Spectral Analysis** menu.

2. Select **File -> Open Analysis Image** from the menu bar.

3. Navigate to the directory where you saved **hyperion_iarr.img**.

   **NOTE**: You created this image in "**IARR**, "**Compute Results"**.

4. Select **hyperion_iarr.img**, then click **OK** in the File Selector.

5. Locate **Map pixel 39, -394** in this image—Alunite Hill.
6. Click the Color Chooser icon and select the color Red.

7. Click the Polygon AOI icon in the Spectral Analysis Workstation.

8. Click to digitize the same area of Alunite Hill as you did in the cuprite_basic.iwp file. The spectrum for the area you selected displays in the Spectrum Plot.

9. Right-click on the spectrum Legend, Sample 1, and select Spectrum Properties from the Options menu.

10. In the Name field, type iarr_alunitehill, then click OK in the dialog.

11. Click and hold on the iarr_alunitehill spectrum in the Legend, then drag it to Material List 1 the Working Library window.

12. Right-click on the Book symbol for Material List 1 and select Rename from the Spectrum Library menu.

13. Type iarr_alunitehill in the Spectrum Library Name field, then click OK.
14. Right-click on `iarr_alunitehill` and select **Save As** from the Spectrum Library menu.

15. Navigate to a directory where you have write permission.

16. Name the file `iarr_alunitehill.spl`, then click **OK** in the File Selector.

17. In the Workstation, select **File -> Close**.

18. Click **No** in the Attention dialog prompting you to save changes.

**Display Truth Image**

1. Click the Spectral Analysis Workstation button on the Spectral Analysis menu.

2. Select **File -> Open Analysis Image**.

3. Navigate to the `/examples` directory, select `cuprite_aviris.img`, then click **OK** in the File Selector.

4. Select **View -> Preset RGB Combinations -> True Color**.

5. Click the Sensor Information Tool icon 📚.

6. Click the **Load** button, then navigate to the `/etc` directory.

7. Select `aviris_1995.saf`, then click **OK** in the File Selector.

8. Click **OK** in the Sensor Information Tool dialog.

   These values are from the 1995 AVIRIS sensor.

   This sets the Workstation, in particular the Spectrum Plot, to 1995 AVIRIS bandpass (sensor information) parameters and defines no bad band regions.

**Select Spectra**

1. Click the Plus symbol + to expand the USGS Archive Library.
2. Click the Spectrum symbol for **Alunite GDS82 Na82**, then drag it to the Spectrum Plot.

3. Right-click in the Working Library window and select **Open a spectrum library file**.

4. Select **aviris_alunitehill.spl**, then click **OK**.
   
   *NOTE: This is the spectrum library file you created from the truth image, **cuprite_aviris.img**, in “IARR Results”, “Select and Save Sample from Truth Image”.*

5. Drag **aviris_alunitehill** from the Working Library to the Spectrum Plot.

6. Right-click in the Working Library window and select **Open a spectrum library file**.

7. Select **iarr_alunitehill.spl**, then click **OK**.
   
   *NOTE: You created this library in “Evaluating Results”, “Select Sample in IARR Corrected Image”.*

8. Drag **iarr_alunitehill** from the Working Library to the Spectrum Plot.

9. Click to select **Alunite GDS82 Na82** in the Legend of the Spectrum Plot.

**Change Legend Editor**

1. Right-click and choose **Legend Editor**.

2. Set the colors as follows: **Alunite GDS82 Na82** to **Red**, **aviris_alunitehill** to **Black**, and **iarr_alunitehill** to **Blue**.

3. Click **Apply**, then **Close** in the Legend Editor dialog.

4. Right-click in the Legend and select **Select None**.

5. Resize the Spectrum Plot to see details.
Change Chart Options

1. Right-click in the Spectrum Plot and choose Chart Options.
2. In the General tab, type a Title of Wavelength (micrometers).
3. Click the X Axis tab, set the Min value to 0.38, set the Major Incr. to 0.1, and set the Format to 0.00.
4. Click the Y Axis tab, set the Min value to 0.4 and set the Format to 0.0.
5. Click Apply then Close in the Chart Options dialog.

Figure 10: IARR Results

NOTE: Do not close the Spectral Analysis Workstation.

This optimizes the Spectrum Plot for analysis. Assuming that the Alunite GDS82 Na82 and aviris_alunitehill spectra represent the truth of how the spectrum of the Alunite Hill AOI should look, we can evaluate how well the IARR algorithm did in correcting this scene for atmospheric effects.

IARR Conclusions

In Figure 10, the three spectra are coplotted and the Spectrum Plot is optimized for evaluation.

Note, in Figure 10, that the spectrum of Alunite GDS82 Na82 is continuous with no data gaps. This is because this is a reference library spectrum and has no associated Bad Band List File (*.bbl). The aviris_alunitehill spectrum shows gaps in the spectrum starting around .51, 1.38, and 1.81 due to the Bad Band List File associated with the cuprite_aviris.img image. The preprocessed image file from which the iarr_alunitehill spectrum was derived has no Bad Band List File, but it does contain the effects of the cuprite_hyperion.bbl Bad Band List File. This is seen as flat sections in the spectrum where the software has interpolated over the gap due to the bad bands in the input file. These flat areas are seen starting at .91, 1.34, and 1.79.
The IARR spectrum shows several small peaks in the < 0.9 micrometer region. These are not seen in either of the two truth spectra and so are probably spurious. More disconcerting is the series of peaks and troughs in the 0.95 to 1.35 region. These are the result of the spectra character of the assumed internal average spectrum; it is not truly a flat field. The absorption band around 1.44 is lost in the IARR image due to bad bands in the hyperion image as is the 1.94 absorption band. The absorbances near 1.48, 1.76, 2.16, and 2.33 are well developed. Note the shoulder at 2.18 that also occurs in the \texttt{aviris\_alunitehill} spectrum but is not seen in the \texttt{Alunite GDS82 Na82} spectrum. Looking at these spectra, one might consider using only the spectral region > 1.4 for mapping alunite with this hyperion dataset and using the IARR technique.

**Modified Flat Field Results**

Next, create a Spectrum Library file for the Modified Flat Field results image.

**Open Modified Flat Field Corrected Image**

1. In the Spectral Analysis Workstation, select \texttt{File -> New} to open another Workstation.

2. Select \texttt{File -> Open Analysis Image} from the menu bar.

3. Navigate to the directory where you saved \texttt{hyperion\_mff.img}.

   *NOTE: You created this image in "Modified Flat Field", "Compute Results".*

4. Select \texttt{hyperion\_mff.img}, then click \texttt{OK} in the File Selector.

**Select Sample in Modified Flat Field Corrected Image**

1. Click the Color Chooser icon \(
\begin{array}{c}
\text{\textcolor{red}{Red}}
\end{array}
\) and select the color \textcolor{red}{Red}.

2. Click the Polygon AOI icon \(
\begin{array}{c}
\text{\textcolor{red}{Red}}
\end{array}
\) in the Spectral Analysis Workstation.

3. Click to digitize the same area of Alunite Hill as you did in the previous images, which is located at approximately \texttt{Map pixel 39, -394} in this image.

4. Right-click on the spectrum Legend, \texttt{Sample 1}, and select \texttt{Spectrum Properties} from the \texttt{Options} menu.

5. In the \texttt{Name} field, type \texttt{mff\_alunitehill}, then click \texttt{OK} in the dialog.

6. Click and hold on the \texttt{mff\_alunitehill} spectrum in the Legend, then drag it to \texttt{Material List 1} the Working Library window.

7. Right-click on the Book symbol \(
\begin{array}{c}
\text{\textcolor{red}{Red}}
\end{array}
\) for \texttt{Material List 1} and select \texttt{Rename} from the \texttt{Spectrum Library} menu.
8. Type `mff_alunitehill` in the **Spectrum Library Name** field, then click **OK**.

**Save Sample in Library**

1. Right-click on `mff_alunitehill` and select **Save As** from the **Spectrum Library** menu.
2. Navigate to a directory where you have write permission.
3. Name the file `mff_alunitehill.spl`, then click **OK** in the File Selector.
4. Select **File -> Close** in the Workstation.
5. Click **No** in the dialog prompting you to save changes to the file.

**Add Spectrum Library**

1. Return to the Workstation displaying the spectra **Alunite GDS82 Na82**, **aviris_alunitehill**, and **iarr_alunitehill**.
2. In the Working Library window, right-click and select **Open a spectrum library file**.
3. Select the library you just created, `mff_alunitehill.spl`, then click **OK** in the File Selector.
4. Click, hold, and drag the Book symbol for the `mff_alunitehill` Working Library to the Spectrum Plot.

**Change Legend Editor**

1. In the Spectrum Plot Legend, right-click on `mff_alunitehill` and choose **Legend Editor**.
2. Set the color for `iarr_alunitehill` to **Light Grey**—this “removes” it from display.
3. Set the color for `mff_alunitehill` to **Blue**.
4. Click **Apply**, then **Close** in the Legend Editor.
5. Right-click and choose **Select None** from the **Options** menu.
Figure 11: Modified Flat Field Results

NOTE: Do not close the Spectral Analysis Workstation.

Modified Flat Field Conclusions

In Figure 11, the four spectra are coplotted and the Spectrum Plot is optimized for evaluation.

The Modified Flat Field corrected spectrum, mff_alunitehill, shows a much better fit with the aviris_alunitehill spectrum. This is to be expected because this is the reference spectrum to which the cuprite_hyperion.img image was corrected. There are still several artifact features in the corrected spectrum notably at 0.984, 0.107, 0.130, 0.162, 2.027, 5.058, and 2.261 micrometers. If the aviris_alunitehill spectrum is considered truth, then the whole spectral range could be used for alunite mapping. If the Alunite GDS82 Na82 spectrum is deemed more desirable, it might be desirable to remove the region < 0.78 micrometers from the analysis.

Empirical Line Results

Next, create a Spectrum Library file for the Empirical Line results image.

Open Empirical Line Corrected Image

1. In the Spectral Analysis Workstation, select File -> New to open another Workstation.

2. Select File -> Open Analysis Image from the menu bar.

3. Navigate to the directory where you saved hyperion_el.img. 
   
   NOTE: You created this image in "Empirical Line", "Compute and Compare Results".

4. Select hyperion_el.img, then click OK in the File Selector.

Select Sample in Empirical Line Corrected Image

1. Click the Color Chooser icon  and select the color Red.

2. Click the Polygon AOI icon  in the Spectral Analysis Workstation.
3. Click to digitize the same area of Alunite Hill as you did in the previous images, which is located at approximately Map pixel 39, -394 in this image.

4. Right-click on the spectrum Legend, Sample 1, and select Spectrum Properties from the Options menu.

5. In the Name field, type el_alunitehill, then click OK in the dialog.

6. Click and hold on the el_alunitehill spectrum in the Legend, then drag it to Material List 1 the Working Library window.

7. Right-click on the Book symbol for Material List 1 and select Rename from the Spectrum Library menu.

8. Type el_alunitehill in the Spectrum Library Name field, then click OK.

**Save Sample in Library**

1. Right-click on el_alunitehill and select Save As from the Spectrum Library menu.

2. Navigate to a directory where you have write permission.

3. Name the file el_alunitehill.spl, then click OK in the File Selector.

4. Select File -> Close in the Workstation.

5. Click No in the dialog prompting you to save changes to the file.

**Add Spectrum Library**

1. Return to the Workstation displaying the spectra Alunite GDS82 Na82, aviris_alunitehill, iarr_alunitehill, and mff_alunitehill.

2. In the Working Library window, right-click and select Open a spectrum library file.

3. Select the library you just created, el_alunitehill.spl, then click OK in the File Selector.

4. Click, hold, and drag the Book symbol for the el_alunitehill Working Library to the Spectrum Plot.

5. In the Spectrum Plot Legend, right-click on mff_alunitehill and choose Legend Editor.

6. Set the color for mff_alunitehill to Light Grey — this “removes” it from display.

7. Set the color for el_alunitehill to Blue.

8. Click Apply, then Close in the Legend Editor.

9. Right-click and choose Select None.
Empirical Line Conclusions

In Figure 12, the five spectra are co-plotted and the Spectrum Plot is optimized for evaluation.

The results of the Empirical Line technique, `el_alunitehill`, are quite similar to that from the Modified Flat Field technique, `mff_alunitehill`. Again, this is not surprising because Alunite Hill was one of the spectral control points input into the correction. Another evaluation might involve looking at spectra that were not part of the input spectral control.

Close and Exit

1. Select **File -> Close All** from a Spectral Analysis Workstation, if you wish.
2. Click **No** in the Attention dialog prompting you to save changes.
3. Close any remaining dialogs by clicking the Close icon .
4. Select **File -> Exit IMAGINE** from the ERDAS IMAGINE menu bar, if you wish.

In the next chapter, you can learn how to use some of the tools you encounter frequently in spectral analysis.
This chapter provides additional examples to aid you in using IMAGINE Spectral Analysis.

Two commonly used tools in the IMAGINE Spectral Analysis software are the Sensor Information Tool and the Spectrum Plot. These exercises do not yield output files, they just present the steps to complete the processes.

In the first section, you are going to perform the following basic steps:

- Open the Sensor Information Tool
- Edit sensor information
- Save the file
- Apply the new *.saf file

Approximate completion time for this portion of the Tour Guide is 5 minutes.

In the next exercise, you are going to perform the following basic steps:

- Open spectrum and project
- Change band combinations
- Identify a sample
- Alter Legend properties
- Change chart options
- Open another Spectrum Plot
- Compare spectra
- Close and exit
Approximate completion time for this portion of the Tour Guide is 15 minutes.

Create a Sensor Attribute File

Some image files, such as those imported using the Generic Binary importer, do not have a Sensor Attribute File (*.saf) attached, or the desired *.saf file may not be present in the *.saf library located in /etc. A *.saf file can be created using the Sensor Information Tool.

For example, some airborne sensors collect different band combinations depending upon the customer’s requirements. Under these circumstances, it is necessary for you to create the desired *.saf file. You can obtain the necessary information from the data provider.

Open the Sensor Information Tool

You must have ERDAS IMAGINE running and a Spectral Analysis Workstation open with an analysis image or *.iwp file displayed.

1. Click on the Sensor Information Tool icon in the Spectral Analysis Workstation.

   The Sensor Information Tool dialog opens.

   ![Sensor Information Tool dialog]

   Click Save As to begin creating a new *.saf file

2. In the Sensor Information Tool dialog, click the Save As button.

3. Navigate to the directory into which you want to save the new *.saf file.

4. Name the file, then click OK in the File Selector.

Edit Sensor Information

You input the actual, new sensor information via the ERDAS IMAGINE Text Editor.

1. Select Tools -> Edit Text Files from the ERDAS IMAGINE menu bar.
2. Click the Open icon to access a File Selector, then navigate to the directory where you saved the *.saf file.

3. Click the Files of type dropdown list and select All Files, then select the *.saf file.

Note the structure of the *.saf file. Simply use the standard tools to correctly populate the file.

4. Type the new **SensorName** in the two locations at the top of the file.

5. If necessary, change the **BandUnits** and **BandMeasurement** by typing over the existing text.

6. If necessary, change the number following **BandCount**.

7. Sequentially type the **Value** and **Width** parameters for each band (layer) in the image.

8. If necessary, add bands by appending them to the end of the list, following the same convention:

   \[
   \text{Band xxx} \{ \text{Value xxx.xx; Width xx.xx; } \}
   \]
**Alternate Method**

Alternately, you can import sensor attribute information directly into the Sensor Information tool using the following steps:

1. Open the Sensor Information dialog by clicking the icon.
2. Click, hold, and drag to select the headings **Wavelength** and **Bandwidth**.
3. Right-click and select **Import** from the **Column Options** menu.
4. Select the file to import, such as `f970619t01p02_r02.c.spc`, located in `/examples`, which is a typical AVIRIS bandpass information file.
5. Click **Options**, then select the **Separator Character** called **WhiteSpace**.
6. Click **OK** in the Import Column Options dialog, then click **OK** in the Import Column Data dialog.
7. Click **Save As** in the Sensor Information Tool, then give the *.saf file a name.

**Save the File**

1. Click the Save icon to save the edits to the *.saf file.
2. Click the Close icon to close the Text Editor.

**Apply the New Sensor File**

You can now apply the new Sensor Attribute File to an analysis image or *.iwp file displayed in the Spectral Analysis Workstation.

1. In the Sensor Information Tool dialog, click the **Load** button, then navigate to the directory in which you saved the *.saf file.
2. Select the file, then click **OK** in the File Selector.
3. Click **OK** in the Sensor Information Tool dialog.
   The Spectrum Plot in the Workstation updates accordingly.

   ![Tip](Tip.png)  
   You may want to view other *.saf files for reference. They are located in the /etc directory.

**Conclusions**

Use of the Sensor Information Tool allows you to create a Sensor Attribute File for virtually any image you choose to use in analysis.
Optimize the Spectrum Plot

Open Spectrum and Project

The Spectrum Plot in the Spectral Analysis Workstation has been designed to give you maximum flexibility in displaying and analyzing spectral profiles. The following exercise demonstrates that flexibility.

You must have ERDAS IMAGINE running and an empty Spectral Analysis Workstation displayed.

1. In the Spectral Analysis Workstation, click the Plus symbol next to the USGS Archive Library.

2. Click the Spectrum symbol for Alunite GDS82 Na82 and drag it into the Spectrum Plot at the bottom of the Workstation.

Notice that the X-axis, which displays wavelength, has adjusted to accommodate the spectral range of the plotted spectrum. The Y-axis defaults to a 0 to 1 range, and the displayed spectrum is normalized to fit into this numerical range.

3. In the Workstation, select File -> Open Project.

4. Navigate to the /examples directory and select the project file cuprite_basic.iwp.

5. Click OK in the File Selector to load the project file into the Spectral Analysis Workstation.

This is the spectrum before sensor information is added to the Workstation

The library spectrum you selected displays in the Spectrum Plot
Notice that the X-axis, Wavelength (nanometers), converts to the spectral range of the AVIRIS sensor, which is the sensor used to capture this image. This is because the Workstation is dominantly responsive to the analysis image. The Alunite GDS82 Na82 spectrum is not damaged—it is simply redisplayed with a slight difference in the X-axis parameters.

Change Band Combinations

1. In the Spectrum Plot, click on the Blue indicator line, and move it to band 191.

   The band number displays on the bottom of the Spectral Analysis Workstation, in the Status Bar.

2. Move the Green indicator line to band 149, and the Red indicator line to 114.

   The analysis image redisplayes in the Spectral Analysis Workstation.
Identify Sample

1. Right-click in the Main View and select **Inquire Cursor** from the **Quick View** menu.

2. In the Inquire Cursor dialog, type the following **Map** coordinates into the **X** and **Y** fields, respectively: 232, -698.

   NOTE: The values you enter are modified slightly by the software to account for image resampling.

3. In the Main View, adjust the Link Box so that it covers the area identified by the Inquire Cursor.

4. In the Spectrum Plot, move the **Red**, **Green**, and **Blue** indicators to the spectral peaks (for example, 131, 152, and 201, respectively) and observe how this affects the visual detection of Alunite in the views.
5. Drag and drop two other Alunite spectra from the USGS Archive Library into the Spectrum Plot.

6. Click Close in the Inquire Cursor dialog.

**Alter Legend Properties**

1. Right-click in the Legend of the Spectrum Plot and select **Legend Editor**.
   
The Legend Editor CellArray opens.

2. Right-click in each of the **Color** cells and choose a new color for the Legend.
   
   Select bold colors, such as **Red**, **Black**, or **Green** for easy viewing.
3. Click **Apply**, then click **Close** in the Legend Editor dialog.

![The Legend reflects your changes](image)

**Change Chart Options**

1. Right-click in the Spectrum Plot and select **Chart Options**. The Chart Options dialog opens.

![Each axis has its own tab where you can make changes to its appearance](image)

2. On the **General** tab of the Chart Options dialog, type **Alunite Spectra** in the **Title** field.

3. Click the Color Chooser icon and set the **Plot Background** to **Light Gray**.

4. Click **Apply**.

5. Click the **X Axis** tab in the Chart Options dialog.
6. Change the **Min** value to **1180**.

7. Change the **Major Incr** (increment) value to **200** and the **Minor Incr** value to **50**.

8. Click **Apply** in the Chart Options dialog and note the changes to the Spectrum Plot.

9. Click the **Y Axis** tab in the Chart Options dialog.

10. In the **Title** window type the new title **Relative Reflectance**.

11. Set the **Min** value to **0.2** and the **Max** value to **0.9**.

12. Click **Apply** and note the changes in the Spectrum Plot.
13. Click **Close** in the Chart Options dialog.

**Open Another Spectrum Plot**

You can add as many Spectrum Plots to the bottom of the Spectral Analysis Workstation as you wish. You may want to maximize the display of the Workstation by clicking the Maximize icon so that you can see all of the details.

1. On the Spectral Analysis Workstation, click the Spectral Plot icon to open another Spectral Plot at the bottom of the Workstation.

2. Confirm that the title bar of the new Spectrum Plot is active.

**Compare Spectra**

1. From the **USGS** Archive Library, click spectrum **Alunite GDS82 Na82** and drag it to the second Spectrum Plot.

2. In the Archive Library window, click the Plus symbol next to **ASTER** to open the Archive Library.

3. Click the Spectrum symbol for two Alunite spectra in the **ASTER** Archive library and drag them to the second Spectrum Plot.
4. Use the Chart Options dialog to optimize the display.

For instructions, see “Change Chart Options”.

Close and Exit

1. Select **File -> Close All** in the Spectral Analysis Workstation, if you wish.

2. Select **Session -> Exit IMAGINE** from the ERDAS IMAGINE menu, if you wish.

Conclusions

Changing the display of the Spectrum Plot may make evaluation of your results easier. Using the Chart Options, you can quickly make alterations to the display, then decide whether or not you want to maintain the changes.
Reference Material
Data Importing

Introduction

Hyperspectral imagery to be used with the IMAGINE Spectral Analysis module can best be accessed by importing. Importing the data into ERDAS IMAGINE and thus, the ERDAS *.img format, has many advantages: file access is optimal, sensor information and statistics are already stored, etc.

AVIRIS Imagery

Imagery from the NASA/JPL AVIRIS sensor can be accessed in several ways:

- an AVIRIS importer in the Import module, or
- the Generic Binary importer may be used for some older AVIRIS datasets, which is set with the following parameters:

  **Data Format:** BIP
  **Data Type:** Signed 16 bit
  **Swap Bytes:** (yes)
  **# Rows:** 512
  **# Cols:** 614
  **# Bands:** 224

Import time for a typical AVIRIS scene is 17 minutes.

When the imported datasets are used within IMAGINE Spectral Analysis, the sensor information (band-to-wavelength mapping) can be applied using the Sensor Information Tool and selecting the `/etc/aviris.saf` file.

HYDICE Imagery

Imagery in the SITAC Hyperspectral Digital Imagery Collection Experiment (HYDICE) format can be accessed in several ways:

- a HYDICE importer in the Import module, or
• the Generic Binary importer may be used for some HYDICE datasets, which is set with the following parameters:

  Data Format: BIL
  Data Type: Signed 16 bit
  Swap Bytes: (yes)
  File Header Bytes: 512
  # Rows: 960
  # Cols: 320
  # Bands: 210

Import time for a typical HYDICE scene is 18 minutes.

When the imported dataset is used within IMAGINE Spectral Analysis, the sensor information (band-to-wavelength mapping) can be applied using the Sensor Information Tool and selecting the HYDICE.saf file, which is located in the /etc directory.

**ENVI Format**

Imagery in the Environment for Visualizing Images (ENVI) format can be accessed in the following ways:

• an ENVI importer in the Import module, or

• the Generic Binary importer may be used for some ENVI datasets, which is set with the requisite parameters. These parameters can be obtained by reading the ENVI *.hdr file in a text editor.

When the imported dataset is used within IMAGINE Spectral Analysis, the sensor information (band-to-wavelength mapping) can be applied by using the Sensor Information Tool and selecting the appropriate *.saf file, which is located in the /etc directory.

**HDF Format**

Installing IMAGINE Spectral Analysis adds new importers. An Hierarchical Data Format (HDF) format importer has been provided for the following imagery types:

• Moderate-resolution Imaging Spectroradiometer (MODIS)

• Advanced Spaceborne Thermal Emission and Reflection Radiometer (ASTER)

**Hyperion Format**

Imagery in the Hyperion format can be accessed via the Hyperion importer in the Import module.
Cuprite Dataset

Introduction

The alteration zone of Cuprite, Nevada has long been used as a test site for airborne and spaceborne remote sensors. Use of this area as a test site originates with the work of Shipman and Adams. Since that time, numerous studies, both on the ground and from remote platforms, have built upon each other to provide a well-characterized test area.

Dataset

The AVIRIS image of Cuprite, Nevada (cuprite_aviris.img) and the truth classification map derived from it (cuprite_classified_map.img) are subsets of datasets provided by Dr. Roger Clark and Dr. Gregg Swayze at the USGS Spectroscopy Lab in Denver, Colorado. Visit the web site http://speclab.cr.usgs.gov/cuprite.html for a list of papers regarding Cuprite.

The file cuprite_aviris.img is a subset of a mosaic of two 1995 AVIRIS scenes. This system, NASA/JPL AVIRIS, has 224 spectral channels from 0.4 to 2.5 microns. The spatial resolution is about 17 meters pixel spacing. This image has been atmospherically corrected at the USGS Spectroscopy Lab as discussed in Surface Reflectance Calibration of Terrestrial Imaging Spectroscopy Data: a Tutorial Using AVIRIS (Clark et al. 2000).

The classification map is the corresponding subset of the classification map discussed in the USGS Spectroscopy Lab publication Imaging Spectroscopy Material Maps: Cuprite Introduction (Clark and Swayze 1998). The full classification map image is discussed therein as follows:

The mineral map shown here is derived from analyzing the vibrational absorption features in minerals (typically in the 2 to 2.5 micron spectral region) common to OH-, CO3-, and SO4-bearing minerals. Each mineral has a specific crystal structure and subtle changes in that structure change absorption bands, even with the same ion (such as OH). Thus specific mineralogy can be identified. In fact, the absorption is so sensitive that small changes in chemistry of a mineral make identifiable changes in the absorption bands, so that solid solution series, or element substitutions can be mapped (for example the high, medium, and low aluminum content of muscovites, or the K versus Na Alunites).

The image shown here is a mineral map derived from AVIRIS data obtained over Cuprite, Nevada, in 1995. The scene is 10.5 km wide and 17 km high and north is up.
Within the Cuprite dataset, two minerals are emphasized in the Tour Guide exercises. One, Buddingtonite, is an ammonia-containing feldspar (Baugh and Kruse 1995) with the chemical formula (NH$_4$)$_2$Si$_3$O$_8$.

This mineral has only three small occurrences mapped in the truth image, which is named `cuprite_classification_map.img`, and is used as an example of a low probability or rare material for Target Detection.

The second mineral of interest is Alunite. This is a sulfate mineral with the chemical formula KAl$_3$(SO$_4$)$_2$(OH)$_6$. This mineral exists as both large outcrop areas and, consequently, as a component of the surrounding alluvial/fluvial deposits. It is one of the main components of this scene and is plotted in red in `cuprite_classified_map.img`. It is used as the example for Material Mapping.
Introduction

Following are works referenced in this document, or are recommended for additional study of spectral analysis.

Works Cited


Clark, R. N., G. A. Swayze, K. Heidebrecht, A. F. H. Goetz, and


Laboratories Publication 85-41:111-119.


detection in a forest environment using spectral imagery. SPIE 3118:46.


Index

Symbols
*.bbl 55
*.gif 103
*.hdr 220
*.iwp 4, 6
*.mtx 163
*.saf 6, 206

A
Absorption features 15
ACORN 17
Airborne Visible/Infrared Imaging Spectrometer 14
Analytical metrics 4
Analytical Spectral Devices 23
Angle distance 27
Anomaly Detection 5, 43
Anomaly mask 5, 47
AOI
  compute noise 162
Archive Library 41
Arrange layers 56
ASCII 22
ASD 23
ASTER 20, 22, 23
ATCOR 17
Atmospheric Adjustment 177
  Empirical Line 188
  IARR 179, 194
  Modified Flat Field 184, 200
Atmospheric correction 17
Atmospheric modeling 17
Atmospheric transmission codes 17
ATREM 17
At-sensor radiance 30
Attributes
  change 103, 117
AVIRIS 14, 23, 219

B
Background 5, 158
Bad Band List File 90, 139
Bad bands 6, 50
  save data 55
Band combinations 135
  preference 135
  preset combinations 135
Band ratios 15
Bandpass 15, 89

C
Calibration coefficients 16
Candidate materials 119
CASI 23
CellArray 93
  Bad Band Selection Tool 139
  Legend Editor 212
  Material Identification 126
  Spectral Subset 129
  Target Detection 148
CEM 25, 85
Chart options 151
Classification map 221
Compact Airborne Spectrographic Imager 23
Compute noise 162
Constrained Energy Minimization 25
CSES 17
Cuprite, Nevada dataset 221

D
Data histogram 139
Digital number 5
Distributed Flat Field 28
DLR 17
DN 5

E
Eigennumber-eigenvalue plot 171
Eigenvectors 26
Empirical line 8, 18, 28
ENVI 220
Equal area normalization algorithm 30
ERDAS 17
Export results 127

F
Field spectrometer 18
File type
  *.bbl 55
  *.gif 103
  *.hdr 220
  *.iwp 4, 6
  *.mtx 163, 173
  *.saf 6, 206
Filtering methods 164
First noise band 172
FLAASH 17
Flat Field
  distributed 28
Modified 29
Flat field 8, 28

G
Gaussian distribution 9

H
Hazardous Air Pollutants 23
HDF 220
HITRAN 17
HYDICE 219
HyMap 23
Hyperion 23, 220
Hyperspectral Mapping 23
Hyperspectral sensor 13

I
IARR 8, 29
Image cube 31
Image noise 162
Image preview 139
Imaging spectrometer 16
Imaging spectroscopy 13
Importer 219, 220
Information layers 163
Inquire Box 137
Inquire Cursor 73
Internal average 29
Internal average relative reflectance 8

J
JPL Archive Library 41

L
Legend Editor 109, 212
Log residuals 30
Log-space 30
Look-up table 28
Low-pass filter 164, 174
LOWTRAN 17
LUT 28

M
Material Identification 119
Material map 90
Material Mapping 5, 85
Matrix Text File 163, 173
Mean filtering method 164
Merged spectrum
    create 152
Minimum Noise Fraction 8
Mixed pixel 13
MNF transform 9, 31, 160
Modified Flat Field 29
MODTRAN 17
Movie Player 53
Multispectral sensor 13

N
Noise 162
Noise covariance 162
Noise layers 163
Noise variance 31

O
Optical sensors 13
Orthogonal Subspace Projection 8
Overlay image 70

P
Panchromatic sensor 13
Pearsonian correlation coefficient 28
Physical parameter reflectance 16
PIMA 23
Pixel albedo 30
Plot 14
Plot options
    General tab 213
    X Axis tab 213
    Y Axis tab 214
Portable Infrared Mineral Analyser 23
Preferences 42
Preprocessing 4
Preset band combinations 135
Preset filtering method 163
Principal components 30
Probe 23
Profile 14

R
Radiance 8
Raw DN form 8
Reflectance 8, 14
Regression line 188, 193
Relative reflectance 8
Resampling 144
Reverse MNF 163

S
S/N 8
SAM 27
SAM algorithm 27
Sample
    identify 123
Save band data 55
Scene variance 31, 164
SCM 27
Sensor Attributes File 6, 67, 80
  create 206
    with MNF image 168
Sensor information 6, 66, 79
SFSI 23
Shade endmember 21
Shift-difference technique 31
Short Wavelength Infrared Full Spectrum Im-
er 23
Shortwave infrared 7
Signal-to-noise ratio 25
Signature 7
  collect 143
Similarity 5
SITAC 22
Skip factor 163
Slope/Intercept 28, 193
Spatial subset 8
  create 136
Spatial Subset Selection Tool 136
SPECMIN 18, 23
Spectra
  copy 106
  map 114
    scene-derived 112
Spectral Analysis Project
  create 134
Spectral Analysis Workstation 35
  Edit menu 37
  File menu 35
  Help menu 37
    interactive tools 38
    preprocessing tools 39
  View menu 37
    views 40
    Workstation management tools 38
Spectral angle 27
Spectral Angle Mapper 27
Spectral control points 18
Spectral Correlation Mapper 27
Spectral libraries 21
Spectral pair 190
Spectral plot 14
Spectral profile 14
Spectral range 7
Spectral signatures 21
Spectral subset 77, 128
  create 141
Spectrum
  AOI 153
    merged 152
  plot options 209
Spectrum properties 75
Spectrum TreeView 61
Spectrum-AOI pair 28
Standard deviation 186
Subpixel detector 111
Subset 8
Swipe tool 47

T
Target 5
Target Detection 5
  run 146
Target mask 63
Target spectrum 65, 78
Ternary model 20
Thermal 7
Thermal Emission Spectral Library 23
Threshold 5, 79
Truth image 71

U
UGLs 23
Unit variance 9
Unity constraint 26, 85
User Generated Libraries 23
USGS Archive Library 41

V
Visible/near infrared 7

W
Wavelength 14
Working Library 41
  create 76, 122
  rename 122
  save 123

Z
Zero filtering method 164