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The DEM Extraction Module
This tutorial introduces the Digital Elevation Model (DEM) Extraction Module with functionality that
enables you to extract elevation data from stereo imagery to create a DEM. A DEM is a raster grid of
elevation values that represent a surface. DEMs are useful for many applications such as mapping,
orthorectification, and land classification. They are often used to create contour maps and perspective
maps and for various types of land use planning applications.  

The DEM Extraction Module enables you to extract elevation data from scanned or digital aerial
photographs, or from an along track or an across track pushbroom satellite acquisition, such as those
from the ALOS PRISM, ASTER, CARTOSAT-1, FORMOSAT-2, GeoEye-1, IKONOS, KOMPSAT-2,
OrbView-3, QuickBird, WorldView-1, or SPOT satellites. Along track stereo images are acquired on
the same orbital pass by a satellite which usually has more than one sensor looking at the Earth from
different angles. Across track stereo images are those taken by the same sensor on multiple orbits.  

The DEM extraction process requires a stereo pair of images containing rational polynomial coefficients
(RPC) positioning from aerial photography or pushbroom sensors. RPCs are used to generate tie points
and to calculate the stereo image pair relationship. See "Building RPCs" in the ENVI User's Guide for
details. DEM extraction does not currently support replacement sensor model (RSM) positioning.

The DEM Extraction Module is comprised of the DEM Extraction Wizard and three DEM tools: the
DEM Editing Tool, Stereo Pair 3D Measurement Tool, and the Epipolar 3D Cursor Tool. 

Note: The DEM Extraction Module requires an additional license in your installation; contact your
ENVI sales representative to obtain a license. If you are not licensed for the DEM Extraction Module,
the tool will be disabled. 

Files Used in this Tutorial
ENVI Resource DVD: /Data/aster

File Description

AST_L1A.hdf ASTER Level 1 data

AST_L1A.hdf.met Metadata for above

U. S. Geological Survey Data. This ASTER Level 1 dataset was processed by the Japanese Ground
Data System (GDS) and archived by the Land Processes Distributed Active Archive Center (LP
DAAC) at the USGS EROS Data Center (EDC). The data contains advanced spaceborne thermal
emission and reflection radiometer (ASTER) data files in the hierarchical data format for earth
observing system (HDF-EOS).

Working with the DEM Extraction Wizard
DEM extraction is a multi-step decision making process involving the setting of many parameters used in
different steps. These steps can be run individually, or from within the DEM Extraction Wizard. The
Wizard guides you through nine steps, presenting you with objective parameters, such as
minimum/maximum elevation of the area of interest, as well as other strategy parameters that depend
upon the terrain relief, cultural content, image quality, shadowing, and the desired speed of operation.
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Following is a diagram of the DEM Extraction Wizard workflow. The Wizard allows you to step
forward, backwards, and to save the workflow at any step so that you can continue at a later time. 
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Inputting a Stereo Image Pair
The DEM extraction process begins with input of a stereo image pair that contains or has associated
RPCs. For this demonstration, we will extract a DEM from an ASTER L1A product using the DEM
Extraction Wizard. ASTER uses the visible near infrared (VNIR) telescope’s normal (3N) and
backward (3B) viewing bands for along-track stereoscopic observation. In this example, we will use the
3B band for the left image and the 3N band for the right image.

In the following steps, you will select a stereo pair of images containing RPC positioning from either an
along track or an across track satellite acquisition.

1. From the ENVI main menu bar, select File > Open External File > EOS > ASTER.

2. Navigate to the Data\aster directory, select the file AST_L1A.hdf from the list, and click
Open. The Available Bands List is displayed.

3. From the ENVI main menu bar, select Topographic > DEM Extraction > DEM Extraction
Wizard > New. 

4. Click the Select Stereo Images button. The Select Left Stereo Pair Image dialog appears. The
order of the data entry here should not matter. However, in tools such as the tie point generation,
you will likely see different tie point selections and calculated errors because the solution will be
different.

5. Select ASTER VNIR Band3N and click OK. The Select Right Stereo Pair Image dialog
appears.

6. Select ASTER VNIR Band3B and click OK. ENVI estimates the scene minimum and maximum
elevations using the associated RPC information and a World DEM file included in the ENVI
sample datasets.

7. Click Next to continue.
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Defining Ground Control Points
In the second step of the Wizard, you will be provided with the option to define or use existing GCPs.
When defining GCPs, you can choose any of the following options:

l No GCPs. Choosing this option would result in a relative DEM, which is a DEM with possible
differences in position, scale and rotation from geodetic coordinates on the ground and mean sea
level.

l Define GCPs Interactively. Choosing this option would require that you manually enter, load,
and edit GCPs that will tie the DEM to a planar map projection. The result of which would be an
absolute DEM. An absolute DEM uses ground control and has horizontal and vertical references
systems tied to these geodetic coordinates.

l Read GCPs From File. Choosing this option would require that you select a GCP file from
which to read GCPs.

For this exercise, you will not use GCPs so the resulting DEM values will be relative elevations.

1. Click the No GCPs radio button. Note that the Examine and Edit Stereo GCPs option (step 3 of 9)
is not available. It is only available if you have loaded a GCP file into the Wizard.

2. Click Next to continue. ENVI skips Step 3 and moves you to Step 4.
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Defining Tie Points
Next, the relationship between the stereo images must be defined by selecting or generating tie points.
The tie points are used to define the epipolar geometry and create epipolar images, which are used to
extract the DEM. When defining tie points, you can choose any of the following options:

l Generate Tie Points Automatically. ENVI can generate tie points automatically, based on
terrain features within the image.

l Define Tie Points Interactively. Choosing this option would require that you manually define tie
points between the two stereo images.

l Read Tie Points From File. Choosing this option would require that you select a tie point file
from which to read the tie points.

For this exercise, you will generate tie points automatically.

1. Click the Generate Tie Points Automatically radio button. Automatic tie point generation
requires four parameters to be specified:                  

l The Number of Tie Points you wish to generate.

l The Search Window Size and the Moving Window Size. The Search Window is a
defined subset of the image. The Moving Window defines an area within the Search
Window that is used to scan and find a topographic feature match for a tie point
placement. The size of these windows should be considered with respect to the spatial
resolution of the data. For example, higher spatial resolution data, such as sub-meter
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QuickBird imagery, should use larger window sizes in order to increase the reliability
of finding similar features between the stereo image Moving Windows.

l The Region Elevation is the average elevation of the region based on the dominant
elevation of the image. It is estimated based on the associated RPC information.

Note: Increasing the number of tie points, the Search Window Size, and/or the Moving
Window Size will increase the processing time but should also increase the reliability of the
matching.

2. Increase the number in the Search Window Size field to 101 (type and replace the current
number in the field or use the increase/decrease buttons). Note that the Search Window Size is
always an odd number in square pixels and must be larger than the Moving Window Size.

3. Increase the number in the Moving Window Size field to 19, which is reasonable for 15 m
ASTER data.

4. Ensure that the Examine and Edit Tie Points toggle is set to Yes so that you can review the tie
points and edit those which are less than optimal, then click Next to continue. It may take a few
minutes to generate the tie points.

Editing Tie Points
Once the tie points have been generated, step 5 of 9 of the DEM Extraction Wizard (View and Edit Tie
Points) will display both images and tie points for examination. Explore and experiment with the options
in this step. You can use the Reset button to undo the last change.

1. Try manually entering x and y locations for the left and right images.

2. Move the Zoom box to a new location in one of the images and click Update to update the tie
point.

3. Use the Current Tie Point arrow buttons to examine each point.

4. Click the Likely Error Rankings drop-down button. This lists the tie points in order of relative
likelihood of error. The first tie point listed is considered the “most likely” to have error.
However, it is possible that the top ranking tie point has very little error since it is only an
approximation. In this case, you should check through the list for pixels with obvious misalignment
but with lower error.

5. Use the Auto Predict section to help estimate placement of the tie point in the image.

6. Examine the Maximum Y Parallax value displayed on the Wizard screen to see if you have
improved the amount of error in the tie points. Any time you update a tie point, you should
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examine the Y Parallax value. It provides an estimate, in pixels, of displacement between the
images in the y direction. Tie points should be adjusted so that the Y Parallax is minimized.
Ideally, it would display 0, indicating no offset in the y direction - all points are displaced in the x
direction only. The maximum allowable Y Parallax value is 10 pixels. You must reduce the value
to less than 10 in order to continue DEM extraction.

7. Once you have a Y Parallax under 10 pixels, click Next to continue.

Calculating Epipolar Geometry and Images
Using the tie points, ENVI will calculate the epipolar geometry and epipolar images that are used to
extract the DEM. These epipolar images describe the relationship between the pixels in the stereo pair
and they can be viewed in 3D using anaglyph glasses. However, it should be noted that approximately
10% of the population cannot see in stereo, so the images may not appear in 3D for these individuals.

1. The epipolar parameters dialog allows you to enter the name for the left and right epipolar images
and select how and where you wish to output the images.

2. You also have the option in this dialog to apply an Epipolar Reduction Factor, which will
reduce the resolution of the extracted DEM. This is useful if you do not require a full resolution
DEM for your application or demo as it will take less processing time to create the DEM. For
example, this ASTER stereo pair has a resolution of 15m. If the requirement was for a 30m DEM,
you could reduce the DEM by 2 using the Epipolar Reduction Factor.
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3. Using the Examine Epipolar Results option, you can view the epipolar images prior to the DEM
extraction. The images can be viewed in 3D using anaglyph glasses.

You can view the images using two different RGB triplets. The first option allows you to view the
left epipolar image as red and the right epipolar image as green and blue. The second option
allows you to view the right epipolar image as red and the left epipolar image as green and blue.

Click RGB=Left,Right,Right. The resulting epipolar image is displayed as an RGB triplet. If
viewed through anaglyph glasses, the image will appear in 3D.

Depending on which image was initially entered as the right or left stereo image, the RGB triplets
can be viewed as an inverse where peaks appear as valleys.

4. Click Next to continue.
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Specifying Parameters
Now that you have created the epipolar images, you will need to specify the DEM output projection and
extraction parameters.

Specifying DEM Output Projection Parameters
Step 7 of the DEM Extraction Wizard allows you to set parameters for the DEM output projection and
map extents. You have the option to change things such as the output projection type, pixel size, or
output image size. Experiment with some of the following options.

l You can change the Eastings and Northings fields (E and N respectively) to Latitude and
Longitude (Lat and Lon) by clicking the toggle button next to the map projection field. 

l Click the Change Proj button to change the projection or projection units.

l You can type in values for X Pixel Size and Y Pixel Size in the fields provided.

l The Output X Size and Output Y Size values describe the output DEM size in pixels. This is the
overlapping region of your output projection.

l The Options drop-down button allows you to set the output size units, choose options when pixel
sizes change, restore initial values on this step of the Wizard, and use the map extent from an
existing file.

l For this exercise, you will use the defaults provided for this screen. Click Next to continue.
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Specifying DEM Extraction Parameters
Step 8 of the DEM Extraction Wizard allows you to specify the parameters for the DEM extraction.
Here you can define thresholds, set the size of the area in which you wish to perform image matching,
determine the level of terrain detail, and specify where to save your DEM result.

l The Minimum Correlation value is the correlation coefficient threshold used to determine
whether or not the points within the Moving Windows are a good match. If a correlation
coefficient is smaller than this minimum, then the points are not considered to be a good match. In
general, correlation values between 0.65 and 0.85 are reasonable, but for larger Moving Window
sizes, a less strict correlation can be used.

l Edge Trimming indicates the normalized percentage of trimming to be applied to the outer edges
of the output DEM.

l The Moving Window Size defines the area in which to compute the correlation coefficients
between the two images. As with automatic tie point generation, a larger window size should be
used with higher resolution imagery in order to increase the reliability of finding similar features
within the Moving Window.

l From the Terrain Relief drop-down list, you can select the type of terrain your DEM best
represents. Select Low if the terrain consists primarily of flat areas and low-terrain relief. The
DEM will have a smoothed effect. Moderate is the default option, which is appropriate for most
terrain types. Select High if the terrain consists primarily of mountainous and high-terrain relief.
Topographic features with large relief displacement are not smoothed.

l DEM extraction uses image matching to find matching features on the left and right image of the
stereo pair. The use of Terrain Detail determines how precisely you wish to represent the terrain
in the DEM output. This option controls the number of image pyramid levels used during image
matching. The levels range between Level 1 (minimum) and N (maximum), where N is
determined by the epipolar image resolution. Level 1 terrain detail indicates that image matching
stops after the coarsest level of image matching is finished. Level N indicates that image
matching is performed on the highest image resolution possible (the epipolar image resolution).
Higher levels of terrain detail will require a more rigorous level of image matching and will affect
the processing time required to extract the DEM.

l You can set parameters for the DEM result. These parameters include the Output Data Type
field, which allows you to choose between Integer (default) or Floating Point. You can also
choose to save the output to File (default) or Memory, and you can select where you wish to save
the DEM result.

For this exercise, you will use the defaults provided for this screen to produce a moderately detailed
DEM.

1. Examine the options provided.

2. Type or choose a filename in Output DEM Filename field.

3. Click Next to start the DEM extraction process. The processing time required can be significant,
depending on your choices for Moving Window Size and Terrain Detail. As the processing
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completes, the various files created (Left Epipolar Image, Right Epipolar Image, and Elevation
result) appear in the Available Bands List.
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Examining Results
Once your DEM extraction is complete, you can examine and/or edit the resulting DEM. The last screen
of the Wizard provides two options; both options will load the DEM result to a display group, but one
will also open the DEM Editing Tool so you can edit the DEM. You will explore each of the options in
this step to examine and edit the resulting DEM.

Loading the DEM Result to the Display and Performing 3D
SurfaceView
To begin, you will load the DEM result to display and perform a 3D surface view using the spectral
bands from the original ASTER image to examine the DEM results.

1. Click the Load DEM Results to Display button (do not close the DEM Extraction Wizard).
Since this extracted DEM has been projected using the UTM coordinate system, you will need to
use a projected image to perform the overlay in order to have properly aligned image and DEM
pixels.

2. From the ENVI main menu bar, select Basic Tools > Preprocessing > Data-Specific Utilities >
ASTER > Georeference Data. This option will georeference the VNIR bands of the ASTER 1A
data.

3. Select the AST_L1A.hdf file and click OK.

4. Select UTM and click OK.

5. In the Output Result to section, select File, type or choose a file name and location, and click
OK.

6. Now you will load a color infrared (CIR) image. From the Available Bands List, right-click the
file you just created and select Load CIR to <current>. Move the Image box in the Scroll
window to an area in the image.
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7. From the Display group menu bar, select Tools > 3D SurfaceView.

8. Select the newly created DEM Elevation input band and click OK.

9. Accept the default parameters to display the surface by clicking OK.

10. Look for unusual artifacts. Use the Options menu in the 3D SurfaceView window to set options
for viewing the image. If you find areas that you wish to alter, you can use the DEM Editing Tool.

Using the DEM Editing Tool
The DEM Editing Tool, which is a component of the DEM Extraction Module, allows you to
interactively edit pixel values within a region of interest (ROI) using one of seven different methods.

1. From the DEM Extraction Wizard dialog, click Load DEM Result to Display with Editing Tool
to open the DEM in a display group with the DEM Editing Tool available.

2. Move the Image box in the Scroll window to an area in the image.

3. Draw a polygon ROI by clicking the left mouse button in the Image window to establish the first
point of the ROI polygon then selecting further border points in sequence by clicking the left
button again. Close the polygon by clicking the right mouse button.

4. Using the DEM Editing Tool, you can replace the new ROI or the entire DEM with a single
value, a smoothing filter, the mean of the area, and so on. Explore the options available in the
Method drop-down list in the DEM Editing Tool dialog.
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If you are satisfied with your edits, you can save the file with the new values. If you do not like
the effect, you can choose to undo your edits to the DEM.

The DEM Editing Tool can also be used on spectral data to edit pixels in a single band.

5. For this exercise, you do not have to save your edits. Click Cancel.

6. Click Finish, then click No to close the DEM Extraction Wizard without saving your place in the
Wizard.
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Working with the Stereo 3D Measurement Tool
The Stereo 3D Measurement Tool is another tool available with the DEM Extraction Module. This tool
allows you to interactively calculate elevations from stereo images and associated RPC information
given a single tie point.

1. From the ENVI main menu bar, select Topographic > DEM Extraction > Stereo 3D
Measurement.

2. Select the ASTER VNIR Band3N option and click OK.

3. Select the ASTER VNIR Band3B option and click OK.

4. In either the left or right Image window, move the Zoom box over a feature whose 3D
measurement you wish to collect. Using the buttons on the Stereo 3D Measurement Tool dialog,
click Predict Right or Predict Left to have the Zoom box in the second image center on the
conjugate point.

5. Click Get Map Location to compute the Lat/Lon and elevation based on the RPS and selected
points. The regional elevation is estimated from the RPC information, but if you have a more
accurate elevation for the region, then you can enter this value here.

6. You could choose to collect and save these points as an ENVI vector file or as a 3D shapefile
using the Export Location button.

7. Click Cancel to close the Stereo 3D Measurement Tool.
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Working with the Epipolar 3D Cursor Tool
The Epipolar 3D Cursor Tool is another tool available with the DEM Extraction Module. This tool
allows you to perform 3D measurements in a 3D stereo viewing environment based on an existing
epipolar stereo pair of images. You can view an anaglyph of epipolar stereo imagery and adjust the
height of the cursor to extract elevation data. As you view the surface, you can collect points then export
them as points, lines, or polygons to an ASCII file, EVF file, or ArcView 3D Shapefile.

1. From the ENVI main menu bar, select Topographic > DEM Extraction > Epipolar 3D Cursor.

2. Select the Left Epipolar Image option and click OK.

3. Select the Right Epipolar Image option and click OK. The epipolar stereo image opens in a new
display group, with left epipolar image as the red band, and the right epipolar image as the blue
band.

4. The cursor in the Image window is now a double red and blue cursor which, when viewed using
anaglyph red/blue stereo glasses, merges together into a single cursor. You can control the 3D
cursor using specific mouse and keyboard controls.                  

l Use the mouse to move the 3D cursor around the epipolar stereo image.

l Click the left mouse button to snap the 3D cursor to the ground.

l Click the middle mouse button to export the map and elevation for the point to an ENVI
Point Collection table.

l Use the right and left arrow keys on the keyboard to move the 3D cursor one pixel to
the right or left.

l Use the up or down arrow keys on the keyboard to move the 3D cursor one pixel toward
the top or bottom of the image.

l Use the + or - key on the keyboard number pad to raise or lower the apparent elevation
of the 3D cursor. 

5. Once you have explored some of the options available in the Epipolar 3D Cursor Tool, click
Cancel to close the tool.
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