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3D SurfaceView and Fly-Through
This tutorial uses Landsat Thematic Mapper (TM) data to demonstrate ENVI’s 3D SurfaceView and
fly-through capabilities. The 3D SurfaceView function allows you to overlay a gray scale or color-
composite image over a digital elevation model (DEM), interactively change the 3D visualization, and
create a 3D fly-through. The 3D SurfaceView function also provides limited analysis capabilities.

Files Used in this Tutorial
ENVI Resource DVD: Data\bh_3d

File Description

bhtmsat.img (.hdr) Landsat TM saturation-enhanced, RGB composite of Bighorn Basin,
Wyoming

bhdemsub.img (.hdr) USGS DEM at 30 m resolution

bhdemsub.pat Fly-through path file

bhdemsub.ann Fly-through path annotation file

3D Visualization in ENVI
ENVI provides numerous tools for viewing and analyzing image data in two dimensions. The 3D
SurfaceView tool is the first step toward extending data analysis into three dimensions.

The 3D SurfaceView tool allows you to display a DEM as a wire frame, ruled grid or points, or with a
gray scale or color image draped over it. You can rotate, translate, and zoom in or out of the 3D surface
in real-time using the mouse. You can add each 3D view to a list to use later for animation. Use saved
views, or interactively draw a flight path (using ENVI's annotation tool) to fly through the 3D data. You
can set the vertical exaggeration, vertical and horizontal view angles, and altitude. The cursor is linked
to the draped 3D image, allowing you to extract profiles in the X, Y, and Z (spectral) directions. You
can also use the Cursor Location/Value tool in the 3D image.
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Load a 3D SurfaceView
If you are running ENVI on a Windows system, you must set the display to 24-bit color mode before
starting ENVI.

Open and Display Landsat TM Data
1. From the ENVI main menu bar, select File > Open Image File. An Enter Data Filenames dialog

appears.  

2. Navigate to Data\bh_3d and select bhtmsat.img. Click Open. ENVI automatically loads
bands 1, 2, and 3 into a new display group. You can adjust the displayed contrast stretch by
selecting Enhance from the Display group menu bar.

Open and Display DEM as a Gray Scale Image
Displaying the associated DEM is not required, but it is recommended to ensure that you have a matched
DEM/image pair.

1. From the ENVI main menu bar, select File > Open Image File. An Enter Data Filenames dialog
appears.

2. Select bhdemsub.img and click Open. A gray scale image of the Bighorn DEM is
automatically loaded to a new display group.
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Start 3D SurfaceView  
1. From the ENVI main menu bar, select Topographic > 3D SurfaceView. A 3D SurfaceView:

Select Input Display dialog appears.

2. Select Display #1 and click OK. An Associated DEM Input File dialog appears.

3. Select DEM Elevation under bhdemsub.img and click OK. A 3D SurfaceView Input
Parameters dialog appears.

4. Select the desired DEM Resolution (number of pixels) used for the 3D plot. The DEM will be
resampled to the selected resolution. Using higher DEM resolutions will significantly slow the
visualization and should only be used when sufficient computing power is available. You can
select more than one resolution. Typically, you should use the lowest resolution (64) while you are
determining the best flight path. Then, use a higher resolution to display your final fly-through
sequence.

5. In the DEM min plot value field, enter 1219. In the DEM max plot value field, enter 1707. (You
can always experiment with different values later if you find you need to cut out background
pixels or limit the elevation range of the DEM.) DEM values lower than the minimum value and
higher than the max value will not be plotted in the 3D view.

6. Set the Vertical Exaggeration field to 15.

7. Select the Full radio button under Image Resolution. (If you select Other, the image is
resampled to the number of pixels selected for the DEM.)

8. Click OK to start the visualization. A 3D SurfaceView dialog appears with the 3D image. 
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Interactively Control 3D Visualization
1. Click-and-drag the left mouse button in a horizontal direction to rotate the surface around the z-

axis. Click-and-drag in a vertical direction to rotate the surface around the x-axis.

2. Click-and-drag the middle mouse button to translate, or pan, the image in the corresponding
direction.

3. Click-and-drag the right mouse button in a horizontal direction to zoom in or out.

4. Double-clicking on a pixel in the 3D SurfaceView moves the Zoom window to that pixel. Double-
clicking links the 3D cursor location to selected functions that are active in the display group (see
"3D SurfaceView as an Analysis Tool" on page 17 for more information).

5. You can also control the rotation, translation, and zoom factor; and reset the 3D view to its
original position, using the SurfaceView Controls dialog described in the following section.
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3D SurfaceView Controls Dialog
Access the 3D SurfaceView Controls, Position Controls, or Motion Controls dialogs from the Options
menu of the 3D SurfaceView dialog. These dialogs determine how the surface is displayed, how the
perspective is positioned, and how the surface is animated, respectively.

The 3D SurfaceView Controls dialog allows you to make fine adjustments, to edit surface properties,
and to rotate the surface around a perspective view.

Rotation/Scale/Translation Controls
1. From the 3D SurfaceView dialog menu bar, select Options > Surface Controls. The 3D

SurfaceView Controls dialog appears.

2.
Click the buttons to change the rotation of the surface plot in the desired
direction. Use the adjacent Inc field to set the rotation increment.

3. Click the buttons to zoom in or out of the surface plot, respectively. Use the adjacent
Inc field to set the zoom increment.

4. Click the buttons to move (translate) the surface plot in the desired direction. Use
the adjacent Inc field to set the translation increment.

Surface Properties
1. Click the Surface Style drop-down list and select different wireframe options. The figures below

show Wire (upper-left), Ruled XZ (upper-right), Ruled YZ (lower-left), and Points (lower-
right).

2. Experiment with different Vertical Exaggeration values. Higher factors increase the vertical
exaggeration.
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Perspective Controls
This section of the 3D SurfaceView Controls dialog allows you to click a point in the 3D SurfaceView
plot to specify a perspective origin around which the surface is rotated. 

1.
Click the button to toggle the cursor to "select" mode.

2. Move the cursor to the 3D SurfaceView plot and click somewhere in the plot to set the origin of
the rotation. The view zooms to the new origin of the perspective, which is set at a height that is
0.05 normalized units (default) above the surface. Rotation begins.

3. You can modify the height of the perspective origin above the surface using the Translation
controls in the 3D SurfaceView Controls dialog.

4. Click Stop to pause the current rotation. If the cursor is in "select" mode, but you did not choose a
perspective origin, clicking Stop toggles the cursor out of "select" mode.

5. Click Start to start a rotation that was stopped; or, if no perspective rotation was started, to begin
rotating the surface around its center point.

6. Enter the desired value for Rotation Delay, which is the number of seconds to wait between the
successive renderings of the rotating surface. The default value is 0.05. Setting the value to 0.0
sets the rotation speed to your computer's limits for calculating the transformation matrix and
rendering the surface.

7. You can change the direction of the rotation of the surface by clicking Direction and selecting
Left or Right. Direction refers to the rotation direction of the surface, not the viewer's
perspective. 

Other Visualization Controls
1. To change the color of the background in the 3D SurfaceView dialog, select Options > Change

Background Color.

2. To smooth a surface that appears pixelated, select Options > Bilinear Interpolation from the 3D
SurfaceView dialog menu bar. To turn off the smoothing effect, reselect this option.

3. To reset the surface view to the default view, select Options > Reset View from the 3D
SurfaceView dialog menu bar.
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3D SurfaceView Position Controls Dialog
Use this dialog to view the surface panoramically (as if you are standing in the image), thus setting the
view to a specific position and direction.

1. From the 3D SurfaceView dialog menu bar, select Options > Position Controls. The
SurfaceView Position Controls dialog appears.

2. Double-click inside the Display #1 Image window to start the Cursor Location/Value tool. Move
the cursor to a preferred viewing position and note the corresponding pixel or map coordinates.

3. Click the Pixel Coord toggle button to toggle between pixel coordinates and map coordinates.
Enter the coordinates from Step 2 into the Sample/Line or E/N fields. A good starting point is
Sample 3600 and Line 3000.

4. Experiment with different Azimuth, Elevation, and Height Above Ground values to see how
they change the 3D SurfaceView. Start with an Azimuth (look direction) of 90, an Elevation
(look angle) of -90 (looking straight down), and a Height Above Ground of 2000 m. Change the
height from 2000 to 1000 to 500. Click Apply.

5. Use the interactive rotation and zooming to see the 3D SurfaceView from the selected viewpoint. 

10

ENVI Tutorial: 3D SurfaceView and Fly-Through



ENVI Tutorial: 3D SurfaceView and Fly-Through

3D SurfaceView Motion Controls Dialog
ENVI’s 3D SurfaceView function can be used to build an animation sequence or fly-through of the 3D
visualization. Try restoring a previously saved flight path and playing the animation sequence. 

1. From the 3D SurfaceView dialog menu bar, select Options > Motion Controls. The 3D
SurfaceView Motion Controls dialog appears.

2. From the 3D SurfaceView Motion Controls dialog menu bar, select File > Restore Sequence. A
file selection dialog appears.

3. Select bhdemsub.pat and click Open.

4. Set the Frames field to 500 and click Play Sequence. Click Stop Sequence to stop the fly-
through.

Define Flight Path and Begin Flying 
1. Click Clear in the 3D SurfaceView Motion Controls dialog. Use the mouse or arrow buttons (in

the 3D SurfaceView Controls dialog) to select the starting viewpoint, and click Add in the 3D
SurfaceView Motion Controls dialog to add this projection as the starting point of the flight path.

2. Use the mouse or arrow buttons to select another viewpoint, and click Add to add this view to the
flight path. Repeat this step until you have selected as many visualization steps as desired (at
least two are required). When you select the number of frames and play the visualization, the
flight path is smoothly interpolated between the different views. A larger number of frames
results in a smoother flight path, but it slows down the animation.                 

l Select a view number and click Replace to replace a projection in the flight path list.

l Select a view number and click Delete to delete a projection in the flight path list.

l Click Clear to clear the flight path list.
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l From the 3D SurfaceView dialog menu bar, select Options > Animate Sequence to
build a full animation and to control the speed and direction of the fly-through.
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Build a Visualization Sequence Using Annotation
1. From the 3D SurfaceView Motion Controls dialog menu bar, select Options >

Motion:Annotation Flight Path to use a flight path drawn in the display group using ENVI
annotation. An Input Annotation Flight Path dialog appears. You can draw a polyline, polygon,
rectangle, or ellipse annotation object to define the flight path, or use a saved file as input instead.

2. Select the Input Annotation from File radio button and click OK. A file selection dialog
appears.

3. Select bhdemsub.ann and click Open. An Input Annotation Object dialog appears.

4. Select Ann Object #1: Green and click OK. The selected annotation file and number of nodes
are shown in the middle of the 3D SurfaceView Motion Controls dialog, and the flight path is
plotted on the surface in the 3D SurfaceView dialog.

5. In the 3D SurfaceView Motion Controls dialog, keep the number of Frames at 500. To smooth
the flight path using a running average of points along the line, enter a Flight Smooth Factor
value of 1000.

6. Set the Flight Clearance field to 1000.

7. Set the Up/Down field to -60. A vertical look angle of -90 degrees looks straight down at the
surface. A look angle of 0 degrees looks straight ahead (horizontal). Leave the Left/Right look
angle at 0. A horizontal look angle of -90 degrees looks to the left, a look angle of 0 degrees looks
straight ahead, and a look angle of 90 degrees looks to the right.

8. Click Play Sequence to animate the fly-through. Try different values in each of the parameters
and observe the effect they have on the visualization. Also, fly over the surface at a constant
elevation by clicking the toggle button to select Flight Elevation, and enter the desired elevation
above sea level.

9. Select the flight path from a saved annotation file by selecting File > Input Annotation File from
the 3D SurfaceView Motion Controls dialog menu bar. A file selection dialog appears.

10. Select bhdemsub.ann and click OK. An Input Annotation Object dialog appears.

11. Select Ann Object #2: Red and click OK.

12. Set the Frames value to 100.

13. Set the Flight Smooth Factor field to 10000.

14. Set the Flight Clearance field to 1000.

15. Set the Up/Down field to -60, and leave the Left/Right value at 0.

16. Click Play Sequence to animate the fly-through. Try different values in each of the parameters
and observe the effect they have on the visualization.

17. Try creating your own annotation objects and animating the fly-through by selecting Overlay >
Annotation from the Display group menu bar, selecting File > Input Annotation from the
SurfaceView Motion Controls dialog menu bar, and clicking Play Sequence. 
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Animate Sequence
The Animate Sequence option allows you to control the speed and direction of the 3D SurfaceView
animation.

1. Use the same values in Steps 12-15 in "Build a Visualization Sequence Using Annotation" on
page 13 for the ellipse flight path, then select Options > Animate Sequence from the
SurfaceView Motion Controls dialog to load the individual frames into the animation. The 3D
SurfaceView Controls dialog changes to show an interactive tool for controlling the animation:

2. Control the speed of the fly-through by increasing the Speed value. Higher values result in faster
animation.

3. Control the direction of the fly-through by clicking the appropriate button at the bottom of the
dialog:

reverse animation
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forward animation

continuous animation

pause animation

When the animation is paused, click-and-drag the slider to step through the animation one or more
frames at a time.

4. From the Animation Window menu bar, select File > Cancel to return to the 3D SurfaceView
Motion Controls dialog.
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Save Visualizations
The ENVI 3D SurfaceView function also offers several options to save the visualization results and/or
path. Select the following from the SurfaceView Motion Controls dialog:

l Select File > Save Sequence to File from the SurfaceView Motion Controls dialog menu bar to
save the current path to an ENVI path (.pat) file that can be restored to a 3D visualization
session.

l Select File > Restore Sequence Path from File from the SurfaceView Motion Controls dialog
menu bar to restore a saved flight path when the visualization is in the User Defined mode.

l Select File > Input Annotation from Display from the SurfaceView Motion Controls dialog
menu bar to get annotation from the current display group when the visualization is in the
Annotation mode.

l Select File > Input Annotation from File from the SurfaceView Motion Controls dialog menu
bar to get annotation from an ENVI annotation file when the visualization is in the Annotation
mode.

l Select File > Save Surface As > Image File from the 3D SurfaceView menu bar to output the
currently displayed view to an ENVI image.

l Select File > Print from the 3D SurfaceView menu bar to perform direct printing of the currently
displayed view.

l Select File > Save Surface As > VRML from the 3D SurfaceView menu bar to output the 3D
visualization to a VRML file that can be viewed in a web browser.
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3D SurfaceView as an Analysis Tool
ENVI’s 3D SurfaceView tool provides powerful visualization capabilities for viewing images draped on
DEMs. Because of the way you can dynamically link ENVI display groups and dialogs, this function
also allows you to perform DEM analysis using the 3D SurfaceView tool. Analysis tools are described
below.

1. Start the 3D SurfaceView tool and display the desired 3D surface.

2. Cursor Location/Value: Double-click in the Image window to start the Cursor Location/Value
tool. Read the cursor location (pixel and map coordinates) and value by moving the cursor in the
3D SurfaceView window.

3. Spatial and Spectral Pixel Editors: From the Display group menu bar, select Tools > Spatial Pixel
Editor or Tools > Spectral Pixel Editor. Double-click on a pixel in the 3D SurfaceView window
to position the cursor in the ENVI display group to the appropriate location. Edit the desired pixel
values.

4. X and Y Profiles: From the Display group menu bar, select Tools > Profiles > X Profile or Tools
> Profiles > Y Profile. Double-click on a pixel in the 3D SurfaceView window to position the
cursor in the ENVI display group to the appropriate location. The X or Y Profiles are updated to
match the selected cursor location, and the location is marked with a red vertical line in the
selected profile.

5. Z Profile (Spectral Profile): From the Display group menu bar, select Tools > Z Profile or Tools
> Profiles > Additional Z Profile. Double-click on a pixel in the 3D SurfaceView window to
position the cursor in the ENVI display group to the appropriate location. The Z Profile spectrum
is extracted from the data to match the selected cursor location.

6. Spectral Analyst: Display a Z Profile, then select Spectral > Spectral Analyst from the ENVI
main menu bar. A Spectral Analyst Input Spectral Library dialog appears. Open the desired
spectral library by clicking Open > Spectral Library. The Edit Identify Methods Weighting
dialog appears. Click OK. From the Spectral Analyst dialog menu bar, select Options > Auto
Input via Z-Profile to link the Spectral Analyst to a specific spectral profile. Once the Spectral
Analyst is set up, double-click on a pixel in the 3D SurfaceView window to position the cursor in
the ENVI display group to the appropriate location. The Z Profile spectrum is extracted from the
data to match the selected cursor location, and the Spectral Analyst calculates a match to the
library spectrum.

7. When you are finished, select File > Exit from the ENVI main menu bar. 
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